New issue
Advanced search Search tips
Note: Color blocks (like or ) mean that a user may not be available. Tooltip shows the reason.
Starred by 16 users

Issue metadata

Status: Duplicate
Merged: issue 5658
Owner:
Last visit > 30 days ago
Closed: Nov 2016
Cc:
Components:
NextAction: ----
OS: iOS
Pri: 2
Type: Feature



Sign in to add a comment

DSCP support cannot be enabled on iOS

Reported by kape...@gmail.com, Aug 27 2015

Issue description

What steps will reproduce the problem?
1. Create a PeerConnection with the "googDscp" constraint.
2. Observe the debug output and use wireshark to look at the packets

What is the expected result?
DSCP flags should be set, e.g. to DSCP_EF


What do you see instead?
DSCP flags are not set.

What version of the product are you using? On what operating system?
latest git, on iOS (probably windows, too)


Please provide any additional information below.

The method "TranslateOptions" in webrtc/base/physicalsocketserver.cc and webrtc/base/win32socketserver.cc will return -1 for OPT_DSCP, this will prevent DSCP flags to be set.

This is easy to fix (at least for iOS), in physicalsocketserver.cc:

@@ -528,8 +528,9 @@ class PhysicalSocket : public AsyncSocket, public sigslot::has_slots<> {
         *sopt = TCP_NODELAY;
         break;
       case OPT_DSCP:
-        LOG(LS_WARNING) << "Socket::OPT_DSCP not supported.";
-        return -1;
+        *slevel = IPPROTO_IP;
+        *sopt = IP_TOS;
+        break;
       case OPT_RTP_SENDTIME_EXTN_ID:
         return -1;  // No logging is necessary as this not a OS socket option.
       default:




 
Project Member

Comment 1 by braveyao@webrtc.org, Aug 28 2015

Cc: braveyao@webrtc.org
Labels: Area-Network
Owner: pthatcher@webrtc.org
@pthatcher, do you know why we don't support DSCP in socketserver? As I remember we once added DSCP support in Chrome.
Project Member

Comment 2 by pthatcher@webrtc.org, Aug 31 2015

I believe it's because of 

https://code.google.com/p/chromium/issues/detail?id=427627

On older versions of Windows, DSCP was broken.

Should we mark this one a dupe?

Comment 3 by kape...@gmail.com, Aug 31 2015

This issue is about iOS. I only mentioned windows because it caught my eye while i scanned through the sources.
Project Member

Comment 4 by pthatcher@webrtc.org, Aug 31 2015

Cc: tkchin@webrtc.org
Owner: guoweis@webrtc.org
Ah, sorry, I misunderstood.

I don't see a good reason.  If iOS supports DSCP well, I think we should enable it.

Guowei?  Zeke?  Would either of you like to look into this?
Project Member

Comment 5 by pthatcher@webrtc.org, Sep 14 2015

Labels: EngTriaged
Owner: honghaiz@webrtc.org
Project Member

Comment 6 by tnakamura@webrtc.org, Sep 15 2015

Labels: OS-iOS
Adding OS-iOS label per #3.
Project Member

Comment 7 by kjellander@webrtc.org, Sep 15 2015

Labels: -Type-Bug Type-Feature
Status: Assigned
Experiencing this same behavior in Windows as well. Same steps to reproduce

Windows 10 Chrome Version 45.0.2454.99 m
Windows 10 Chrome Version 47.0.2517.0 canary

Comment 9 by rgu...@twilio.com, Nov 3 2015

We are also experiencing the same behavior. Tested on

Windows 10 Chrome Version 46.0.2490.80 m


Any update on this item? We'd really like to see DSCP working consistently in Windows 10. According to https://bugs.chromium.org/p/chromium/issues/detail?id=427627, it looks like it should be working reliably (except possibly in Win7?), but we're not seeing DSCP flags set in our pcaps taken on Win10 tests, even with "googDscp" set. What's the official word on DSCP support in Windows?
Project Member

Comment 11 by honghaiz@webrtc.org, Mar 21 2016

Cc: pthatcher@webrtc.org
CL for IOS/Android/Linux is under review under this issue: 
https://bugs.chromium.org/p/webrtc/issues/detail?id=4951#c10

Will look into this. 
Project Member

Comment 12 by deadbeef@webrtc.org, Nov 12 2016

Mergedinto: 5658
Status: Duplicate (was: Assigned)
Summary: DSCP support cannot be enabled on iOS (was: DSCP support cannot be enabled)
This issue was meant to be about iOS (see comment #3), which is covered by https://bugs.chromium.org/p/webrtc/issues/detail?id=5658.

Let's use https://bugs.chromium.org/p/webrtc/issues/detail?id=5836 to track enabling DSCP for Windows.

Sign in to add a comment