New issue
Advanced search Search tips
Note: Color blocks (like or ) mean that a user may not be available. Tooltip shows the reason.
Starred by 8 users
Status: Duplicate
Owner:
Last visit > 30 days ago
Closed: Aug 2015
Cc:
Components:
NextAction: ----
OS: ----
Pri: 2
Type: Bug



Sign in to add a comment
Implement setConfiguration() (was updateIce)
Project Member Reported by vikasmarwaha@webrtc.org, Oct 29 2014 Back to list
What steps will reproduce the problem?
1. Run apprtc in loopback.
2. Run in console pc.updateICE();
3. Throws DOM exception 12. 

What is the expected result?
It should work. 

What do you see instead?
It throws DOM exception. Discussed with Victoria, the problem seems to be that there are 2 updateICE methods in peerconnection.cc and Chrome is calling the wrong one that returns false. 

 
Comment 1 by vrk@webrtc.org, Nov 24 2014
Labels: EngTriaged Mstone-42
Owner: pthatcher@webrtc.org
Status: Assigned
Summary: Implement setConfiguration() (was updateIce) (was: UpdateICE() JS method throws a DOM exception in chrome 38. )
The spec has changed to setConfiguration, so we should change the implementation to that. Need to support the case of changing from relay -> all.
Project Member Comment 2 by pthatcher@webrtc.org, Feb 19 2015
Labels: -Mstone-42 Mstone-44
This looks like it's not hitting m42.  Update it if I'm wrong.
Project Member Comment 3 by pthatcher@webrtc.org, Aug 31 2015
Mergedinto: 4947
Status: Duplicate
Project Member Comment 4 by kjellander@webrtc.org, Oct 5 2016
Labels: M-44
Sign in to add a comment