New issue
Advanced search Search tips
Note: Color blocks (like or ) mean that a user may not be available. Tooltip shows the reason.
Starred by 4 users

Issue metadata

Status: WontFix
Owner:
Last visit > 30 days ago
Closed: Sep 2017
Cc:
Components:
NextAction: ----
OS: ----
Pri: 3
Type: Bug



Sign in to add a comment

PortTest.TestLocalToTurn is flaky

Project Member Reported by phoglund@webrtc.org, May 9 2014

Issue description

What steps will reproduce the problem?
1. Build and run libjingle_p2p_unittest (this flake was see on Win)

What is the expected result?


What do you see instead?
If flakes: http://chromegw.corp.google.com/i/internal.client.webrtc/builders/Win64%20Debug/builds/1602/steps/libjingle_p2p_unittest/logs/stdio

[ RUN      ] PortTest.TestLocalToTurn
[258:087] Jingle:Port[:1:0:local:Net[unittest:0.0.0.0/32]]: Port created
[258:087] Jingle:Port[:1:0:relay:Net[unittest:0.0.0.0/32]]: Port created
[258:103] Test: udp to turn(udp): 
[258:103] Jingle:Port[:1:0:relay:Net[unittest:0.0.0.0/32]]: Trying to connect to TURN server via udp @ 99.99.99.4:3478
e:\b\build\slave\win\build\src\talk\p2p\base\port_unittest.cc(646): error: Value of: ch2.complete_count()
  Actual: 0
Expected: 1
[  FAILED  ] PortTest.TestLocalToTurn (1030 ms)

Please use labels and text to provide additional information.

 
Project Member

Comment 1 by phoglund@webrtc.org, May 9 2014

Labels: Breaks-Bot
Project Member

Comment 2 by phoglund@webrtc.org, May 27 2014

Owner: ----
Status: Available

Comment 3 by vrk@webrtc.org, Oct 14 2014

Labels: Area-Network

Comment 4 by vrk@webrtc.org, Nov 3 2014

Labels: EngTriaged Mstone-42
Owner: pthatcher@google.com
Status: Assigned
Project Member

Comment 5 by pthatcher@webrtc.org, Feb 19 2015

Labels: -Mstone-42 Mstone-44
This looks like it's not hitting m42.  Update it if I'm wrong.
Project Member

Comment 6 by tnakamura@webrtc.org, Feb 1 2016

Labels: -Mstone-44 Hotlist-Testing
I don't see any recent CLs linked to this bug, so I don't think it's been fixed. I'm therefore leaving this in an open state, but I am removing the milestone label since this bug hasn't been updated in quite some time.
Project Member

Comment 7 by pthatcher@webrtc.org, Nov 8 2016

Labels: Pri-3
Project Member

Comment 8 by anatolid@webrtc.org, Sep 4 2017

Is this still valid? Looks like a candidate for archiving.
Project Member

Comment 9 by phoglund@webrtc.org, Sep 4 2017

Status: WontFix (was: Assigned)
Yeah, looks like this isn't getting fixed and hopefully it's obsolete anyway :)

Sign in to add a comment