New issue
Advanced search Search tips
Starred by 20 users

Issue metadata

Status: WontFix
Owner:
Closed: Nov 2017
Cc:
Components:
NextAction: ----
OS: Mac
Pri: 2
Type: Bug
Mic



Sign in to add a comment

audio_device.h InitPlayout() and InitRecording() not working on Mac.

Project Member Reported by kjellander@webrtc.org, Mar 6 2012

Issue description

What steps will reproduce the problem?
1. Sync WebRTC r1843 on a Mac.
2. Compile and run audio_device_test_api

What is the expected output? What do you see instead?
You will get errors caused by InitPlayout() and InitRecording() failing the tests.

Please use labels and text to provide additional information.
In the CL http://webrtc-codereview.appspot.com/437002/ I refactored and updated this test so it was possible to run it at Mac (not previously working). 
In the test audio_device_test_api.cc there are some places where InitPlayout() and InitRecording() is not working on Mac while they execute as expected on Linux and Windows.  
I decided to exclude these tests using #if !defined(WEBRTC_MAC) macros that should be removed when this issue is fixed. 

 
Project Member

Comment 1 by alberto@google.com, Mar 8 2012

Labels: -Type-Defect -Priority-Medium Type-Bug Pri-2
Status: Assigned
Project Member

Comment 2 by alberto@google.com, Mar 8 2012

Labels: -OpSys-OSX OS-Mac
Project Member

Comment 3 by kjellander@webrtc.org, May 14 2012

Labels: Hotlist-Testing

Comment 4 by vrk@webrtc.org, Sep 29 2014

Labels: Area-PeerConnection

Comment 5 by vrk@webrtc.org, Oct 28 2014

Cc: xians@webrtc.org tommi@webrtc.org
Labels: -Area-PeerConnection Area-Mic Area-Render IceBox EngTriaged
Owner: kjellander@webrtc.org
Hey Henrik, we're going through some ancient bugs. Is this still broken and if so, who is the best owner?
Project Member

Comment 6 by kjellander@webrtc.org, Oct 28 2014

Cc: -xians@webrtc.org
Owner: xians@webrtc.org
Not really, I just digged into this old test a long time ago to make it possible to run it on Mac. I don't know the code and I don't know how much we should work on this test. Today it (audio_device_tests) only runs on Windows and Mac, not Linux.
Project Member

Comment 7 by juberti@webrtc.org, Jan 7 2015

Labels: -Area-Mic Area-GetUserMedia-Mic
Project Member

Comment 8 by juberti@webrtc.org, Jan 7 2015

Labels: -Area-GetUserMedia-Mic Mic
Project Member

Comment 9 by kjellander@webrtc.org, Dec 1 2016

Cc: -tommi@webrtc.org
Owner: ----
Status: Available (was: Assigned)
I was surprised to see xians@webrtc.org still owning issues in the tracker. Cleaning up...
Project Member

Comment 10 by mflodman@webrtc.org, Aug 4 2017

Components: -Render Audio
"Render" component is being removed -> moving this to "Audio", as agreed.
Project Member

Comment 11 by henrik.lundin@webrtc.org, Aug 10 2017

Owner: solenberg@webrtc.org
Project Member

Comment 12 by solenberg@webrtc.org, Aug 22 2017

Owner: henrika@webrtc.org
I believe you were working to replace this test?
Project Member

Comment 13 by henrika@webrtc.org, Aug 22 2017

Correct. It shall be removed. We use a more "higher level" ADM test now and there is no longer any use for test which verifies all the fine details in the existing API.
Project Member

Comment 14 by henrika@webrtc.org, Nov 6 2017

Status: WontFix (was: Available)
Closing really old issue. The reported test is no longer used.

Sign in to add a comment