New issue
Advanced search Search tips
Note: Color blocks (like or ) mean that a user may not be available. Tooltip shows the reason.

Issue 1979 link

Starred by 24 users

Issue metadata

Status: Assigned
Owner:
Cc:
Components:
NextAction: ----
OS: ----
Pri: 2
Type: Bug



Sign in to add a comment

WebRTC shouldn't use built-in laptop cameras when the lid is closed

Reported by juberti@google.com, Jun 26 2013

Issue description

When enumerating cameras, we can determine whether the camera is "suspended" on at least some OSes. We should mark cameras accordingly in the return from getSources, and perhaps also avoid picking suspended cameras in GetUserMedia.
 
Project Member

Comment 1 by tnakamura@webrtc.org, May 16 2014

Owner: ----
Status: Available
Project Member

Comment 2 by tnakamura@webrtc.org, May 16 2014

Cc: tommyw@webrtc.org

Comment 3 by juberti@google.com, Oct 17 2014

Cc: -tommyw@webrtc.org tommi@webrtc.org
Owner: tnakamura@webrtc.org
I think this has been fixed, at least on Mac. Ted, can you verify with AVFoundation and QTKit on Mac?

Tommi, is there any signal for this on Windows?
Project Member

Comment 4 by tommi@webrtc.org, Apr 20 2015

Cc: tnakamura@webrtc.org
Labels: EngTriaged
Owner: jansson@webrtc.org
Chris - can you check Windows?
Project Member

Comment 5 by jansson@webrtc.org, Apr 20 2015

Owner: ----
Camera is still available when the lid is shut on my Lenovo X230 running Win 8.1 indicating lack of a signal. It even turns on when lid is closed (leave a 1 cm gap (possible on the aforementioned lenovo laptop) and shine some light between the keyboard and lid).
Project Member

Comment 6 by tommi@webrtc.org, Apr 20 2015

Owner: hbos@webrtc.org
Henrik - can you take a look at this?
Project Member

Comment 7 by sheriffbot@chromium.org, Dec 12 2016

Labels: Hotlist-Recharge-Cold
Status: Untriaged (was: Available)
This issue has been available for more than 365 days, and should be re-evaluated. Please re-triage this issue.
The Hotlist-Recharge-Cold label is applied for tracking purposes, and should not be removed after re-triaging the issue.


Project Member

Comment 8 by anatolid@chromium.org, Dec 15 2016

Cc: hbos@webrtc.org
Owner: ----

Comment 9 Deleted

Project Member

Comment 10 by guidou@webrtc.org, Aug 25 2017

Components: -GetUserMedia Webcam
Not sure if this refers to WebRTC video capture code or what is used by the getUserMedia Web API in Chrome. If the latter, this should be a Chrome bug.

In the meantime, changing components since either way it's not about the gUM Web API.
Project Member

Comment 11 by anatolid@webrtc.org, Oct 12 2017

Ping for triaging.
Project Member

Comment 12 by tommi@webrtc.org, Oct 12 2017

Owner: niklas.enbom@webrtc.org
Status: Assigned (was: Untriaged)
I'm *guessing* that the reason the bug is still open, is because it's in the webrtc tracker and not Chromium.

Niklas - do you know?
Nope I dony

Sign in to add a comment