New issue
Advanced search Search tips
Starred by 14 users
Status: Fixed
Owner:
Closed: Nov 27
Cc:
Components:
NextAction: ----
OS: ----
Pri: 2
Type: Bug



Sign in to add a comment
Make sure MediaStreamTrack::readyState is set to ended when a USB camera is unplugged on Windows
Project Member Reported by perkj@webrtc.org, Apr 24 2013 Back to list
Also See  issue 960 .

What steps will reproduce the problem?
1. goto apprtc.appspot.com
2. unplug the camera
3. check that the ready state of the local track has changed to ended.

What is the expected result?


What do you see instead?


Please use labels and text to provide additional information.

 
Project Member Comment 1 by perkj@webrtc.org, Apr 24 2013
Labels: Area-GetUserMedia
Project Member Comment 2 by tommi@webrtc.org, Apr 20 2015
Cc: tommi@webrtc.org
Labels: EngTriaged
Owner: magjed@webrtc.org
Magnus - can you take a look at this?
If this was fixed, we could discover when somebody unplugs a camera and plugs it in again and re-start a previous stream. It's really annoying to have to check frequently whether a device has been removed just to reset a broken stream. This is clearly specified in the spec and should work: https://www.w3.org/TR/mediacapture-streams/#idl-def-MediaStreamTrackState.ended
Project Member Comment 4 by hbos@webrtc.org, Jul 20 2016
Cc: magjed@webrtc.org hbos@webrtc.org
 Issue 1685  has been merged into this issue.
Project Member Comment 5 by tommi@webrtc.org, Nov 27
Status: Fixed
Closing stale bugs. Please ping back if this is still an issue.
Sign in to add a comment