New issue
Advanced search Search tips
Starred by 1 user

Issue metadata

Status: Duplicate
Merged: issue chromium:604033
Owner: ----
Closed: Jun 2016
HW: ----
NextAction: ----
OS: ----
Priority: 2
Type: Bug



Sign in to add a comment
link

Issue 5146: typeof null === "undefined" is sometimes true

Reported by evgenyor...@gmail.com, Jun 23 2016

Issue description

Version: 5.1.281.65
OS: Linux
Architecture: x64

What steps will reproduce the problem?
for (let n = 0; n < 10000; n++) {
    console.log(typeof null === "undefined");
}

What is the expected output?
It should print "false" 10000 times.

What do you see instead?
It prints "false" 4917 times and "true" 5083 times.

There is no such problem if I use var instead of let.
 
2016-06-23-153445_1920x1080_scrot.png
18.6 KB View Download

Comment 1 by pawelmar...@gmail.com, Jun 23 2016

Confirmed. 

Version: 5.1.281.65
OS: Windows
Architecture: x64

Comment 2 by cbruni@chromium.org, Jun 23 2016

Status: Fixed (was: Untriaged)
this is a duplicate of crbug/604033

Comment 3 by adamk@chromium.org, Jun 23 2016

Mergedinto: chromium:604033
Status: Duplicate (was: Fixed)

Comment 4 by hablich@chromium.org, Mar 23 2017

Labels: Priority-2

Sign in to add a comment