New issue
Advanced search Search tips
Starred by 3 users

Issue metadata

Status: WontFix
Owner:
Closed: Aug 2017
Cc:
Area: ----
Priority: Medium
Type: Defect



Sign in to add a comment

GM crashing on matriximagefilter on Mac 10.6

Project Member Reported by senorblanco@chromium.org, Mar 25 2014

Issue description

The matriximagefilter is causing the gm binary to crash on Mac 10.6, for unknown reasons. (Unfortunately, the bot gives us no stack trace.)
 
Project Member

Comment 1 by mtkl...@google.com, Mar 25 2014

Interested to see how this plays out.  Just coincidentally we've been thinking about reducing 10.6 test capacity and to drop this compiler, and I'd been thinking it was a safe thing to do.  Depending on how this settles, I may not be right.  (GASP!)

https://code.google.com/p/skia/issues/detail?id=2337
Project Member

Comment 2 by mtkl...@google.com, Mar 26 2014

Using Apple's GCC 4.2 on my 10.9 laptop, I cannot reproduce this problem.  I flipped the #if to 1 in the new GM and tried running it two ways:
  - out/Debug/dm --match matriximagefilter passes with no problems.
  - I had difficultly compiling gm/system_preferences_mac.mm, but hacking around that, out/Debug/gm --match matriximagefilter also passes with no problems.
Project Member

Comment 3 by senorblanco@chromium.org, Mar 26 2014

Did you try running all the samples, with the same args as the bots? It could be a cumulative problem of some kind.

Or could it could be specific to 10.6, although that would be surprising. It would be great to log into the bot and run it there to catch a stack trace, if possible.
Project Member

Comment 4 by mtkl...@google.com, Mar 26 2014

I ran GM again with the bot's flags.  Still no failures.

I also ran DM again in its default thorough mode.   When using this compiler, but not when using Clang, some unit tests and benches segfault inside GrMemoryPool.  Probably something unrelated.

If I were you I'd talk with Eric about how to play around on the bots without messing up the build slaves.  You can probably just run GM in GDB?
Project Member

Comment 5 by hcm@google.com, Dec 7 2015

Labels: Hotlist-Fixit
Project Member

Comment 6 by senorblanco@chromium.org, Aug 24 2017

Status: WontFix (was: Accepted)
I don't think we're going to make any further progress here, and 10.6 is pretty ancient at this point.

Sign in to add a comment