New issue
Advanced search Search tips
Starred by 6 users

Issue metadata

Status: Invalid
Owner: ----
Closed: Feb 2013
Components:
EstimatedDays: ----
NextAction: ----
OS: ----
Pri: 2
Type: Bug



Sign in to add a comment

@font-face doesn't work when printing and in print prewiew

Reported by meir.tol...@gmail.com, Sep 26 2011 Back to list

Issue description

Chrome Version       : <Copy from: 'about:version'>
URLs (if applicable) :
Other browsers tested:
Add OK or FAIL after other browsers where you have tested this issue:
Safari 5:
Firefox 4.x:
IE 7/8/9:

What steps will reproduce the problem?
1.
2.
3.

What is the expected result?


What happens instead?


Please provide any additional information below. Attach a screenshot if
possible.

 
Labels: Action-FeedbackNeeded
Please attach a sample file that doesn't print / preview properly.

Comment 2 by tkent@chromium.org, Sep 27 2011

Labels: -Area-Undefined Area-WebKit WebKit-WebFonts
most of problem I found was with html I create. The render seems to work well but the print preview and the printed page has a problem.

The problem can be seen in some <p> from http://css-tricks.com/7405-adding-stroke-to-web-text/

Seems to work ok here. Can you print the webpage to PDF in Google Chrome and in another browser to illustrate the difference? Attach the PDFs here.

Comment 5 by Deleted ...@, Dec 1 2011

I have the same issue.

Reliably reproduced by:
1. Open http://www.typetester.org/
2. Pick a google web font Lobster is good as it is quite different).
3. Print the page.

Safari works fine and the fonts are properly printed, but Chrome (15.0.8) uses a standard font.

Setup:
Chrome 15.0.8
Safari 5
Windows 7 Enterprise x64

Comment 6 by adee...@gmail.com, Aug 16 2012

There is something in this bug. Woff stopped working for me even though I was returning the correct headers. I had to use TTF to get it to work.

Comment 7 by laforge@google.com, Oct 22 2012

Status: Invalid
Using the repro steps described in comment #5, I don't see the issue on the latest M23 Beta release.  I'm guessing that this was a legitimate issue that has since been fixed.  If this is still an issue, please open up a new bug.
Project Member

Comment 8 by bugdroid1@chromium.org, Mar 9 2013

Labels: -Action-FeedbackNeeded Needs-Feedback
Project Member

Comment 9 by bugdroid1@chromium.org, Mar 11 2013

Labels: -Area-WebKit -WebKit-WebFonts Cr-Content Cr-Content-WebFonts
Project Member

Comment 10 by bugdroid1@chromium.org, Apr 6 2013

Labels: -Cr-Content Cr-Blink
Project Member

Comment 11 by bugdroid1@chromium.org, Apr 6 2013

Labels: -Cr-Content-WebFonts Cr-Blink-WebFonts

Comment 12 by Deleted ...@, Apr 9 2013

When I first load it's OK. After reloading the page (F5 or Ctrl + F5) the problem occurs again.
1. Open this pen: http://codepen.io/TiGR/pen/eJRjYQ
2. Open Chrome Inspector, disable cache.
3. Reload page.
4. Try to print it.

You supposed to see 2 lines on print. But you'll see only one in Google Chrome. If you close preview dialog, and then reopen it, you'll see both lines.
(#13 tarasov....@gmail.com
1. Open this pen: http://codepen.io/TiGR/pen/eJRjYQ
2. Open Chrome Inspector, disable cache.
3. Reload page.
4. Try to print it.

You supposed to see 2 lines on print. But you'll see only one in Google Chrome. If you close preview dialog, and then reopen it, you'll see both lines.)
_____________________________________________________________________________________________________________________________________________________________
Yes, This is happening exactly described above, I had to use standard font for Print CSS in some cases then It's working fine.
I didn't test any other browsers.

Sign in to add a comment