New issue
Advanced search Search tips

Issue 95157 link

Starred by 10 users

Issue metadata

Status: Duplicate
Owner:
Closed: Nov 2011
EstimatedDays: ----
NextAction: ----
OS: Linux
Pri: 2
Type: Compat

Restricted
  • Only users with Commit permission may comment.



Sign in to add a comment

Some text is overlapping

Reported by takayosh...@gmail.com, Sep 2 2011

Issue description

Chrome Version       : 15.0.865.0
OS Version: Linux Ubuntu 10.04 LTS
URLs (if applicable) : http://blogs.adobe.com/typblography/2011/09/postscript-comes-to-typekit.html
Other browsers tested: Chrome Dev channel on OSX 10.6: OK
  Add OK or FAIL after other browsers where you have tested this issue:
     Safari 5:
  Firefox 4.x:
     IE 7/8/9:

What steps will reproduce the problem?

1. Visit the site

What is the expected result?

On OSX the rendering is done as expected [screenshot-mac.png]

What happens instead?

On Linux some text (blue anchor text) overlaps text before and after.
Some regular text is also overflowing to the right.
See attached image [screenshot-linux.png].


Please provide any additional information below. Attach a screenshot if
possible.

UserAgentString: Mozilla/5.0 (X11; Linux x86_64) AppleWebKit/535.2 (KHTML, like Gecko) Chrome/15.0.865.0 Safari/535.2



 
screenshot-mac.png
215 KB View Download
screenshot-linux.png
122 KB View Download

Comment 1 Deleted

Comment 2 Deleted

Comment 3 by bashi@chromium.org, Sep 2 2011

Owner: bashi@chromium.org

Comment 4 Deleted

Please test again with the latest version, which is 15.0.869.0

Comment 6 by kochi@chromium.org, Sep 5 2011

> #5

What is the supposed fix for this between 15.0.865 and 15.0.869?
Labels: Action-FeedbackNeeded
Works fine on 15.0.874.1 - Ubuntu 10.04 LTS
Status: Untriaged
Works fine in Linux Ubuntu 10.04 . Build 15.0.874.5 (Official Build 100117) dev

Comment 9 by kochi@chromium.org, Sep 14 2011

Status: Available
I can still reproduce this on my 15.0.874.5 / Ubuntu 10.04.

The font seems dynamically loaded (using webfont), and during the page (font?) load
the page has overlapping text.
Once the whole page (or font?) load is complete, sometimes the re-layout is performed
and all the text is displayed properly, but sometimes it won't.

If the page has overlapping text, window resizing won't fix the overlap, but
I have always succeeded to relayout without overlap by opening developer tools
(right click -> inspect element)

Comment 10 by bashi@chromium.org, Sep 16 2011

I couldn't reproduce on my Linux box with 15.0.865.0.. Have you installed fonts which are used on the page (e.g. adobe-clean-1, adobe-clean-2, Myriad or Mriad Pro) in your machine? What font are you using for "sans-serif" generic font name?
Labels: -Area-Undefined Area-Compat
I also have this bug on Chromium 15.0.865.0 and 15.0.871.0 / Ubuntu 11.04
screenshot1.png
184 KB View Download
Same bug seen here. I think it has been present for several weeks now.

I noted that if I clicked inspect element - then the page re-rendered, the kerning was slightly wider and the text did not over-spill to the right of the white background. i.e. it rendered perfectly.

Deatils:
  Ubuntu 11.04, Chrome 15.0.874.92beta
  Page zoom 100%, font size medium
  Standard => Times New Roman:16
  Serif => Times New Roman:16
  Sans => Arial:16
  Fixed => Courier New

Comment 14 by Deleted ...@, Nov 14 2011

This bug occurs in my personal blog too. If I reload the page sometimes the font rendering is performed well. It is a bit frustrating.

Using: Chrome 15.0.874.106 (Developer Build 107270 Linux) Ubuntu 10.04


http://dev.monsterzen.com
screenshot.png
143 KB View Download

Comment 15 by bashi@chromium.org, Nov 18 2011

Mergedinto: 66073
Status: Duplicate
Looks like the root cause is the same of issue 66073. I didn't see these overlaps with my custom build which disable using FT_Get_Advance().

Comment 16 Deleted

Project Member

Comment 17 by bugdroid1@chromium.org, Oct 13 2012

Labels: Restrict-AddIssueComment-Commit
Mergedinto: chromium:66073
This issue has been closed for some time. No one will pay attention to new comments.
If you are seeing this bug or have new data, please click New Issue to start a new bug.
Project Member

Comment 18 by bugdroid1@chromium.org, Mar 9 2013

Labels: -Action-FeedbackNeeded Needs-Feedback
Project Member

Comment 19 by bugdroid1@chromium.org, Mar 10 2013

Labels: -Area-Compat -Type-Bug Type-Compat

Sign in to add a comment