New issue
Advanced search Search tips
Starred by 3 users

Issue metadata

Status: Started
Owner:
Cc:
Components:
EstimatedDays: ----
NextAction: ----
OS: Mac
Pri: 2
Type: Bug-Regression
Team-Accessibility



Sign in to add a comment
link

Issue 913503: Back, forward, reload UI controls not visible

Reported by pe...@schussheim.com, Dec 10

Issue description

UserAgent: Mozilla/5.0 (Macintosh; Intel Mac OS X 10_14_1) AppleWebKit/537.36 (KHTML, like Gecko) Chrome/73.0.3636.0 Safari/537.36

Steps to reproduce the problem:
1. Open Chrome Canary 
2. Load https://chromiumbugs.appspot.com
3. notice back, forward, reload controls on top left of UI are not visible.  Hover makes them visible only on hover.

What is the expected behavior?
These controls should always be visible.

What went wrong?
back, forward, reload controls on top left of UI are not visible.  Hover makes them visible only on hover.

Did this work before? Yes 

Chrome version: 73.0.3636.0  Channel: canary
OS Version: OS X 10.14.1
Flash Version:
 
Google Chrome047.png
252 KB View Download

Comment 1 by meh...@chromium.org, Dec 10

Cc: ellyjo...@chromium.org
Components: -UI UI>Browser
Is this an installed Theme from the Web Store you are using or the macOS Reduce Contrast Mode?

Comment 2 by pe...@schussheim.com, Dec 10

Hi Elly,

I do not have any Web Store themes installed and do not have a reduced contrast setting enabled.  I do have INCREASED contrast enabled in macOS as shown in attached screenshot.

Thanks
System Preferences001.png
405 KB View Download

Comment 3 by meh...@chromium.org, Dec 10

Components: UI>Accessibility
Thanks for your feedback. Yes, I can reproduce it.

This issue happens with the combination of System DarkMode and System IncreaseContrastMode.
Bildschirmfoto 2018-12-10 um 19.00.29.png
135 KB View Download

Comment 4 by meh...@chromium.org, Dec 10

Status: Untriaged (was: Unconfirmed)

Comment 5 by ellyjo...@chromium.org, Dec 11

Labels: Proj-MacMojave
Owner: lgrey@chromium.org
Status: Assigned (was: Untriaged)
Over to lgrey@, who is working on dark mode.

Comment 6 by lgrey@chromium.org, Dec 12

Status: Started (was: Assigned)

Comment 7 by bugdroid1@chromium.org, Dec 14

Project Member
The following revision refers to this bug:
  https://chromium.googlesource.com/chromium/src.git/+/0da801c32687733e8d0e043e42f621abac157df6

commit 0da801c32687733e8d0e043e42f621abac157df6
Author: Leonard Grey <lgrey@chromium.org>
Date: Fri Dec 14 15:07:25 2018

Mac: Don't explicitly set high contrast appearances when forcing appearance

Despite these being perfectly kosher appearance names, the system returns
nil when you set them, which inadvertently turns on dark mode for high
contrast users if their system is in Mojave dark mode.

Since most of our high contrast interventions are at the views level,
regular Aqua appearance will do temporarily.

Bug: 913503
Change-Id: I13238eac68d2dfa4a0d4c828bdd3e98d37d0505a
Reviewed-on: https://chromium-review.googlesource.com/c/1374437
Reviewed-by: Elly Fong-Jones <ellyjones@chromium.org>
Reviewed-by: Peter Kasting <pkasting@chromium.org>
Commit-Queue: Leonard Grey <lgrey@chromium.org>
Cr-Commit-Position: refs/heads/master@{#616673}
[modify] https://crrev.com/0da801c32687733e8d0e043e42f621abac157df6/base/mac/sdk_forward_declarations.h
[modify] https://crrev.com/0da801c32687733e8d0e043e42f621abac157df6/base/mac/sdk_forward_declarations.mm
[modify] https://crrev.com/0da801c32687733e8d0e043e42f621abac157df6/ui/native_theme/native_theme_mac.mm

Comment 8 by meh...@chromium.org, Jan 2

Hey lgrey, thanks for your CL. This seems to be fixed in latest Canary with System DarkMode and System IncreaseContrastMode now.

But I noticed, that when you additionally start Chrome in Dark Mode vis --force-dark-mode this seems still to be an issue.

Please let me know, if I should file a separate "Dark Mode" report for this.

Thanks.

Comment 9 by lgrey@chromium.org, Jan 2

I haven't had a chance to address high contrast dark mode yet (I'm assuming this is true for --enable-features=DarkMode with the system set to dark too?)

Comment 10 by meh...@chromium.org, Jan 2

Yes, the same with --enable-features=DarkMode and with the system set to dark.

Sign in to add a comment