New issue
Advanced search Search tips
Note: Color blocks (like or ) mean that a user may not be available. Tooltip shows the reason.

Issue 90856 link

Starred by 32 users

Issue metadata

Status: Duplicate
Merged: issue 113041
Owner:
Closed: Dec 2012
Cc:
Components:
EstimatedDays: ----
NextAction: ----
OS: Android
Pri: 2
Type: Feature

Blocked on:
issue 161303

Blocking:
issue 152934



Sign in to add a comment

Reliable viewport control API for mobile devices

Project Member Reported by smus@chromium.org, Jul 28 2011

Issue description

Games and multimedia apps often need a full screen experience on mobile devices. 

This includes:
- switching to the native device resolution
- maximizing the browser viewport
- hiding browser chrome (url bar, tabs, etc)

This can currently be achieved with meta viewport tags and scroll hacks, but not reliably.
 

Comment 1 by thakis@chromium.org, Jul 28 2011

Is this is a dupe of  issue 16735 ?

Comment 2 by smus@chromium.org, Jul 28 2011

I don't think so. This is tracking full screen APIs on mobile devices.  crbug.com/16735  seems to be video specific.

Comment 3 by thakis@chromium.org, Jul 28 2011

I don't think it's terribly useful to file many bugs targeted at mobile devices at this point. The mobile ports of chrome are all in feature freeze trying to get ready for public launch. (And nobody of the cc'd folks has seen our mobile codebases. But that can of course change.)
Labels: -private OS-Android
Labels: GamesRoadmapped

Comment 6 Deleted

from smus@
Full-screen mode exists in Chrome for Android. It's useful for explicitly zooming into particular parts of the page (eg. a video): http://html5-demos.appspot.com/static/fullscreen.html

However, developers expect this feature to hide the omnibox (which we don't currently do). Also, there's no way to get out of full screen mode unless there's an explicit button for this implemented (in Chrome desktop, you can exit via the Escape key.


-----

Full full screen support is something we want to explore but won't be in the near term. In the interim, it may be better to just disable support for the fullscreen API. 

Comment 8 by adman....@gmail.com, Mar 10 2012

Comment #7 was also reported in  issue 113128  by me, perhaps blocking or merge into this bug?
 Issue 113128  has been merged into this issue.
I own Galaxy Nexus. I would like to have full screen for chrome. In full screen mode it should hide 'omni box' as well as main android navigation buttons (home, back and menu) to take full screen available. These 'omni box' and main navigation buttons can popup when I scroll. This would make quite good space for displaying web page.
Samsung Galaxy S2 with Android 4.0.3 here (and a few other phones with the same Android version).
Cannot enter and exit programmatically (javascript) from fullscreen when playing video.
See http://stackoverflow.com/questions/10724897/html5-video-on-android-4-play-fullscreen-then-redirect-to-another-webpage-not

Please give us back soon at least the fullscreen functions of Android 2.3

Labels: Mstone-22

Comment 13 by qinmin@google.com, Jun 18 2012

Regarding comment 11, where WebkitEnterFullscreen() and video.play() is not working after hitting the poster, I cannot reproduce the bug on 4.0.4 galaxy nexus with both android browser and chrome beta.
Could there be a problem with your video file.
Labels: -Mstone-22 Mstone-23
Blockedon: -chromium:113041 chromium:113041
Labels: Feature-OSIntegration
Labels: WebKit-WebApps

Comment 17 by vinodkr@google.com, Sep 10 2012

Labels: -Mstone-23 Mstone-24
Labels: -Feature-OSIntegration Feature-FullScreen
Approach and design is also blocked on  crbug.com/113041  - which is for how we will support full screen on user initiated gestures.
Cc: koz@chromium.org yzshen@chromium.org jeremya@chromium.org
 Issue 153417  has been merged into this issue.
Blocking: chromium:152934
Cc: -jeremya@chromium.org
Labels: -Mstone-24 MovedFrom-Mstone-18
 Issue 161108  has been merged into this issue.
Labels: -MovedFrom-Mstone-18
Blockedon: -chromium:113041 chromium:161303
Cc: felipeg@chromium.org

Comment 28 by vli@chromium.org, Nov 26 2012

Labels: ImportanForMobile

Comment 29 by vli@chromium.org, Nov 26 2012

Labels: -ImportanForMobile ImportantForMobile
Owner: tedc...@chromium.org
Status: Assigned
Mergedinto: 113041
Status: Duplicate
Merging this in with  Issue 113041  which is also asking for UI & API support for fullscreen mode (and has more stars - so is a better one to merge into).
Project Member

Comment 32 by bugdroid1@chromium.org, Mar 11 2013

Labels: -Area-WebKit -Feature-FullScreen -WebKit-WebApps Cr-Content Cr-UI-Browser-FullScreen Cr-Content-WebApps
Project Member

Comment 33 by bugdroid1@chromium.org, Apr 6 2013

Labels: -Cr-Content Cr-Blink

Sign in to add a comment