Project: chromium Issues People Development process History Sign in
New issue
Advanced search Search tips
Note: Color blocks (like or ) mean that a user may not be available. Tooltip shows the reason.
Starred by 241 users
Status: Duplicate
Owner: ----
Closed: Nov 2009
Cc:
Components:
EstimatedDays: ----
NextAction: ----
OS: All
Pri: 2
Type: Feature

Restricted
  • Only users with Commit permission may comment.



Sign in to add a comment
Enable downloads to a temporary location (view vs. save)
Project Member Reported by nickbaum@chromium.org, Mar 19 2009 Back to list
Change download section of options to:

--

() Download to a folder [C://...][Browse]
    [] ask where to save each time
() Download to a temporary location

--

When the second radio button is selected, download files to a hidden temp 
folder that eventually gets cleaned up by the OS (we should not implement 
this logic if we can avoid it). The "Show in folder" option in the shelf 
menu should be replaced with "Save file as..."

Regardless of which radio button is selected, all downloads should still 
appear on the downloads page.
 
Might want to make that second button something akin to "open"?

Might want the ability to control this on a per-filetype basis a la Firefox?
Comment 2 by darin@chromium.org, Mar 22 2009
Just please don't make the mistake that Firefox makes of deleting temp files on 
shutdown.  Nothing more aggravating than having the file deleted out from under you 
just because you closed the fox :-/
Labels: -Pri-3 -ui-fixit Pri-2 fixit Mstone-2.1
Peter: I think per-filetype is overkill in this case, especially since you can always 
save through the menu.

Darin: We should not deal with the deleting, we should let the OS do that. If we have 
to, we can use max(shutdown, one week) or something like that.
Status: Assigned
Comment 5 by darin@chromium.org, Apr 6 2009
Nick: The fundamental problem is that Windows doesn't have a /tmp folder that gets 
cleaned up periodically by the system.  If we put things in the Windows temp folder, 
then eventually we'll clog the users disk, and bad times will ensue.  So, we can't 
leave it up to the system it seems.  If we have to manage this ourselves, then we end 
up fighting with the user since they might not expect their files to magically 
disappear after a week or whatever timeout we pick.  I wonder what IE does...
Comment 6 by dhh...@gmail.com, Apr 6 2009
Hi Darin, that is the wrong thinking.  You say "users might not expect their files to 
magically disappear" but in fact the opposite is true: they *do* expect this.

Specifically, this bug is going about this all the wrong way.  Peter's comment 1 is 
essentially correct.  This is effectively an "open" [right away] option, and the 
opened content is _only available for the time that it remains open_.  Once it is 
closed, the user views the file as *gone*.  Whether or not a copy may actually still 
exist in the Windows %TEMP% directory is a technical/implementation detail, but again   
a file that was "opened" is considered *gone* after closing.

And definitely such "opened" files absolutely should *not* be listed in the Downloads 
page because they are not considered as having been downloaded but rather just 
"opened".  There is also no need for a "Save file" button on the download shelf as 
the "opened" file will *not* show any entry on the download shelf.

This issue is a duplicate of Issue 333, or I guess what I'm saying is that Issue 333 
is much more important and Issue 333 must be implemented first.
Darin, my understanding is that lots of programs use temporary directories, and that
the system will prompt users to clean those up if it runs out of space. I might be
mistaken though.

Otherwise, I think a simple algorithm like "delete if older than a week and not
currently open" would be fine. I'd prefer to not have to implement this though.

Dhhwai, we don't want the user to have to make a choice each time they download a
file. Right now, [download] is the default action. The point of this feature request
is to allow the user to [open] by default, and [download] by right-clicking and
choosing "Save as...".

We can't add an [open] context menu option in the default case, since we don't know a
link is a download until the user clicks on it. We could look at the file extension
as a heuristic for this, but it wouldn't work all the time.
Looks like there's still confusion on what needs to be done here.  I'm holding off 
until we reach more of a consensus.
I'm assigning to Nick to figure out exactly what needs to be done here.  Assign back 
to me when the design requirements are clear.
Ben tells me that there's a Temporary Internet Files folder that supposedly gets
cleared up "at some point" (either by the system, or by IE, or by user action). I'm
fine with putting the files in there, it seems like the expected behavior on Windows.

Is there a similar mechanism on other platforms? If not, I suppose we'd have to
handle this on our own, so we might as well implement the algorithm described above.

Darin, do these options seem reasonable to you?
I may be mistaken, but I think this folder _only_ gets cleaned up as a result of a user 
action, either through the IE UI or (on at least XP) when the user is out of disk space 
and gets presented with a dialog prompt saying (you are about to run out of space, 
which of these things do you want to clean up?).

This approach feels a bit awkward to me. Sure, those files are now out of sight, but 
now you have to use IE to clean them up.
The Firefox (and IE!) options are both sub-optimal. The feature is very useful however, 
even with its flaws.

Using a subdir of %TEMP% and deleting lazily on close/reboot works well enough IMHO.
Comment 13 by wra...@gmail.com, Apr 21 2009
IE DOES clean out the temporary directory automatically.

When I look at the Browser history settings for IE, it gives you a posibility to set 
a threshold for how much space it should use. Mine is set to 50MB. Recommended size 
is 50 to 1024 MB.

I think IE purges old files, once this limit has been reached. I haven't cleared my 
temporary internet files in ages, and they only contain 1.5MB of data right now. So 
it was purged at some point.

This "Temporary Internet Files" Folder is not just managed by the systems's normal 
temp-file system . It is managed by IE, either periodically, or every time a resource 
is downloaded.It also provides the user the option to pick a different folder to use 
for these files.

And yes this is the type of storage the user will EXPECT you to clean.
Comment 14 by ben@chromium.org, May 14 2009
Contact me before assigning.
Hi, just a suggestion, check out Safari 4's way of doing this, I think that might be 
the best solution.
Labels: -Mstone-2.1 Mstone-2.2
Pardon the intrusion, but from reading this discussion, I think most of you are 
overthinking this.  It seems to me that the implementation for "opening" a link 
versus "saving" or "downloading" it should be very simple.

Consider a normal HTML link.  When the user clicks on it, Chrome "opens" it - that 
is, it downloads the HTML file (as well as all referenced resources, such as images, 
CSS, script, etc.), stores it in its private Cache folder, and displays the result in 
the browser.  At some point after the page has been displayed (typically, though not 
necessarily, sometime after the user closes the tab or navigates to a different 
page), Chrome deletes the file(s).

"Opening" a non-HTML link should be handled in *exactly the same way*.  The only 
difference is that an external application is launched to display the file.  So, for 
example, consider a ZIP file.  The user clicks on the link to the ZIP file and 
chooses to "open" it rather than "save" it.  Chrome downloads the ZIP file, stores it 
in its private Cache folder, and makes the appropriate system API call to open the 
ZIP file in whatever application is associated with ZIP files on the user's system.  
At some point after the the external application is done with the file (typically, 
though not necessarily, sometime after the user closes the file in the external 
application), Chrome deletes the file from its cache.

But how does Chrome *know* when the external application is done with the file?  
Don't worry about it.  Just try to delete it during the normal cache clean-up 
process.  If the external application still needs it, it will typically have a lock 
on the file, and Chrome won't be allowed to delete it.  No problem; try deleting it 
the next time around.  Maybe there are a few edge cases where this approach would 
delete the file before the external application was done with it, but would I expect 
them to be rare.

Based on observation, I'm pretty sure this is the way IE handles the "opening" versus 
"saving" distinction.
Comment 18 by jsuti...@gmail.com, Jun 15 2009
I believe Steve has the right idea with this one. Storing the "opened" downloads along 
with the browser cache allows you to use your existing cache management. The file will 
be available for "save as" until it is automatically purged from the cache.

Peeking at the cache folder I see none of the files have extensions. This would be a 
deviation from the existing cache management system as in order to call the generic 
"open this with the default program" you will need to preserve the original file 
extension. However it would not be necessary to keep the original filename.
Comment 19 by jon@chromium.org, Jun 15 2009
Labels: Mstone-3
Status: Untriaged
Moving to mstone 3 from an older milestone.  Need to triage.
Comment 20 by jon@chromium.org, Jun 15 2009
Moving to milestone 3 from an older milestone.  Need to triage.
Labels: -Mstone-3 Mstone-4 DesignDocNeeded
Status: Available
In the mean time, an option to delete the (needlessly) saved files, from the interface, 
would be great.
Firefox might be sub optimal, but at least does the trick. This is -in my opinion- 
the very last thing where chrome lags behind the other browsers and why I still have 
firefox installed in my computer.

As users we know most of the time when to use the open button, instead of save. We 
want to see, not to keep. Read a pdf but not keep it, check some data or hear a mp3 
that we don't want. The open function is specially useful in academia, where you 
might only keep a tiny % of the docs you read, so it allows you to preview and then, 
if you want, hit the save as button.

It might be done in a better way that firefox... but I would be happy with the same 
sub-optimal solution. 

Thanks for a great product and I am counting the seconds for google chrome!
Labels: Downloads
I did a poll in the Google Chrome's community most visited of Orkut.
After a significant number of users have voted, the count showed, for now, that the 
"Chrome way to download" is one of the features most bother the people.

This, of course, is making many users leave the Google Chrome. There's a thing 
important to do here.
Comment 26 by Deleted ...@, Aug 11 2009
Comment 7 by nickbaum@chromium.org, Apr 06, 2009:
"We can't add an [open] context menu option in the default case, since we don't know a
link is a download until the user clicks on it. We could look at the file extension
as a heuristic for this, but it wouldn't work all the time."

Leave this to the user- if he tick "Always Open files of this type", do just this- open 
it, don't save. Leave the user to make a decision. All programs which can open file, 
can save it. 
Comment 27 by Deleted ...@, Sep 23 2009
Chrome has been great for me so far. crashes a lot less than FireFox. unfortunately 
though I open about 20 to 50 files a day that I do not want saved to my computer.  The 
files I want saved i save to my desktop then move them later.  I just can not put up 
with deleting these 20 to 50 files every day from my desktop that I do not want so I 
guess I am switching back to fox for now my come back if you guys get this straightened 
out.
Comment 28 by evan@chromium.org, Sep 23 2009
jawaulk: I work around this by downloading everything to the same folder, then 
deleting all the contents of that folder occasionally.  (I hate this behavior too, 
just letting you know how I work around it.)
Comment 29 by ben@chromium.org, Sep 29 2009
Labels: -Mstone-4 Mstone-5
Labels: -Downloads Feature-Downloads
@10: As I understand it, the mechanism on UNIXy filesystems like ext2/ext3 is to 
download to /tmp, launch the associated program, and then delete either when the 
program exits or after a minute or two, depending on what is more appropriate. (Open 
file handles carry the same weight as hardlinks, so the inode stays allocated after 
you "delete" the file)
@17 I really liked your solution. However, we should also focus on UI.

What I am suggesting is, add a new checkbox option for the downloading file "delete 
the file once its closed" (feel free to change the option text). The user can select 
the option while the file is being downloaded or after the file is downloaded.

case 1: while the file is being downloaded
In this case, chrome will finish downloading the file. It will open it in External 
application. The chrome will try to delete the file every 5 minutes( time is not an 
issue here). If the file is still open, the chrome will not be able to delete it. If 
the file is closed, it will be deleted.

case 2: After the file is downloaded
If the user selects to delete the file, after the download is done. Chrome will try 
to delete the file on the spot. If it succeeds in deleting the file, Chrome will even 
delete it from the download pane. If it does not succeed in deleting the file, it 
will keep trying to delete it after sometime, same as case 1.

P.S. 
Look at the picture attached for better understanding.
downloadOption.png
46.5 KB View Download
@32 - I also like @17's suggestion, and appreciate your desire to improve UI -- but I 
definitely would be annoyed if I had to set the "delete file once closed" option for 
each download.  Again, consider treating this as opening any other page -- make it 
available while you're looking at it only -- and people will have an option to either 
right-click to download at the start, or do a 'save as' from the application if they 
want to save it later.  If you think there's a significant percentage of people who 
would LIKE to download all viewed files to a specific location (though I don't see 
why -- you can't organize that way), you could provide that option in the Chrome 
Preferences.
Comment 34 by mattk...@gmail.com, Oct 20 2009
I like the original idea - the default behaviour should be to save the file 
temporarily (until the tab that opened the file is closed, along with the downloads 
bar along the bottom), and the user should have the ability to easily save that file 
to a default directory or to a chosen one, after or during download.

I think the issue with firefox is that it still records a file that was saved 
temporarily in your downloads list, where the expected behaviour is that files are 
accessible. Instead, in chrome your download history should only show saved files, 
and files that were only opened would not be (easily) accessible after the tab that 
opened them is gone.
For what it's worth, the current behavior is one of the things that makes me jump 
back to Firefox for the rest of the night. It's annoying to have to save a file to a 
location, then open it each time.

Another thing to consider are the set of rules surrounding HTTP Cache headers. There 
are some subtle bugs with the headers set to not cache, or not save, or a combination 
(depending on what the web designer has decided). It's caused me some headaches in 
the past. Whatever the solution will be needs to honor the HTTP Cache headers for a 
request, but also be simple.

Cheers!

(PS. Went to view the PNG above, but gave up after I got prompted to save the file 
:))
Comment 36 by ben@chromium.org, Nov 16 2009
Labels: -Mstone-5 Mstone-X
Comment 37 by ghost...@gmail.com, Nov 17 2009
Is this not a duplicate of http://code.google.com/p/chromium/issues/detail?id=333 ?
Comment 38 by evan@chromium.org, Nov 17 2009
Mergedinto: 333
Status: Duplicate
Personally, I don't think Open'd files really need to be persistent. 

Pardon me if I'm wrong, but whenever you guys 'Open' a file through your browser, do 
you not usually only use it once, and then completely forget about it? And if you 
need it again, don't you just re-download & 'Open' the file anyway?

Downloaded files which are Open'd by the browser should only be temporary, and I 
don't think that a download entry should be left in the Download page, if this was to 
be implemented. 'Open'ing a file, as I said, is something that should be/feel 
temporary.

But meh, that's just my ($0.01 * 2).
Comment 40 by Deleted ...@, Dec 10 2009
so great there are extensions for Google chrome. BUT I STILL CAN'T OPEN A FILE WITHOUT 
DOWNLOADING IT??? :o

But chrome will be certainly my favorite if i dont have to save all the files. hope 
there will be a solution soon. 
Comment 41 by zmat...@gmail.com, Dec 14 2009
The best way to do this would be to create a temp downloads folder, when a link is 
clicked an option would appear to save the file (as it does now) or open it. If the 
open button is selected the file should be saved to the temp folder and opened using 
it's default program. Once this folder reaches a set size each new download would 
delete however many files it needs to for the folder to be under its max size, older 
files will need to be deleted first as they are the least likely to cause any conflict. 
Comment 42 by Deleted ...@, Dec 18 2009
I can't believe this has been ongoing for over 9 months.  That's insane!  Until 
either the ability to open a file is either enabled natively (as is the case with 
Internet Explorer) or enabled through a plugin (like OpenDownload with Firefox) I 
can't use Chrome as my primary browser.  It's that simple.  Additionally I need the 
option that Firefox gives with a per file type basis (i.e. '.avi' opens with windows 
media and '.mpeg' opens with VLC).  This is so simple to implement (at least the 
'OPEN' instead of downloading is, because Firefox added this with a few KB extension 
called 'OpenDownload').  There is nothing left to think on.  Any further issues 
Chrome has with decided which way to go, you should develop extensions to give the 
user the option to decide for themselves.  Thanks!
We really need this feature now.  How much longer?

I think downloads getting deleted upon close of Chrome is fine.  Keeps the OS running 
better.  Can't really on the OS to delete files.
Comment 44 by tiki...@gmail.com, Jan 18 2010
I understand that adding an extra step to the default download process would not be a 
good idea, but why not have the ability to show this sort of save/open menu for certain 
mime types of file extensions? Usually people want to open relatively few filetypes, 
and for the ones they do want to just open, the extra menu would be really helpful.

Say I wanted to start up my favorite music stream. I could download the stream file, 
select a "Ask whether to open this filetype?" option, and not have to worry about 
saving the file onto disk over and over again.
Comment 45 by chik...@gmail.com, Jan 18 2010
I don't think this even needs to be an extra step. Just add an run button to the Save / 
Cancel buttons that appear when you download a file. Click run and it downloads to 
some temporary place, and immediately opens when it's done downloading. And that 
temp folder can get cleaned out at the end of the session or however often the user 
chooses in preferences. Then save and cancel work the same as now. I think all of this 
MIME-type specific options just complicates the matter. Unless there's a plugin to 
open the file within the browser, it should always just ask you to open/save. Maybe 
put in a "Remember my choice for this filetype." option later. 

The point is simply to not clutter up the downloads folder with stuff that you only plan 
to look at once like installers. There's 173 things in my downloads folder at the 
moment, almost all of which are dmg's, zips or pdfs that I never intend to look at 
again. And it's simpler to choose whether to keep it when I download it, than to have 
to go back later and sort through 173 files trying to find those I actually want to keep.
Comment 46 by Deleted ...@, Jan 18 2010
The point is this has been an issue for nearly a year, and Google's stance is somewhere 
between "we see the lack of this option as a feature" and "we haven't the technical 
know how to accomplish this feat".  What a joke.  It's January and this thread began in 
March of 2009.  
Seriously.

To say that Google does not have the tech knowledge to do something like this is 
pathetic.  Solely due to this fact I am using Opera at home and work.
Comment 48 by evan@chromium.org, Jan 19 2010
It's almost as if there were literally over 10,000 other bugs to work on!
Comment 50 by Deleted ...@, Jan 26 2010
I think:

1. The behavior should be selectable from Options (Default Open or Default Save)
2. A key combination would be good to switch behavior on the fly (if open is the 
default behavior, clicking the link with Control (or other key) pressed would save it. 
If the default behavior is save, clicking the link with Control pressed would open it)

I think this would be even better than Firefox since it requires just one click.
Comment 51 by Deleted ...@, Feb 18 2010
Uninstalling Chrome now because it doesn't have the open file option.  This is pathetic 
Google... It doesn't take a year + to implement a simple download option that everyone 
seems to want..  I'm very disappointed in this.  Maybe I'll come back in a couple 
years, hopefully you'll have sufficient time to get on this problem by then?
They don't care.

Maybe if we related this to the Nexus 1, Google would jump on it.  Chrome is a lost 
cause.  Opera rocks.
Comment 53 by Deleted ...@, Feb 22 2010
I love Chrome. But sadly, I am not using it, because I am tired of cleaning up my 
downloads folder off the useless torrent, stream and even document (doc, pdf, ppt...) 
files. If I need that file in future, I have a better chance of finding it in my email 
quickly, than in the overly bloated downloads folder on my hard disc. 
Please implement this feature FAST! It is the only thing that makes me not want to use 
Google Chrome at the moment. Its so annoying that you cant open files with out 
physically downloading them..

-Davis
@Davisstraus

Please explain to me how you can open files without physically downloading them?
Sorry, what I meant by that was the option to choose wether to "save" or "open" the 
file which would download them in a temp folder and then automatically delete at some 
point.


Comment 57 by Deleted ...@, Mar 9 2010
Just please answer Google, Are you taking this serious? are you implementing this 
feature or not? is it so complicated to add a check box in the options menu to activate 
or desactivate this feature???. Only reason me and thousands of people prefer any other  
programs, ANY.

Please at least answer ARE YOU GOING TO DO THIS OR NOT????? i dont want to try chrome 
if you are not
Agree with pabloelizaga. I am tired of waiting. I am uninstalling Chrome. 
I'm not going to uninstall chrome.. it's the best browser on the market and I CAN
stand waiting for google guys.. 

I'm only writing this to support any developer that might read this. And I think they
will implement this.. we just need to make sure this is the ONLY thread about this..
probably there are others where there are owners which will fix this one here...

	
Google Employee
4/20/09
Hey guys,

We've been hearing your requests for the this feature and there's more to the
implementation than meets the eye. We're still working on it and appreciate your
feedback and patience.

Thanks!
Shawn
Possible solution if you think it will confuse most users is simply an extension - 
Firefox has the OpenDownload add-on which "allows you to open any file from the 
internet into the OS assigned program."  It then deletes the file after 24 hours.  
https://addons.mozilla.org/en-US/firefox/addon/207
Comment 61 by Deleted ...@, Apr 13 2010
I'm very disappointed how such a stupid thing like adding an add-on in chrome could 
take over a year!

Comment 62 by Deleted ...@, Apr 14 2010
Where is this fix?! Gosh, such a simple thing...
I don't know why it's not possible, but I think it's for security reasons.
They will probably put this feature soon, but don't forget that Chrome is a closed box. 
It's good for us. It's very secure. They don't want to create another IE.
So be patient.
No more patience.  Opera now and forever.
Comment 65 by ama...@gmail.com, Apr 17 2010
this bug is a duplicated of http://code.google.com/p/chromium/issues/detail?id=333
Thanks douglasracaixeta, finally an smart comment!

I can't belive how people loses that much time saying the same thing:
1) How this feature is SO important that they can't live without it and are moving to 
other browsers because of it. (I just find it a bluff)

2) How people say "such a simple thing" or "such a stupid feature".... 
Have you ever even programmed a calculator? Have you got any remote idea of what does 
programming this feature mean? Probably not, so please quit the whinning...

Instead of saying this stupid things, why don't you say something useful?

I doubt google reads this post, but I'd recommend them to do the following tweak 
until the feature is fully developed and tested for every OS:

Since when im currently downloading a file, I have the option to Cancel it, and it 
deletes the unfinished file, I assume that the ability to delete files isn't hard to 
implement. So, why don't we put an icon or a contextual item in the arrow that gives 
the user the option to delete the downloaded file? That way I'd not mind if it's 
saved in my Downloads folder instead of a Temp folder, because I can easily and 
effortlesly delete the file, without having to go all the way to the file's folder 
and manually deleting it.

Just my 2 cents
ddeamilivia, you are dead on for the simplest solution!  About 3 days ago I 
downloaded a file that I only needed for 1 minute, then I wanted to delete it, I hit 
the arrow next to the file download (at the bottom of the screen on the download bar 
that appears when downloading files), and I honestly and truthfully expected to see a 
"Remove Downloaded file" or "Delete", or some other option.  I did see "Show in 
Folder", which I used to open the folder, and then delete the file, and wondered the 
same thing that you proposed, why not just have on the same context menu, a delete 
file option... I like the idea, I hope that Google DOES read these comments, and sees 
this as an "easy win" and implements it.
Comment 68 Deleted
Comment 69 Deleted
ddeamilivia, programming is not easy, indeed, but I would expect the most important 
Internet company's programmers to be able to implement a feature that EVERY other 
browser has. We are not asking anything that hasn't done before. Just a damn OPEN 
button! a temporary folder! Why is it so hard?
Comment 71 by hac...@gmail.com, Apr 26 2010
I hate having to go and manually clean up my Downloads directory every few days 
because it is full of junk PDF files, documents, server-side generated content with 
no file extension (PDF, image, whatever) that I clicked on to open *temporarily* 
instead of save permanently.  I think that is what everyone else here is saying, just 
wanted to share my agreement.

One possible solution would be to have temporary files appear on the download bar for 
that particular session only (or even a specified time limit), along with a *unique* 
icon or other visual indicator to indicate that they are temporary.  You could then 
choose to save or delete the file from the context menu, and also expect it to be 
deleted automatically the next time the browser starts (not closes).

Also remember that many programs like Evince (and presumably Adobe Reader still does 
this as well) have a "Save As..." option, because it assumes the PDF was opened as a 
temporary file, and so gives the user the choice to save it if they want to retain 
it.
Comment 72 by costi...@gmail.com, May 10 2010
Dear Chromium/Chrome,
I was using you just for gmail, because features like noscript and flashblock are way 
too rudimentarily implemented in you.
I was masochist enough to use you.

You are far away from opera/firefox. You stolen few hours of my life during using you 
because of having to go with save/browse/open/delete scenario.

"writing software is not that easy" is not an excuse, it's actually the worst excuse 
one can come up with.
GOODBYE CHROMIUM/CHROME, I'm back to normal, where I can choose "OPEN" or "RUN", in 
other browsers. (you see, I'm just "BROWSING", not 
"saving/browsing/opening/deleting")
Comment 73 by Deleted ...@, Jun 18 2010
Ok, how about this:  Add a button that says, "open this file with IE" since programming isn't easy and MS already did the "hard" programming.
Comment 74 by hac...@gmail.com, Jun 19 2010
@DevAndDesign Don't be an asshole.  You juts spammed everyone subscribed to this *bug report* with your useless drivel.  Unless you have a patch, don't complain.  Or complain to Google to prioritize the issue among their paid developers.  Messages like yours help no one.
Comment 76 Deleted
Comment 77 by bobp...@gmail.com, Jul 6 2010
@75: Unfortunately there's no patch, merely a windows build. Redsnake does not appear to have published his source code changes.
Comment 78 by Deleted ...@, Jul 25 2010
I love Chrome for being lightweight, fast, standards-friendly, and for its clean and simple UI. It has been my browser of choice for many months, and I've recommended it to many friends who are now using it as default browser as well.

The complaint I hear the most from them, and one of my major grievances, is the lack of a temporary download option ("open"/"open as"). It litters my download folder to an incredible extent, because most of the files I open I do not wish to keep (pdfs, docs, ppts, installers, torrent files, zips, and so many others). It gets hard to manage very fast, and forces me to manually clean the folder almost on a daily basis or spend time searching for the files that I want to keep and use in the middle of all the garbage. It's a hit in my productivity, and a flat out nuisance...

Please increase the priority of this feature request! I won't presume to know the best way to implement this, but as a user, it's something I really long for and would appreciate a lot!

Thank you for your time.
Comment 79 by Deleted ...@, Aug 6 2010
It can't be that hard to copy the behavior of Firefox.
Comment 80 by costi...@gmail.com, Aug 11 2010
WTF?
http://code.google.com/p/chromium/issues/detail?id=333 is closed for comments, so I'm typing here.

quoting ben:
"Comment 143 by ben.at.chromium.org, Jun 09, 2010
This is going into Mstone-X until we have a UI design that satisfies our other Chrome constraints (not prompting, etc), "

there, fixed that for ya, this fits perfectly into current UI design: http://clip2net.com/page/m0/7240405 (attached here, too)

"and it's not something that is currently on our list. We do understand it's a commonly requested feature however so it is possible we'll consider it in the next 6-12 months."

...but is on OUR list, the f..ing USERS !!!
1281558836-clip-73kb.jpg
185 KB View Download
What a shame. I am a HUGE Google fan, but i think this is a big disappointment. I know we can download, save, and then manually delete the file. that's fine. but i can't understand why Google is so opposed to giving priority to a highly requested other option (automatically deleting the file). 
I'm surprised by this.
Comment 82 by Deleted ...@, Aug 12 2010
After using Chrome for many months, I finally got tired of grieving over this issue and reverted to firefox. The ff 4 beta showcases some major improvements and revamped look (very similar to chrome, actually), and it includes a feedback mechanism that really makes you feel heard, unlike what you experience with *some* other browser developers.

If you're annoyed by this issue (and if you're reading this bug report, then you certainly are...), save yourself the grievance and give ff4 a try. Thank me latter.

@chromium devs: good job alienating your user base. Keep it up and chrome will head down google Wave's path. Goodbye and thanks for all the fish.

/unsubscribe
Comment 83 by Deleted ...@, Aug 17 2010
Has anyone tried to put a file watcher application on the download folder to "start" the file with the default application?  I played around with this but have not gotten the concatenation sequence correct in FileWatcher to make it work correctly.
Comment 84 by Deleted ...@, Aug 17 2010
All, I did get watchDirectory working.  It invokes on any file addition to the download directory and opens the file automatically using the default application.  I also setup a watcher on the overall size of the directory and use FIFO to keep it in control.  I love Chrome, so I am pretty pleased to have a way to make file behavior "better" while the long-term fix is worked.
Comment 85 by Deleted ...@, Aug 25 2010
@todorgmt:
I'm with you. How is it possible that the brains at Google cannot produce a simple fix for an even simpler problem. You simply need to create a popup window and automate what the user already does manually. Forget cleaning up the directory as the google downloads directory is left to grow by default and currently has no trash collection. We just want a dialog that asks if we want to open/run or save as. If you open/run, it shells the download based on the file association, if you choose save as, it calls the "browse for directory" dialog using existing api calls, allows user to choose path, and instead of the file downloading the the default downloads directory, it now downloads to the newly defined path. Once the download is complete and that event is fired, you open another dialog asking to open or run it which again shells the file based on the association. No new events need to be created, you can use all of the existing events that are already being fired in the current download functions and these new additions can use standard api calls and a few lines of custom code. I believe they are waaaaay over thinking this remedy. 

What am I missing here? I must have written 20 of these scenarios in various programs I've coded throughout the years and never has it been a problem.
Is it possible for someone to make an extension to get this functionality?
Comment 87 by Deleted ...@, Sep 4 2010
Please add my vote to get this going.  I'd like to echo the sentiment of comment 78!

I did not click the star because I do not want to subscribe to "e-mail change notifications."  Sorry to bug you.

(code.google.com needs to allow us to vote without subscribing, really!)
Comment 88 by Deleted ...@, Oct 11 2010
It's a shame that this issue hasn't been implemented as of yet! It's a small issue but one that prevents me from making the switch to Chrome from Firefox yet!
Blocking issue!!
I am uninstalling Chrome!
Chrome is not yet ready for user, I'm going back to stick to IE.
Chrome's got a serious lack of features and options, and is not configurable at all!
why is it so hard to make such an easy option to open a file without saving it ... Google you really let me down on this one ...
Comment 91 by Deleted ...@, Nov 3 2010
As a user I really think opening the downloaded file right away is useful. But I see google have no intension on implementing this. As the issue ticket raised 1.5 years ago. I think this is one of the reason I still haven't set chrome as default browser... sigh...

Chrome is fast... but still feature first.
Lack of the open/view feature instead of permanently downloading a file is a HUGE draw back for Chrome. Highly annoying...
Is this still on the backburner?  I think its priority/milestone should be re-evaluated.  If you insist on continuing to clutter users' download folders with garbage files, you might as well disable all options to delete cookies and clear the cache.

It seems this hasn't been implemented because nobody can figure out how to do it without creating an extra prompt for the user.  Because it can't be done.  There's no way for Chrome to know which .exe or .pdf or .whatever the user wants to save for later or just open once unless it asks.  Why is this a problem?  Make it optional if you must.  There's already an option to "Ask where to save each file before downloading."  What's wrong with one more *optional* prompt?  If it doesn't fit into Chrome's current development guidelines, those guidelines need re-evaluation.

Implementation is simple: Just add a check box above/below "Ask where to save each file before downloading" to "Ask whether to open or save each file before downloading."  "Open" would save to temp directory, "Save" would save to default download directory or prompt where to save, depending on whether the other box is checked.  Have Chrome handle the purging of this temp directory whenever is deemed appropriate.  Simple.  Optional.  User-friendly.  Done.  Everyone's happy and stops complaining about it.

Can we get on with this already?
Currently, when you click something to download, it pops up and says Save / Cancel. Why not just do Save / Open / Cancel ?? Doesn't sound that hard to me...
Labels: Restrict-AddIssueComment-Commit
Labels: -Fixit bulkmove TaskForce-Fixit
Mergedinto: -0
Change download section of options to:

--

() Download to a folder [C://...][Browse]
    [] ask where to save each time
() Download to a temporary location

--

When the second radio button is selected, download files to a hidden temp 
folder that eventually gets cleaned up by the OS (we should not implement 
this logic if we can avoid it). The "Show in folder" option in the shelf 
menu should be replaced with "Save file as..."

Regardless of which radio button is selected, all downloads should still 
appear on the downloads page.
Labels: -DesignDocNeeded Action-DesignDocNeeded
Change download section of options to:

--

() Download to a folder [C://...][Browse]
    [] ask where to save each time
() Download to a temporary location

--

When the second radio button is selected, download files to a hidden temp 
folder that eventually gets cleaned up by the OS (we should not implement 
this logic if we can avoid it). The "Show in folder" option in the shelf 
menu should be replaced with "Save file as..."

Regardless of which radio button is selected, all downloads should still 
appear on the downloads page.
Project Member Comment 98 by bugdroid1@chromium.org, Mar 9 2013
Labels: -Action-DesignDocNeeded Needs-DesignDoc
Project Member Comment 99 by bugdroid1@chromium.org, Mar 11 2013
Labels: -Feature-Downloads Cr-UI-Browser-Downloads
Sign in to add a comment