New issue
Advanced search Search tips
Starred by 1 user

Issue metadata

Status: Fixed
Merged: issue 899919
Owner:
Closed: Dec 14
Cc:
EstimatedDays: ----
NextAction: ----
OS: ----
Pri: 1
Type: Bug
Flaky-Test: __main__.ZChromeStartRetryCountTest.testChromeStartRetryCount



Sign in to add a comment
link

Issue 899886: __main__.ZChromeStartRetryCountTest.testChromeStartRetryCount is flaky

Reported by Findit, Oct 29 Project Member

Issue description

Comment 1 by zmin@google.com, Oct 30

Mergedinto: 899919
Status: Duplicate (was: Untriaged)

Comment 2 by erikc...@chromium.org, Dec 13

Cc: jbudorick@chromium.org crouleau@chromium.org
Owner: johnchen@chromium.org
Status: Assigned (was: Duplicate)
I'm unduping this issue and assigning to johnchen@.

There is significant flakiness in this test:
https://findit-for-me.appspot.com/flake/occurrences?key=ag9zfmZpbmRpdC1mb3ItbWVyZwsSBUZsYWtlIlxjaHJvbWl1bUBjaHJvbWVkcml2ZXJfcHlfdGVzdHNAX19tYWluX18uWkNocm9tZVN0YXJ0UmV0cnlDb3VudFRlc3QudGVzdENocm9tZVN0YXJ0UmV0cnlDb3VudAw

Flakes occur every day including today.

This bug was duped into an open bug with last action 10/30.

Comment 3 by erikc...@chromium.org, Dec 13

For other flakes that have occurred recently [not including timeouts]:
https://findit-for-me.appspot.com/ranked-flakes?flake_filter=step%3A%3Achromedriver_py_tests+%28with+patch%29

Comment 4 by hongchan@chromium.org, Dec 13

Components: Tests>Flaky
Labels: -Sheriff-Chromium
The issue is assigned and troopers are cc-ed. Removing sheriff label.

Comment 5 by bugdroid1@chromium.org, Dec 14

Project Member
The following revision refers to this bug:
  https://chromium.googlesource.com/chromium/src.git/+/1f74ea840053948628df4a2fd35a32556620fb82

commit 1f74ea840053948628df4a2fd35a32556620fb82
Author: John Chen <johnchen@chromium.org>
Date: Fri Dec 14 02:42:38 2018

[ChromeDriver] Disable flaky testChromeStartRetryCount

Disable flaky chromedriver_py_tests test case
ZChromeStartRetryCountTest.testChromeStartRetryCount.

Bug:  899886 
Change-Id: I1c1bd3450682d1f87108cc739a2471ba818fcec8
Reviewed-on: https://chromium-review.googlesource.com/c/1377333
Reviewed-by: Erik Chen <erikchen@chromium.org>
Commit-Queue: John Chen <johnchen@chromium.org>
Cr-Commit-Position: refs/heads/master@{#616565}
[modify] https://crrev.com/1f74ea840053948628df4a2fd35a32556620fb82/chrome/test/chromedriver/test/run_py_tests.py

Comment 6 by johnchen@chromium.org, Dec 14

Status: Fixed (was: Assigned)
The flaky test has been disabled.

Comment 7 by estaab@chromium.org, Jan 24

Components: -Tests>Flaky

Sign in to add a comment