New issue
Advanced search Search tips
Note: Color blocks (like or ) mean that a user may not be available. Tooltip shows the reason.

Issue 889636 link

Starred by 13 users

Issue metadata

Status: Fixed
Merged: issue 884161
Owner:
Last visit > 30 days ago
Closed: Oct 15
Cc:
Components:
EstimatedDays: ----
NextAction: ----
OS: Chrome
Pri: 2
Type: Bug



Sign in to add a comment

"Use a shorter name" error, but name is short

Project Member Reported by michae...@chromium.org, Sep 26

Issue description

Chrome Version: 70.0.3538.22

I'm getting this error when attempting to rename a file.

Not sure what the repro steps are; here's what I did:

1. Select a file with a long name (dev-channel%2Fkevin%2F11101.0.0%2Fchromeos_11101.0.0_kevin_recovery_dev-channel_mp.tar.xz)
2. Ctrl-Enter to edit name, Ctrl-C, Esc to stop editing
3. Select a file with a short name (chromiumos_test_image.bin)
4. Ctrl-Enter to edit name, Ctrl-V, Enter to save

That shows the dialog. Fine, it's a long name. But now:

5. Ctrl-Enter to edit name, "foo", Enter to save

That still shows the dialog. "foo" is now considered too long a name. I can't rename any file in the list now because they all result in the same error.
 
Screenshot 2018-09-26 at 3.43.54 PM.png
148 KB View Download
Also seeing this issue.
Chrome OS Beta Version 70.0.3538.22 (Official Build) beta (64-bit)

Occurring in a few contexts but this is one I can recreate. 

1. Open Caret text editor: https://chrome.google.com/webstore/detail/caret/fljalecfjciodhpcledpamjachpmelml
2. Start a new file.
3. Save file to Google Drive or any other mounted file system (ie. Something from Add new Service menu option) 
4. Start another new file in Caret
5. Save this new file to Downloads (My files > Downloads)
- Navigate to Downloads, type any filename and click Save 
- You will be presented with a modal for "Use a shorter name"
- You will not be able to save the file. This is irrespective of the filename's content, extension or length.
- NB: Perhaps noteworthy that the filename is sometimes prefilled as "root"

NB: Bug reported to Caret too: https://github.com/thomaswilburn/Caret/issues/652
 

use a shorter name.png
42.0 KB View Download
Labels: -Pri-3 Pri-2
Mergedinto: 884161
Status: Duplicate (was: Untriaged)
Cc: slangley@chromium.org
Status: Untriaged (was: Duplicate)
Don't understand why this was merged. This error message occurred for a *three-character name*.
Labels: CrOSFilesCategory-UI
Neither techniques described above repro for me, so I merged it to the bug to provide better diagnostics.

If I can't repro it without better diagnostics there's not much I can do.
Status: Unconfirmed (was: Untriaged)
So if you have the time, can you take a look at the contents of /var/log/ui/ui.LATEST (or perhaps earlier files in /var/log/ui/) to see if there are any potentially interesting error messages with the string "file_system" in them?

We do print our some logs for some of the failure paths, they should land in here.
Labels: Needs-Feedback
Labels: -M-70 M-71
Labels: -Needs-Feedback
Owner: lucmult@chromium.org
Status: Assigned (was: Unconfirmed)

Comment 10 Deleted

Same issue here on a Pixelbook: 69.0.3497.95 (Official Build) (64-bit)

When I save a downloaded file to Google Drive, there aren't any issues, but once I try to save it locally I get the error message even for a 1-character filename.
Error messages in the developer console
Screenshot 2018-10-10 at 9.44.17 PM.png
45.5 KB View Download
/var/log/ui/ui.20180925-220457:[2670:17942:1010/213459.218839:ERROR:private_api_file_system.cc(91)] Cannot statvfs() the name length limit for: /provided/hlffpaajmfllggclnjppbblobdhokjhe:dropboxfs:%2F%2Fdbid:AACzn78EwGCbkb59ruUmF4DznhjAhZ4rNcE:6ed45404ba2f8d79b347ccd8adce2f157863d5e5/proyectos/
Project Member

Comment 14 by bugdroid1@chromium.org, Oct 12

The following revision refers to this bug:
  https://chromium.googlesource.com/chromium/src.git/+/40a6cb9be79a8d05395498a705e59d50cbb77f57

commit 40a6cb9be79a8d05395498a705e59d50cbb77f57
Author: Luciano Pacheco <lucmult@chromium.org>
Date: Fri Oct 12 08:02:18 2018

Fix naming issue when renaming files inside My files

Change DirectoryModel to "unwrap" VolumeEntry when it's selected via
file list. This fixes the issue where after selecting a VolumeEntry any
operation in the private API would fail because it wouldn't be able to
send a VolumeEntry to private API, because it requires a real Entry.

This fixes the user issue of trying to rename and always getting "Use
shorter name" error, even with a short name.

Update FakeEntry to be an implementation of FilesAppDirEntry, since all
users were using as directory, also update some functions to typing to
use FilesAppDirEntry instead of FakeEntry which is more correct.

Test: browser_tests --gtest_filter="*/myFilesFolderRename"
Bug:  889636 
Change-Id: Ieb75ffbb811a91e4742fb7a49a3badfd129376ad
Reviewed-on: https://chromium-review.googlesource.com/c/1276067
Reviewed-by: Joel Hockey <joelhockey@chromium.org>
Commit-Queue: Luciano Pacheco <lucmult@chromium.org>
Cr-Commit-Position: refs/heads/master@{#599136}
[modify] https://crrev.com/40a6cb9be79a8d05395498a705e59d50cbb77f57/chrome/browser/chromeos/file_manager/file_manager_browsertest.cc
[modify] https://crrev.com/40a6cb9be79a8d05395498a705e59d50cbb77f57/ui/file_manager/file_manager/background/js/volume_info_impl.js
[modify] https://crrev.com/40a6cb9be79a8d05395498a705e59d50cbb77f57/ui/file_manager/file_manager/common/js/files_app_entry_types.js
[modify] https://crrev.com/40a6cb9be79a8d05395498a705e59d50cbb77f57/ui/file_manager/file_manager/common/js/files_app_entry_types_unittest.js
[modify] https://crrev.com/40a6cb9be79a8d05395498a705e59d50cbb77f57/ui/file_manager/file_manager/foreground/js/directory_model.js
[modify] https://crrev.com/40a6cb9be79a8d05395498a705e59d50cbb77f57/ui/file_manager/file_manager/foreground/js/file_manager.js
[modify] https://crrev.com/40a6cb9be79a8d05395498a705e59d50cbb77f57/ui/file_manager/file_manager/foreground/js/file_transfer_controller.js
[modify] https://crrev.com/40a6cb9be79a8d05395498a705e59d50cbb77f57/ui/file_manager/file_manager/foreground/js/file_watcher.js
[modify] https://crrev.com/40a6cb9be79a8d05395498a705e59d50cbb77f57/ui/file_manager/integration_tests/file_manager/my_files.js

Labels: Merge-Request-70
Requesting to merge this fix to M-70.

I have merged this in a local branch from refs/branch-heads/3538 (M70), resolved the conflicts and tested it locally.


Project Member

Comment 16 by sheriffbot@chromium.org, Oct 15

Labels: -Merge-Request-70 Merge-Review-70 Hotlist-Merge-Review
This bug requires manual review: We are only 0 days from stable.
Please contact the milestone owner if you have questions.
Owners: benmason@(Android), kariahda@(iOS), geohsu@(ChromeOS), abdulsyed@(Desktop)

For more details visit https://www.chromium.org/issue-tracking/autotriage - Your friendly Sheriffbot
Labels: -Merge-Review-70 Merge-Approved-70
Project Member

Comment 18 by bugdroid1@chromium.org, Oct 15

Labels: -merge-approved-70 merge-merged-3538
The following revision refers to this bug:
  https://chromium.googlesource.com/chromium/src.git/+/8d0c105144240f56de7c48a9ca9bf2c86a47fd02

commit 8d0c105144240f56de7c48a9ca9bf2c86a47fd02
Author: Luciano Pacheco <lucmult@chromium.org>
Date: Mon Oct 15 23:28:18 2018

Fix naming issue when renaming files inside My files

Change DirectoryModel to "unwrap" VolumeEntry when it's selected via
file list. This fixes the issue where after selecting a VolumeEntry any
operation in the private API would fail because it wouldn't be able to
send a VolumeEntry to private API, because it requires a real Entry.

This fixes the user issue of trying to rename and always getting "Use
shorter name" error, even with a short name.

Update FakeEntry to be an implementation of FilesAppDirEntry, since all
users were using as directory, also update some functions to typing to
use FilesAppDirEntry instead of FakeEntry which is more correct.

Manually merged on M70 branch.

Test: browser_tests --gtest_filter="*/myFilesFolderRename"
Bug:  889636 
Change-Id: Ieb75ffbb811a91e4742fb7a49a3badfd129376ad
Reviewed-on: https://chromium-review.googlesource.com/c/1276067
Reviewed-by: Joel Hockey <joelhockey@chromium.org>
Commit-Queue: Luciano Pacheco <lucmult@chromium.org>
Cr-Original-Commit-Position: refs/heads/master@{#599136}
Reviewed-on: https://chromium-review.googlesource.com/c/1282142
Reviewed-by: Luciano Pacheco <lucmult@chromium.org>
Cr-Commit-Position: refs/branch-heads/3538@{#1004}
Cr-Branched-From: 79f7c91a2b2a2932cd447fa6f865cb6662fa8fa6-refs/heads/master@{#587811}
[modify] https://crrev.com/8d0c105144240f56de7c48a9ca9bf2c86a47fd02/chrome/browser/chromeos/file_manager/file_manager_browsertest.cc
[modify] https://crrev.com/8d0c105144240f56de7c48a9ca9bf2c86a47fd02/ui/file_manager/file_manager/background/js/mock_volume_manager.js
[modify] https://crrev.com/8d0c105144240f56de7c48a9ca9bf2c86a47fd02/ui/file_manager/file_manager/background/js/volume_info_impl.js
[modify] https://crrev.com/8d0c105144240f56de7c48a9ca9bf2c86a47fd02/ui/file_manager/file_manager/background/js/volume_manager_impl.js
[modify] https://crrev.com/8d0c105144240f56de7c48a9ca9bf2c86a47fd02/ui/file_manager/file_manager/common/js/files_app_entry_types.js
[modify] https://crrev.com/8d0c105144240f56de7c48a9ca9bf2c86a47fd02/ui/file_manager/file_manager/common/js/files_app_entry_types_unittest.js
[modify] https://crrev.com/8d0c105144240f56de7c48a9ca9bf2c86a47fd02/ui/file_manager/file_manager/common/js/util.js
[modify] https://crrev.com/8d0c105144240f56de7c48a9ca9bf2c86a47fd02/ui/file_manager/file_manager/common/js/volume_manager_common.js
[modify] https://crrev.com/8d0c105144240f56de7c48a9ca9bf2c86a47fd02/ui/file_manager/file_manager/foreground/js/directory_model.js
[modify] https://crrev.com/8d0c105144240f56de7c48a9ca9bf2c86a47fd02/ui/file_manager/file_manager/foreground/js/file_manager.js
[modify] https://crrev.com/8d0c105144240f56de7c48a9ca9bf2c86a47fd02/ui/file_manager/file_manager/foreground/js/file_transfer_controller.js
[modify] https://crrev.com/8d0c105144240f56de7c48a9ca9bf2c86a47fd02/ui/file_manager/file_manager/foreground/js/file_watcher.js
[modify] https://crrev.com/8d0c105144240f56de7c48a9ca9bf2c86a47fd02/ui/file_manager/file_manager/foreground/js/navigation_list_model.js
[modify] https://crrev.com/8d0c105144240f56de7c48a9ca9bf2c86a47fd02/ui/file_manager/integration_tests/file_manager/my_files.js

Status: Fixed (was: Assigned)
To check the fix: The error only happened when clicking on "My files" then clicking on "Downloads" via file list (on the right hand side).
Labels: Merge-Merged-70-3538
The following revision refers to this bug: 
https://chromium.googlesource.com/chromium/src.git/+/8d0c105144240f56de7c48a9ca9bf2c86a47fd02

Commit: 8d0c105144240f56de7c48a9ca9bf2c86a47fd02
Author: lucmult@chromium.org
Commiter: lucmult@chromium.org
Date: 2018-10-15 23:28:18 +0000 UTC

Fix naming issue when renaming files inside My files

Change DirectoryModel to "unwrap" VolumeEntry when it's selected via
file list. This fixes the issue where after selecting a VolumeEntry any
operation in the private API would fail because it wouldn't be able to
send a VolumeEntry to private API, because it requires a real Entry.

This fixes the user issue of trying to rename and always getting "Use
shorter name" error, even with a short name.

Update FakeEntry to be an implementation of FilesAppDirEntry, since all
users were using as directory, also update some functions to typing to
use FilesAppDirEntry instead of FakeEntry which is more correct.

Manually merged on M70 branch.

Test: browser_tests --gtest_filter="*/myFilesFolderRename"
Bug:  889636 
Change-Id: Ieb75ffbb811a91e4742fb7a49a3badfd129376ad
Reviewed-on: https://chromium-review.googlesource.com/c/1276067
Reviewed-by: Joel Hockey <joelhockey@chromium.org>
Commit-Queue: Luciano Pacheco <lucmult@chromium.org>
Cr-Original-Commit-Position: refs/heads/master@{#599136}
Reviewed-on: https://chromium-review.googlesource.com/c/1282142
Reviewed-by: Luciano Pacheco <lucmult@chromium.org>
Cr-Commit-Position: refs/branch-heads/3538@{#1004}
Cr-Branched-From: 79f7c91a2b2a2932cd447fa6f865cb6662fa8fa6-refs/heads/master@{#587811}
It started happening to me as well since this past update.
Thank you for the fix!
This is crazy it's not still actually fixed!
This problem is happening to me with my Google Chromebook Pixel LS(2015). I see no "fix" here for ordinary users, like me. Thanks.
Hi all, 

If you're still affected, please share the version you're currently using, you can get it from chrome://version. I think it's just that the fix hasn't been rolled out for you yet.

WORKAROUND: Use the directory tree (in the left hand side) to navigate to the directory/file that you want to rename.

The issue only happens if you use file list (right hand side) to navigate.

Cheers.
Version I am using(still affected) is :

Version 69.0.3497.120

Thanks!
It's fixed from 70 onwards, so this is expected.
That will be fine!  Thank you very much!!
I am still experiencing this issue.

Google Chrome	71.0.3578.94 (Official Build) beta (64-bit)
Revision	6da2ba233559398092dabd8dc7bc8e78cd758307-refs/branch-heads/3578@{#890}
Platform	11151.59.0 (Official Build) beta-channel gandof
Firmware Version	Google_Gandof.6301.155.9

Yes, sill experiencing this issue on Pixelbook on Chrome OS 71.0.3578.98.
Screenshot 2019-01-03 at 19.56.03.png
101 KB View Download
Still experiencing this issue. Veyron speedy 71.0.3578.94
I am having this issue when attempting to download a file to local storage (Downloads folder).

Google Chrome	 71.0.3578.94 (Official Build) (64-bit)
Revision	 6da2ba233559398092dabd8dc7bc8e78cd758307-refs/branch-heads/3578@{#890}
Platform	 11151.59.0 (Official Build) stable-channel nautilus-unibuild (nautilus nautiluslte)
Firmware Version Google_Nautilus.10431.81.0
I, too, have this issue when downloading a file to local storage(Downloads
folder).

Chrome OS Version 71.0.3578.94 (Official Build) (64-bit)
Platform  11151.59.0 (Official Build) stable-channel samus
Firmware  Google_Samus.6300.276.0
A few minutes after posting my "me too" comment above, I re-tried downloading the file that failed, and it succeeded without giving the error. That was still using the same version of Chrome OS.
The issue is also no longer a problem on my Chromebook (fixed by a restart).

Sign in to add a comment