New issue
Advanced search Search tips
Starred by 21 users

Issue metadata

Status: Unconfirmed
Owner: ----
Components:
EstimatedDays: ----
NextAction: ----
OS: Windows
Pri: 2
Type: Bug



Sign in to add a comment
link

Issue 873097: Failed to load

Reported by l...@factus.dk, Aug 10

Issue description

UserAgent: Mozilla/5.0 (Windows NT 10.0; Win64; x64) AppleWebKit/537.36 (KHTML, like Gecko) Chrome/68.0.3440.106 Safari/537.36

Steps to reproduce the problem:
1. install chrome offline for Windows Server 2016 build 1709
2. go to c:\program files (x86)\google\applications\ 
3. run chrome.exe or chrome.exe --headless

What is the expected behavior?
At least with headless, a chrome process should start.

What went wrong?

Chrome crashes with this error:  (from a powershell console)
.\chrome.exe : [0810/095914.783:ERROR:main_dll_loader_win.cc(134)] Failed to load Chrome DLL from C:\Program Files (x86)\Google\Chrome\Application\68.0.3440.106\chrome.dll: The spec ified module could not be found. (0x7E)
    + CategoryInfo          : NotSpecified: ([0810/095914.78...e found. (0x7E):String) [], RemoteException
    + FullyQualifiedErrorId : NativeCommandError

Crashed report ID: 

How much crashed? Whole browser

Is it a problem with a plugin? No 

Did this work before? No 

Chrome version: 68.0.3440.106  Channel: stable
OS Version: Server 2016 build 1709
Flash Version: 

This is a windows server core, with no ui. 1709 only comes in this flavor, and I am using it as a buildserver. I am guessing that maybe some ui components could be missing?  It is intended to work on this Windows Server version?  I haven't been able to google anyone getting this to work OR having the problem on this windows server version.
 

Comment 1 Deleted

Comment 2 by l...@factus.dk, Aug 10

Just to add. The goal is to run seleniums tests in a headless chrome on the server during a build or deployment. 

I can see that Microsoft has hosted build agents running windows server 2016 where Chrome and chromedriver is installed to run selenium tests. The difference is that this is the 1709 build of windows server, and it only comes as a core server with no UI parts that can be installed. Don't know if that makes a difference.

Comment 3 by tgunn...@gmail.com, Aug 14

Just to add. 

Did this work before? Yes.  (previous version was Chrome 66.0.3359.139 Stable, and worked consistently on build machine)

After updating to Chrome Stable 68.0.3440.106 issue presented. 



OS version: Windows Server 2016 1607 (10.0.14393.2363)

Error:

13/194748.152:ERROR:main_dll_loader_win.cc(134)] Failed to load Chrome DLL from C:\Program Files (x86)\Google\Chrome\Application\68.0.3440.106\chrome.dll: The specified module could not be found. (0x7E)

Comment 4 by christop...@gmail.com, Aug 15

We get the same error on our microsoft/windowsservercore docker containers.

We use these for running browser tests as part of our jenkins pipeline:

```
10 08 2018 13:40:46.411:INFO [launcher]: Launching browser ChromeHeadlessMoodStandard with unlimited concurrency
10 08 2018 13:40:46.417:INFO [launcher]: Starting browser ChromeHeadless
10 08 2018 13:40:46.580:ERROR [launcher]: Cannot start ChromeHeadless
	[0810/134046.535:ERROR:main_dll_loader_win.cc(134)] Failed to load Chrome DLL from C:\Program Files (x86)\Google\Chrome\Application\68.0.3440.106\chrome.dll: The specified module could not be found. (0x7E
```

Comment 5 by l...@factus.dk, Aug 15

Hi Christop...  Did you ever have it working in your Jenkins pl and do you remember what were the versions of Chrome and the Chromedriver where it worked?  I'd try and rollback to those versions if possible to see if I get it working on windows coreserver 1709

Also - what label of the docker image are you running?  Is it the old 2016 Windows Server core, or the newer and smaller 1709?

Comment 6 by tgunn...@gmail.com, Aug 15

The work around we used to get Chrome back up (ie. builds back up and running again on our Jenkins Swarms). 

- revert back to Chrome 66.0.3359.139
- disable auth-update using the registry tweak.

(see https://www.chromium.org/administrators/turning-off-auto-updates)




@ l...@factus.dk:

we're running: 'openjdk:8-windowsservercore' which iirc is windowsservercore 10.0.14393.2068

Comment 7 by l...@factus.dk, Aug 15

Brilliant. Thanks. Worked for me as well on Windows Server Core 1709. So can confirm this works in chrome 66.0.3359.181   But fails on 68.0.3440.106

Comment 8 by christop...@gmail.com, Aug 16

This has been working fine for over 8 months.

My docker container is running Windows Version 10.0.14393 which I think is 1607?

When Chrome updated to 68.0.3440.106 is when it stopped working I don't know the version before this I will try and find out. This is using karma-chrome-launcher which launches chrome directly as far as I am aware so no chromedriver involved.

Comment 9 by christop...@gmail.com, Aug 16

How did you guys go about reverting back to Chrome 66.0.3359.139? use chromium instead?

Comment 10 by jcai...@gmail.com, Aug 16

I am also seeing this issue.

I posted a stack overflow question about it as well.
https://stackoverflow.com/questions/51860091/does-chromium-headless-work-on-windows-server-core-2016

Comment 11 by tgunn...@gmail.com, Aug 16

christop...@gmail.com

we use choco for our installs, so revert was done that way - then disabled auto-updates.

Comment 12 by l...@factus.dk, Aug 16

But choco uses the online installer, meaning choco install googlechrome --version 66.xyz will still get you Chrome version 68. 

On the choco page it says "This package always installs the latest version of Google Chrome, regardless of the version specified in the package. Google does not officially offer older versions of Chrome for download." 

I ended up uninstalling via Choco and the going here https://www.slimjet.com/chrome/google-chrome-old-version.php to download version 66. 

And then I started it before I followed Christop's link to how to disable automatic updates. So I got to do it two times ... :-D

Comment 13 by christop...@gmail.com, Aug 16

Awesome thanks l...@factus.dk will give that a go and update our docker files to not do a choco install and use that fixed version instead.

Comment 14 by steven.c...@gmail.com, Sep 6

Any update on this issue? I am running into the same issue when running an automated test during a build process.
Capture.PNG
8.5 KB View Download

Comment 15 by harvey.k...@just-eat.com, Sep 19

Any update? I've tried Chrome version 69.0.3497.100 and same result on Windows 2016 Core and Windows Server 1803.

Comment 16 by l...@factus.dk, Sep 20

@harvey  I don't think this issue has been picked up and flagged as an issue. Looking at the metadata is is "unconfirmed" and nextaction is blank. I was the original creator, and not sure how to move this forward or raise it any higher powers ... :-/

Comment 17 by rogersil...@gmail.com, Oct 2

Same issue here with 1907 and chrome 69.x - was working as of chrome 67.x

Comment 18 by justin.s...@gmail.com, Oct 8

Same issue with Windows 10.0.14393 and Chrome 69.0.3497.0

Comment 19 by ryanebe...@gmail.com, Oct 22

Has this been resolved in Chrome 70?

Comment 20 by jd.cain...@gmail.com, Oct 24

I can confirm having this issue with Chrome 70 in Server Core 2016 ltsb

Comment 21 by jd.cain...@gmail.com, Oct 26

I was able to download Chromium 72.0.3592.0 via Chocolatey and the issue is resolved in that version.

Comment 22 by paulir...@chromium.org, Oct 31

Components: Internals>Headless

Comment 23 by abdulsam...@gmail.com, Nov 1

I can also confirm I was able to download Chromium 72.0.3592.0 via Chocolatey and the issue is resolved in that version.

Sign in to add a comment