New issue
Advanced search Search tips
Note: Color blocks (like or ) mean that a user may not be available. Tooltip shows the reason.

Issue 871692 link

Starred by 6 users

Issue metadata

Status: Duplicate
Merged: issue 870861
Owner:
Last visit > 30 days ago
Closed: Aug 12
Cc:
Components:
EstimatedDays: ----
NextAction: ----
OS: Windows
Pri: 1
Type: Bug



Sign in to add a comment

Flaky mocha tests

Project Member Reported by rakina@chromium.org, Aug 7

Issue description

Blockedon: -87166 871666
Description: Show this description
Owner: dschuyler@chromium.org
Some other CrSettings tests are failing. Maybe problem with mocha? Reverted on https://chromium-review.googlesource.com/c/chromium/src/+/1166562
Blockedon: 872027
Blockedon: 872026
Blockedon: 872028
Project Member

Comment 7 by bugdroid1@chromium.org, Aug 8

The following revision refers to this bug:
  https://chromium.googlesource.com/chromium/src.git/+/0b4a1c44cc93eaa962988b5d0c1f187be6602298

commit 0b4a1c44cc93eaa962988b5d0c1f187be6602298
Author: Rakina Zata Amni <rakina@chromium.org>
Date: Wed Aug 08 04:44:18 2018

Disable Flaky CrSettings tests

TBR=dschuyler@chromium.org

Bug:  87206 , 872027 , 872028 , 871692 
Change-Id: I798194cdb7ee2059565940791b751856611ed34a
Reviewed-on: https://chromium-review.googlesource.com/1166562
Reviewed-by: Rakina Zata Amni <rakina@chromium.org>
Commit-Queue: Rakina Zata Amni <rakina@chromium.org>
Cr-Commit-Position: refs/heads/master@{#581471}
[modify] https://crrev.com/0b4a1c44cc93eaa962988b5d0c1f187be6602298/chrome/test/data/webui/settings/cr_settings_browsertest.js

Cc: dpa...@chromium.org
 Issue 871543  has been merged into this issue.
 Issue 871544  has been merged into this issue.
 Issue 871545  has been merged into this issue.
 Issue 871546  has been merged into this issue.
 Issue 871547  has been merged into this issue.
 Issue 871548  has been merged into this issue.
 Issue 871666  has been merged into this issue.
Cc: dschuyler@chromium.org
 Issue 872026  has been merged into this issue.
 Issue 872027  has been merged into this issue.
 Issue 872028  has been merged into this issue.
Labels: -Pri-2 Sheriff-Chromium OS-Windows Pri-1
Tons more tests failing, going to disable and dupe in a lot more.  Raising to P1.  Something is wrong.
 Issue 873371  has been merged into this issue.
 Issue 873370  has been merged into this issue.
 Issue 873369  has been merged into this issue.
 Issue 873368  has been merged into this issue.
 Issue 873367  has been merged into this issue.
Summary: Flaky mocha tests (was: Flaky CrSettings tests)
 Issue 871541  has been merged into this issue.
 Issue 871540  has been merged into this issue.
 Issue 871539  has been merged into this issue.
Here's a sample failure:

[ RUN      ] CrSettingsSiteListTest.SiteList
[5352:5580:0803/014334.734:WARNING:discovery_network_list_win.cc(195)] Failed to open Wlan client handle: 1062
[5352:3796:0803/014334.773:WARNING:chrome_browser_main_win.cc(654)] Command line too long for RegisterApplicationRestart:  --brave-new-test-launcher --cfi-diag=0 --disable-gpu-process-for-dx12-vulkan-info-collection --gtest_also_run_disabled_tests --gtest_filter=CrSettingsSiteListTest.SiteList --single_process --test-launcher-bot-mode --test-launcher-output="e:\b\swarm_slave\w\itddel73\scoped_dir3032_21861\results3032_29044\test_results.xml" --test-launcher-summary-output="e:\b\swarm_slave\w\ioepcw4j\output.json" --user-data-dir="e:\b\swarm_slave\w\itddel73\scoped_dir3032_21861\d3032_31041" --disable-offline-auto-reload --enable-blink-features=MojoJSTest --no-first-run --no-default-browser-check --enable-logging=stderr --disable-default-apps --wm-window-animations-disabled --disable-component-update --test-type=browser --force-color-profile=srgb --disable-zero-browsers-open-for-tests --ipc-connection-timeout=30 --allow-file-access-from-files --dom-automation --log-gpu-control-list-decisions --disable-backgrounding-occluded-windows --disable-gl-drawing-for-tests --override-use-software-gl-for-tests --force-color-profile=srgb --disable-compositor-ukm-for-tests --enable-features=SiteSettings,TestFeatureForBrowserTest1 --disable-features=NetworkPrediction,SpeculativePreconnect,TestFeatureForBrowserTest2 --disable-gpu-process-for-dx12-vulkan-info-collection --flag-switches-begin --flag-switches-end --file-url-path-alias="/gen=e:\b\swarm_slave\w\ir\out\Release\gen" --restore-last-session about:blank
[3196:4896:0803/014334.802:INFO:media_foundation_video_encode_accelerator_win.cc(346)] Windows versions earlier than 8 are not supported.
[5352:3796:0803/014335.128:WARNING:gaia_auth_fetcher.cc(924)] Could not reach Google Accounts servers: errno -11
[5352:3796:0803/014336.127:WARNING:gaia_auth_fetcher.cc(924)] Could not reach Google Accounts servers: errno -11
[5352:3796:0803/014336.675:WARNING:CONSOLE(44)] "Throttling history state changes to prevent the browser from hanging.", source: chrome://settings/crisper.js (44)
[5352:3796:0803/014337.988:INFO:CONSOLE(1236)] "Running TestCase CrSettingsSiteListTest.SiteList", source: file:///E:/b/swarm_slave/w/ir/chrome/test/data/webui/test_api.js (1236)
[5352:3796:0803/014338.020:ERROR:CONSOLE(48)] "Mocha test failed: SiteList "before each" hook for "read-only attribute"
TypeError: Cannot read property 'GEOLOCATION' of undefined
    at populateTestExceptions (file:///E:/b/swarm_slave/w/ir/chrome/test/data/webui/settings/site_list_tests.js:85:39)
    at Context.<anonymous> (file:///E:/b/swarm_slave/w/ir/chrome/test/data/webui/settings/site_list_tests.js:270:5)
", source: file:///E:/b/swarm_slave/w/ir/chrome/test/data/webui/mocha_adapter.js (48)
[5352:3796:0803/014338.021:ERROR:CONSOLE(48)] "Mocha test failed: SiteList "after each" hook for "read-only attribute"
TypeError: Cannot read property '$$' of undefined
    at closeActionMenu (file:///E:/b/swarm_slave/w/ir/chrome/test/data/webui/settings/site_list_tests.js:301:30)
    at Context.<anonymous> (file:///E:/b/swarm_slave/w/ir/chrome/test/data/webui/settings/site_list_tests.js:280:5)
", source: file:///E:/b/swarm_slave/w/ir/chrome/test/data/webui/mocha_adapter.js (48)
[5352:3796:0803/014338.028:ERROR:web_ui_test_handler.cc(100)] Test Errors: 2/2 tests had failed assertions.
[5352:3796:0803/014338.028:ERROR:web_ui_browser_test.cc(481)] CONDITION FAILURE: encountered javascript console error(s):
[5352:3796:0803/014338.028:ERROR:web_ui_browser_test.cc(483)] JS ERROR: '[5352:3796:0803/014338.020:ERROR:CONSOLE(48)] "Mocha test failed: SiteList "before each" hook for "read-only attribute"
TypeError: Cannot read property 'GEOLOCATION' of undefined
    at populateTestExceptions (file:///E:/b/swarm_slave/w/ir/chrome/test/data/webui/settings/site_list_tests.js:85:39)
    at Context.<anonymous> (file:///E:/b/swarm_slave/w/ir/chrome/test/data/webui/settings/site_list_tests.js:270:5)
", source: file:///E:/b/swarm_slave/w/ir/chrome/test/data/webui/mocha_adapter.js (48)
'
[5352:3796:0803/014338.028:ERROR:web_ui_browser_test.cc(483)] JS ERROR: '[5352:3796:0803/014338.021:ERROR:CONSOLE(48)] "Mocha test failed: SiteList "after each" hook for "read-only attribute"
TypeError: Cannot read property '$$' of undefined
    at closeActionMenu (file:///E:/b/swarm_slave/w/ir/chrome/test/data/webui/settings/site_list_tests.js:301:30)
    at Context.<anonymous> (file:///E:/b/swarm_slave/w/ir/chrome/test/data/webui/settings/site_list_tests.js:280:5)
", source: file:///E:/b/swarm_slave/w/ir/chrome/test/data/webui/mocha_adapter.js (48)
'
[5352:3796:0803/014338.028:ERROR:web_ui_browser_test.cc(485)] JS call assumed failed, because JS console error(s) found.
gen/chrome/test/data/webui/settings/cr_settings_browsertest-gen.cc(1697): error: Value of: RunJavascriptTestF( true, "CrSettingsSiteListTest", "SiteList")
  Actual: false
Expected: true
Stack trace:
Backtrace:
	StackTraceGetter::CurrentStackTrace [0x01BEF7C8+40]
	testing::internal::UnitTestImpl::CurrentOsStackTraceExceptTop [0x01BF8225+69]
	testing::internal::AssertHelper::operator= [0x01BF7E70+48]
	CrSettingsSiteListTest_SiteList_Test::RunTestOnMainThread [0x01B35411+721]
	content::BrowserTestBase::ProxyRunTestOnMainThreadLoop [0x03CF9619+441]
	ChromeBrowserMainParts::PreMainMessageLoopRunImpl [0x04B41311+3169]
	ChromeBrowserMainParts::PreMainMessageLoopRun [0x04B405EA+170]
	content::BrowserMainLoop::PreMainMessageLoopRun [0x027E4504+68]
	content::StartupTaskRunner::RunAllTasksNow [0x02B6396E+30]
	content::BrowserMainLoop::CreateStartupTasks [0x027E32A5+805]
	content::BrowserMainRunnerImpl::Initialize [0x027E6994+100]
	content::BrowserMain [0x027E15DA+138]
	content::RunBrowserProcessMain [0x03A42C74+84]
	content::ContentMainRunnerImpl::Run [0x03A4345A+538]
	content::ContentServiceManagerMainDelegate::RunEmbedderProcess [0x03A428F3+19]
	service_manager::Main [0x0428AD88+1384]
	content::ContentMain [0x03A42BC3+51]
	content::BrowserTestBase::SetUp [0x03CF9393+1923]
[5352:3732:0803/014338.306:WARNING:discardable_shared_memory_manager.cc(431)] Some MojoDiscardableSharedMemoryManagerImpls are still alive. They will be leaked.
[5352:3796:0803/014339.088:WARNING:pref_notifier_impl.cc(23)] Pref observer found at shutdown.
[5352:3796:0803/014339.088:WARNING:pref_notifier_impl.cc(23)] Pref observer found at shutdown.
[  FAILED  ] CrSettingsSiteListTest.SiteList, where TypeParam =  and GetParam() =  (4614 ms)
 Issue 872195  has been merged into this issue.
 Issue 873366  has been merged into this issue.
 Issue 873365  has been merged into this issue.
Cc: aboxhall@chromium.org quacht@google.com mgiuca@chromium.org hcarmona@chromium.org
 Issue 872575  has been merged into this issue.
Cc: palmer@chromium.org
Note: this may be a dupe of  bug 870861 .
Leaving in sheriff queue until this is either fixed or the assignee otherwise indicates activity.
Mergedinto: 870861
Status: Duplicate (was: Assigned)
Seems to indeed be a dupe.

Sign in to add a comment