New issue
Advanced search Search tips
Note: Color blocks (like or ) mean that a user may not be available. Tooltip shows the reason.
Starred by 2 users

Issue metadata

Status: WontFix
Owner:
Closed: Jul 2018
Cc:
Components:
EstimatedDays: ----
NextAction: ----
OS: ----
Pri: 1
Type: Bug-Regression



Sign in to add a comment
link

Issue 855181: CPU overload and tab crash when page loads

Reported by zenpos...@gmail.com, Jun 21 2018

Issue description

UserAgent: Mozilla/5.0 (Macintosh; Intel Mac OS X 10_13_5) AppleWebKit/605.1.15 (KHTML, like Gecko) Version/11.1.1 Safari/605.1.15

Steps to reproduce the problem:
1. Open site url
2. Look at crash
3. Audit my code and not found any problems with it(step by step disabling of executable functions)

What is the expected behavior?
Page load finish and performing animations with fetch requests.

What went wrong?
Tab crashed without console messages.

Did this work before? Yes a month weeks ago

Chrome version: Version 69.0.3468.0 (Official Build) canary (64-bit)  Channel: canary
OS Version: OS X 10.13.5
Flash Version: I am not use flash

plain code examples thats crashes on localhost also: https://github.com/xShiftx/RevolveR
 

Comment 1 by zenpos...@gmail.com, Jun 21 2018

Affected sites examples: 

1). http://arch66.pro
2). https://cyberx.pro

Comment 2 by krajshree@chromium.org, Jun 22 2018

Labels: Needs-Triage-M69 Needs-Bisect

Comment 3 by krajshree@chromium.org, Jun 22 2018

Cc: krajshree@chromium.org
Labels: Triaged-ET Needs-Feedback
Unable to reproduce the issue on mac 10.13.5 and mac 10.13.3 using latest canary #69.0.3466.0.

Attached a screen cast for reference.

Following are the steps followed to reproduce the issue.
------------
1. Opened site url i.e http://arch66.pro/ and https://cyberx.pro/
2. Also opened html file from url: https://github.com/xShiftx/RevolveR on local host.
3. Observed that page rendered properly without any tab crash.

zenposter@ - Could you please check the issue by creating a new profile without any apps and extensions and please let us know if the issue still persist or not.
Also please let us know the url from where the chrome reported version 69.0.3468.0 (Official Build) canary (64-bit)  Channel: canary was downloaded as the version is still not available in the market.

Thanks...!!
855181.mp4
5.2 MB View Download

Comment 4 by krajshree@chromium.org, Jun 22 2018

Also unable to reproduce the issue using latest canary #69.0.3468.2.

zenposter@ - Please ignore the comment i.e "Also please let us know the url from where the chrome reported version 69.0.3468.0 (Official Build) canary (64-bit)  Channel: canary was downloaded as the version is still not available in the market".

PFA the attached screen shot.

Thanks...!!
Screen Shot 2018-06-22 at 12.01.58.png
894 KB View Download

Comment 5 by zenpos...@gmail.com, Jun 22 2018

Thanks for reply!

Thats my video with this issue: https://youtu.be/_QSzXVncnxU

In Windows, Linux and MacOS it look like identical and affected all chromium based browsers.

Comment 6 by sheriffbot@chromium.org, Jun 22 2018

Project Member
Labels: -Needs-Feedback
Thank you for providing more feedback. Adding the requester to the cc list.

For more details visit https://www.chromium.org/issue-tracking/autotriage - Your friendly Sheriffbot

Comment 7 by krajshree@chromium.org, Jun 25 2018

Components: -Blink Blink>JavaScript
Labels: -Pri-2 -Needs-Bisect ReleaseBlock-Stable RegressedIn-68 Target-69 M-68 Target-68 FoundIn-68 FoundIn-69 Pri-1
Status: Untriaged (was: Unconfirmed)
Able to reproduce the issue on mac 10.13.3 using chrome reported version #69.0.3468.0 and latest canary #69.0.3469.2. Issue is specific to OS-Mac.

Bisect Information:
=====================
Good build: 68.0.3439.0
Bad Build : 68.0.3440.0

Note: Unable to provide the per-revision bisect results as on running the script got all the good builds and also the issue is very inconsistent.

Hence, requesting someone from Blink>JavaScript team to please help us in assigning it to the correct owner and marking it as untriaged. Adding label RBS for M-68.

Thanks...!!

Comment 8 by zenpos...@gmail.com, Jun 26 2018

Thank you for a reply, krajshree.

The bug founded also under Windows on latest Chromium.
Symptoms identical?

I use Kaby Lake i3 with 10.13.5 and Windows 10. 

Also I found this issue under Linux live USB with Chrome.

Check carefully.

Comment 9 by abdulsyed@google.com, Jul 3 2018

Bulk update: M68 stable cut is scheduled for July 19th. This issue is marked as RB-Stable, so please take a look at it before. Thanks!

Comment 10 by hablich@chromium.org, Jul 9 2018

Cc: ahaas@chromium.org
Can anybody please provide us with a crash id?

Comment 11 by jmukthavaram@chromium.org, Jul 12 2018

Friendly ping to get an update as per C#10?
Thanks...!

Comment 12 by abdulsyed@google.com, Jul 16 2018

krajshree@ can you please provide crash ids?

Comment 13 by abdulsyed@google.com, Jul 16 2018

Cc: manoranj...@chromium.org

Comment 14 by hablich@chromium.org, Jul 17 2018

Cc: neis@chromium.org

Comment 15 by krajshree@chromium.org, Jul 17 2018

The crash id as requested at comment #12 is as follows:
ff69962a166f34ee

Thanks...!!

Comment 16 by krajshree@chromium.org, Jul 17 2018

Screen Shot 2018-07-17 at 15.37.43.png
63.4 KB View Download

Comment 17 by neis@chromium.org, Jul 17 2018

Cc: -neis@chromium.org
Owner: neis@chromium.org
Status: Assigned (was: Untriaged)

Comment 18 by neis@chromium.org, Jul 17 2018

Labels: -OS-Mac

Comment 19 by neis@chromium.org, Jul 18 2018

Status: WontFix (was: Assigned)
I was able to reproduce the hang on https://cyberx.pro. That's simply an inifite loop in the site's code. Specifically, in function "effects" in revolver.js:

for (var a = 0, b = 1; 1; a += b, b /= 2){
  if (f >= (7 - 4 * a) / 11){
    value = b * b - Math.pow((11 - 6 * a - 11 * f) / 4, 2);
    break;
  }
}

This runs forever with
a: 2
b: 0
f: -0.09901999993642172

Comment 20 by zenpos...@gmail.com, Jul 19 2018

neis@chromium.org, not true.

Without any active effects(via request animation frame) issue have an effect again.
And why this works perfect in FireFox, Edge and Safari?

This not a error.

Comment 21 by neis@chromium.org, Jul 19 2018

Status: Assigned (was: WontFix)
Okay, I'm taking another look to see if there's a deeper problem.

Comment 22 by neis@chromium.org, Jul 19 2018

I can't find any.

The value f with which the effects function gets called is very timing dependent, that might explain why you're not hitting the bad case with other browsers.

If there's a Chrome version that you think is "fine", let me know and I can check it.

Comment 23 by zenpos...@gmail.com, Jul 19 2018

> I can't find any.

Sorry. It's really bounce issue. Test it around 50 times. Looks like all work like a charm for now without apply this effect. Big Thanks!

Comment 24 by neis@chromium.org, Jul 19 2018

Status: WontFix (was: Assigned)

Sign in to add a comment