New issue
Advanced search Search tips
Starred by 1 user

Issue metadata

Status: Duplicate
Merged: issue 848210
Owner: ----
Closed: Jun 5
EstimatedDays: ----
NextAction: ----
OS: Mac
Pri: 2
Type: Bug-Regression



Sign in to add a comment

Synchronous AJAX calls result in 100% CPU from Google Chrome Helper

Reported by rober...@twasink.net, Jun 5

Issue description

UserAgent: Mozilla/5.0 (Macintosh; Intel Mac OS X 10_13_4) AppleWebKit/605.1.15 (KHTML, like Gecko) Version/11.1 Safari/605.1.15

Steps to reproduce the problem:
1. Open the Task Manager so that you can see how much CPU is used by each tab.
2. Open the Dev Tools in a tab.
3. In the console, type the following, to trigger a synchronous AJAX call:

function reqListener () {
  console.log(this.responseText);
}

var oReq = new XMLHttpRequest();
oReq.addEventListener("load", reqListener);
oReq.open("GET", "http://www.example.org/example.txt", false);
oReq.send();

4. Note that the CPU consumption of that tab jumps to about 100%, as reported by the Task Manager.

What is the expected behavior?
Synchronous AJAX calls are rightly deprecated, as they can cause the browser to lock up. But the CPU is not expected to go to 100% and stay there.

What went wrong?
The Google Chrome Helper process seems to get stuck in a loop following a synchronous AJAX call. It remains in this state as long as that browser tab is open, even if you navigate away.

Did this work before? Yes Either 65 or 66

Does this work in other browsers? Yes

Chrome version: 67.0.3396.62  Channel: stable
OS Version: OS X 10.13.4
Flash Version: 

The use of the synchronous AJAX call is occurring only in my development environment; it fetches javascript files that are not collated into a single file. So it's not a production problem. However, it remains very annoying.
 
If the page you have open when you do the AJAX call uses HTTPS, you'll need to do the same in the XMLHttpRequest, otherwise it doesn't get invoked.
Looks like a duplicate of  bug 848210  fixed in 67.0.3396.71.
Try forcing an update of Chrome (maybe by running the web installer again).
It's probably a duplicate then - even after re-installing and changing to the beta build, I'm still on 67.0.3396.62. I'll retest when the beta or stable next gets updated.

I'll need to up my search-fu skills, seeing as how I didn't spot the existing bug report.
Mergedinto: 848210
Status: Duplicate (was: Unconfirmed)
I can confirm that it's fixed in the latest release (67.0.3396.79)

Sign in to add a comment