New issue
Advanced search Search tips

Issue 848232 link

Starred by 9 users

Issue metadata

Status: WontFix
Owner:
Closed: Jun 2018
Cc:
Components:
EstimatedDays: ----
NextAction: ----
OS: Windows
Pri: 2
Type: Bug



Sign in to add a comment

[14452:3972:0531/170507.354:ERROR:install_util.cc(597)] Unable to read registry value HKLM\SOFTWARE\Policies\Google\Chrome\MachineLevelUserCloudPolicyEnrollmentToken for writing result=2

Reported by tadesus...@gmail.com, May 31 2018

Issue description

UserAgent: Mozilla/5.0 (Windows NT 10.0; Win64; x64) AppleWebKit/537.36 (KHTML, like Gecko) Chrome/67.0.3396.62 Safari/537.36

Steps to reproduce the problem:
1. download chrome drive
2. create chrome driver object
3. while navigating problem will occure

What is the expected behavior?
After creating chrome driver object I should be able to navigate

What went wrong?
https://github.com/SeleniumHQ/selenium/issues/5966#issuecomment-393507820

Did this work before? N/A 

Does this work in other browsers? Yes

Chrome version:  67.0.3396.62  Channel: stable
OS Version: 10.0
Flash Version: 

OS: Windows 10
Selenium Version: 3.11.0
Browser: Chrome
Chrome driver: 2.39.562718

Browser Version: Version 67.0.3396.62 (Official Build) (64-bit)
 
This is also an error:
[14596:10928:0531/174034.867:ERROR:install_util.cc(589)] Unable to create registry key HKLM\SOFTWARE\Policies\Google\Chrome for reading result=2

Comment 2 by gov...@chromium.org, May 31 2018

Cc: pbomm...@chromium.org
Labels: Needs-Triage-M67
Cc: georgesak@chromium.org
Components: Tests>WebDriver
Owner: johnchen@chromium.org
Status: Assigned (was: Unconfirmed)
Since this is related to Chrome driver assigning to John.
I am also getting this error, is this cuz my CHrome registry in different location than this to "Computer\HKEY_LOCAL_MACHINE\SOFTWARE\WOW6432Node\Google\Update"

Error:
Step - Verify "Actions Dropdown"
[20872:21044:0606/004528.626:ERROR:install_util.cc(589)] Unable to create registry key HKLM\SOFTWARE\Policies\Google\Chrome for reading result=2

DevTools listening on ws://127.0.0.1:12544/devtools/browser/34326d68-a92e-4249-a98c-1fe73a90a3cb

**************************************************
*                    Failures                    *
**************************************************

Executed 1 of 58 specs (1 FAILED) (57 SKIPPED) in 2 mins 52 secs.
[00:45:30] I/launcher - 0 instance(s) of WebDriver still running
[00:45:30] I/launcher - chrome #01 failed 1 test(s)
[00:45:30] I/launcher - overall: 1 failed spec(s)
[00:45:30] E/launcher - Process exited with error code 1
Labels: Needs-Feedback
I am unable to repro this issue. It might be due to some local configuration differences.

For people experiencing this issue: Does the problem occurs only when Chrome is started by ChromeDriver? What happens when you manually start Chrome from the command line?
Cc: rogerta@chromium.org zmin@chromium.org

Comment 7 by zmin@chromium.org, Jun 6 2018

Status: WontFix (was: Assigned)
Hi,

This was an log error and it has been fixed by http://crrev.com/eb49ccc013d304921d419249b955a0bf03905ca6

And this is not an error that will block Chrome usage.


Hey,

Whenever we start chrome driver manually from command line it works fine. But problem occurs when crhome is started by ChromeDriver.
I am also experiencing this issue, also using ChromeDriver.

Comment 10 by hin...@gmail.com, Jun 8 2018

I can run normally (script attachment) if not open any chrome browser on Windows 10.
However, on Windows Server 2012 R2, the issue is still present.
test.py
482 bytes View Download

Comment 11 by hin...@gmail.com, Jun 9 2018

Update:
I checked on Windows Server 2016 Datacenter Windows
Server with Desktop Experience(because I'm writing application on server platform) and the script worked well. I think the problem may be due to the operating system.
i'm also experiencing this issue when running a python script that utilizes selenium and webdriver

[8996:9684:0612/013138.978:ERROR:install_util.cc(589)] Unable to create registry key HKLM\SOFTWARE\Policies\Google\Chrome for reading result=2
I just got the reply on github 
https://github.com/SeleniumHQ/selenium/issues/5966#event-1659981641

chrome_options = webdriver.ChromeOptions()

For:

from selenium.webdriver.chrome.options import Options
chrome_options = Options()

Comment 14 by jarm...@gmail.com, Jun 18 2018

Getting the same running chromedriver via Robot Framework's Seleniumlibrary on Windows 10. However I worked around by adding the missing registry key (HKLM\SOFTWARE\Policies\Google\Chrome\MachineLevelUserCloudPolicyEnrollmentToken) manually (empty string type), after that the message doesn't appear anymore. 
I have the same issue 
Windows 10 x64,
Selenium 4.0(node),
Chrome opened by chromeDriver 
([10024:15104:0710/133607.813:ERROR:install_util.cc(589)] Unable to create registry key HKLM\SOFTWARE\Policies\Google\Chrome for reading result=2)
This is fixed in chrome version 68.0.3433.0 or later.  Please make sure that chromedriver is running the latest version of chrome.  From comment #8, it seems this may not be the case.  Please include the version of chrome when adding a comment to this issue.

Chrome driver docs at http://chromedriver.chromium.org/getting-started say:

- Ensure Chromium/Google Chrome is installed in a recognized location

  ChromeDriver expects you to have Chrome installed in the default location
  for your platform. You can also force ChromeDriver to use a custom
  location by setting a special capability.

Sign in to add a comment