New issue
Advanced search Search tips
Starred by 7 users

Issue metadata

Status: Duplicate
Merged: issue v8:7740
Owner:
Closed: May 15
Cc:
Components:
EstimatedDays: ----
NextAction: ----
OS: Windows
Pri: 1
Type: Bug-Regression



Sign in to add a comment

Crash on page with lots of Canvas updates

Reported by m...@wilmslowastro.com, May 4

Issue description

UserAgent: Mozilla/5.0 (Windows NT 10.0; Win64; x64) AppleWebKit/537.36 (KHTML, like Gecko) Chrome/66.0.3359.139 Safari/537.36

Steps to reproduce the problem:
1. Browse to https://weather.wilmslowastro.com/gauges-ss.php
2. Wait a few seconds to a few minutes
3. Aw, Snap!

What is the expected behavior?
The page should update every 5 seconds or so for 20 minutes before timing out.

What went wrong?
Crashes with Aw, Snap! error.

Crashed report ID: a949d5123a1fe70e 

How much crashed? Just one tab

Is it a problem with a plugin? No 

Did this work before? Yes 65

Chrome version: 66.0.3359.139  Channel: stable
OS Version: 10.0
Flash Version: 

This page (and many others using the same gauges code) has worked fine for years in previous versions of Chrome. It continues to work correctly in other browsers (tested IE 11, Edge, Firefox, and Safari)
 
Components: Blink>JavaScript

Comment 2 Deleted

I can confirm this issue, AND it also crashes other tabbed windows in Chrome 66 at the same time with either "Aw, Snap!" or "Cant open this page" errors
Yep same here as mentioned above. Worked for years till 66. All other browsers no issue. Just Chrome.
Me To

You can see it at scannorthcounty.net
Same here. Exactly as above.

http://weather.wi3x.com/gauges-ss.htm
Wild stab... is this something to do with SetTimeout() and the stack?
Each call to setTimeout() is now being pushed onto the stack, I do not see this with Firefox, the stack there only contains the last async call to update() in the code below. Chrome 66 the stack just grows continuously.

<!DOCTYPE HTML>
<html lang="en">
<head>
    <script>
        var count = 0;
        function update() {
            document.getElementById('update_me').innerHTML = count;
            count++;
            setTimeout(update, 1);
        }
        setTimeout(update, 1);
    </script>
</head>
<body>
    <div id="update_me"></div>
</body>
</html>
I am also confirming this.
Mergedinto: 838503
Status: Duplicate (was: Unconfirmed)
Thanks for filing the issue. As per the provided crash id in C#0, seems this issue is similar to #838503 hence merging into it.

Feel free to undup if it is not similar.

I do not think this is a duplicate of 838503, the crash happens when the dev tools are not running.
I am also getting this issue on Cumulus MX (http://localhost:8998/index.html). I am running Chrome on a Mac High Sierra 10.13.4 (17E202).  The Cumulus MX page reloads fine every time manually but then 2-3 minutes later it goes Aw Snap again. 

Status: Untriaged (was: Duplicate)
838503 is specific to DevTools. Unmerging.
Cc: ahaas@chromium.org yangguo@chromium.org jkummerow@chromium.org
I can't reproduce it on my Mac. Yang, Jakob, Andreas any clue?
This was fixed by neis@ in https://bugs.chromium.org/p/v8/issues/detail?id=7740
Labels: -Pri-2 Pri-1
Owner: neis@chromium.org
Status: Assigned (was: Untriaged)
Thanks Ulan and Georg. Can you please set this bug to fixed when appropriate and request a merge to 67 after some Canary coverage?
Cc: cbruni@chromium.org
Mergedinto: -838503 v8:7740
Status: Duplicate (was: Assigned)

Sign in to add a comment