New issue
Advanced search Search tips

Issue 835555 link

Starred by 1 user

Issue metadata

Status: Duplicate
Merged: issue 833167
Owner: ----
Closed: Apr 2018
Components:
EstimatedDays: ----
NextAction: ----
OS: Windows
Pri: 2
Type: Bug



Sign in to add a comment

Absolutely poistioned layer is mialigned in vertical layout

Reported by na...@moon.email.ne.jp, Apr 21 2018

Issue description

UserAgent: Mozilla/5.0 (Windows NT 10.0; Win64; x64; rv:61.0) Gecko/20100101 Firefox/61.0

Steps to reproduce the problem:
1. See an attached HTML file.

What is the expected behavior?
Left edge of the fixed element touches left edge of viewport.

What went wrong?
There is 17px gap (same as width of vertical scrollbar) between left edge of the fixed element and left edge of viewport.

Did this work before? N/A 

Does this work in other browsers? N/A

Chrome version: 68.0.3402.0  Channel: canary
OS Version: 10.0
Flash Version: Shockwave Flash 29.0 r0

This issue happens when:

* The principal writing mode is `vertical-rl`,
* Viewport has vertical scrollbar, and
* CSS properties that may cause hardware acceleration, such as `animation` or `transform: translateZ(0)`, are applied to the absolutely positioned element itself or its descendants.
 
20180421-positioned-layer-in-vertical-layout.html
440 bytes View Download
20180421-positioned-layer-in-vertical-layout-on-chrome.png
2.4 KB View Download

Comment 1 by woxxom@gmail.com, Apr 21 2018

Looks like a duplicate of  issue 833167 .
If you have additional info, add a comment in the original issue.
Labels: Needs-Triage-M68
Labels: Triaged-ET
Mergedinto: 833167
Status: Duplicate (was: Unconfirmed)
As per comment #1, this issue is similar to  issue 833167 . Hence merging this issue to  issue 833167 .

Thanks...

Sign in to add a comment