New issue
Advanced search Search tips
Starred by 18 users

Issue metadata

Status: Duplicate
Merged: issue 326740
Owner: ----
Closed: Apr 2018
Cc:
Components:
EstimatedDays: ----
NextAction: ----
OS: Linux , Windows , Mac
Pri: 2
Type: Feature



Sign in to add a comment
link

Issue 830832: Implement W3C MediaCapture Screen Share API

Reported by fluoresc...@gmail.com, Apr 9 2018

Issue description

UserAgent: Mozilla/5.0 (Windows NT 6.1; Win64; x64) AppleWebKit/537.36 (KHTML, like Gecko) Chrome/65.0.3325.181 Safari/537.36

Steps to reproduce the problem:
Try to capture/record (share) the screen (the whole or application/window/tab only).

What is the expected behavior?

What went wrong?
As of today, screen capturing/recording (sharing) in Chrome is available via {"mandatory": {"chromeMediaSource": "screen"}} video constraint. But:

1. it's only for Android
2. it requires enabling chrome://flags#enable-usermedia-screen-capturing flag
3. "mandatory" is old constraint syntax
4. "chromeMediaSource" is non-standard, Chrome-only thing

Also Chrome has tab sharing implemented via {"mandatory": {"chromeMediaSource": "tab"}} video constraint, but it works only in Chrome extensions.

There is a W3C MediaCapture Screen Share API spec (https://w3c.github.io/mediacapture-screen-share/). What about implementing it for all platforms (desktop and mobile)?

Currently, Firefox has partially implemented W3C MediaCapture Screen Share API spec on all platforms (mobile and desktop, not only Android) without any flags:

* {"mediaSource": "window"} video constraint to capture only application window
* {"mediaSource": "application"} video constraint to capture all application windows

Some caveats:

* Firefox uses non-standard {"mediaSource": "screen"} video constraint instead of {"mediaSource": "monitor"} to capture the whole screen
* Currently, Firefox doesn't support {"mediaSource": "browser"} video constraint

Firefox (before version 52) requires to set media.getusermedia.screensharing.enabled to true and add the web app domain to media.getusermedia.screensharing.allowed_domains in about:config.

BTW, Chrome doesn't support combining screen capture video tracks with audio tracks.

In Firefox it's easy to create a stream that contains both audio and video tracks as well. Any combination of devices and constraints can be used when configuring.

Did this work before? No 

Does this work in other browsers? Yes

Chrome version:   Channel: canary
OS Version: 
Flash Version: 

This issue is for all platforms (desktop and mobile).
 

Comment 1 by dtapu...@chromium.org, Apr 9 2018

Components: Blink>GetUserMedia

Comment 2 by krajshree@chromium.org, Apr 10 2018

Labels: Needs-Triage-M67

Comment 3 by viswa.karala@chromium.org, Apr 10 2018

Labels: -Type-Bug Triaged-ET M-67 Target-67 FoundIn-67 OS-Mac OS-Windows Type-Feature
Status: Untriaged (was: Unconfirmed)
Thanks for filing the issue!

As per comment#0 by the reporter this seems to be a feature request hence marking it as Untriaged.

Comment 4 by guidou@chromium.org, Apr 11 2018

Components: -Blink>GetUserMedia Blink>GetUserMedia>Desktop

Comment 5 by wilhelm....@gmail.com, Apr 23 2018

It's worth adding that the Screen Capture API (getDisplayMedia) is under development in Edge (https://developer.microsoft.com/en-us/microsoft-edge/platform/status/screencapture/ https://wpdev.uservoice.com/forums/257854-microsoft-edge-developer/suggestions/19334152-support-screen-capture-per-w3c-specification), and while Firefox currently uses a non-standard constraint, they are reportedly working on implementing the new standard.

Comment 6 by niklase@chromium.org, Apr 23 2018

Mergedinto: 326740
Status: Duplicate (was: Untriaged)

Sign in to add a comment