New issue
Advanced search Search tips
Note: Color blocks (like or ) mean that a user may not be available. Tooltip shows the reason.
Starred by 12 users

Issue metadata

Status: Duplicate
Merged: issue 821607
Owner:
Closed: Apr 13
Cc:
EstimatedDays: ----
NextAction: ----
OS: Chrome
Pri: 2
Type: Bug-Regression



Sign in to add a comment

freeze after sleep

Reported by brianof...@gmail.com, Apr 4

Issue description

UserAgent: Mozilla/5.0 (X11; CrOS x86_64 10323.62.0) AppleWebKit/537.36 (KHTML, like Gecko) Chrome/65.0.3325.184 Safari/537.36
Platform: 10323.62.0 (Official Build) stable-channel cyan

Steps to reproduce the problem:
1. do not use chromebook for a while (goes to sleep)
2. open lid
3. try to use keyboard, touchpad, touchscreen

What is the expected behavior?
it working normally...

What went wrong?
no keyboard, touchpad, or touchscreen input accepted. No mouse cursor visible.

This does not happen all the time after sleep. So far it happened two times SINCE THE SYSTEM UPDATE OF LAST WEEK. Need to long-press the power button to get it to reboot, then it works again.

Did this work before? Yes all the ones before the update of last week

Chrome version: 65.0.3325.184  Channel: stable
OS Version: 10323.62.0
Flash Version:
 
I'm seeing the same issue; freeze after sleep. And just as the other user indicated, this only started happening with 65.0.3325.184. I've seen it 5 times since the update. I'm using an Acer C771T. I enabled crash reporting but at least for this particular type of freeze, no information is being captured in chrome://crashes
Cc: bhthompson@chromium.org
Labels: M-65
I saw a few reports for Cave.

https://listnr.corp.google.com/report/85304451616
https://listnr.corp.google.com/report/85302862681
https://listnr.corp.google.com/report/85303683356

But seems this is not only limited to Cave.
Capture from the first EVENT log & kernel panic log:
263 | 2018-04-12 18:32:03 | Chrome OS Developer Mode
264 | 2018-04-12 18:32:24 | Kernel Event | Oops
265 | 2018-04-12 18:32:24 | Kernel Event | Panic
266 | 2018-04-12 18:32:26 | System boot | 42
267 | 2018-04-12 18:32:26 | System Reset
268 | 2018-04-12 18:32:26 | Chrome OS Developer Mode
269 | 2018-04-12 18:33:19 | Kernel Event | Oops
270 | 2018-04-12 18:33:19 | Kernel Event | Panic
271 | 2018-04-12 18:33:21 | System boot | 43
272 | 2018-04-12 18:33:21 | System Reset
273 | 2018-04-12 18:33:21 | Chrome OS Developer Mode
274 | 2018-04-12 18:44:01 | Kernel Event | Oops
275 | 2018-04-12 18:44:01 | Kernel Event | Panic
276 | 2018-04-12 18:44:03 | System boot | 44
277 | 2018-04-12 18:44:03 | System Reset
278 | 2018-04-12 18:44:03 | Chrome OS Developer Mode
279 | 2018-04-12 18:44:24 | Kernel Event | Oops
280 | 2018-04-12 18:44:24 | Kernel Event | Panic
281 | 2018-04-12 18:44:26 | System boot | 45
282 | 2018-04-12 18:44:26 | System Reset
283 | 2018-04-12 18:44:26 | Chrome OS Developer Mode
284 | 2018-04-12 18:44:55 | Kernel Event | Oops
285 | 2018-04-12 18:44:55 | Kernel Event | Panic
286 | 2018-04-12 18:44:57 | System boot | 46

<1>[   27.762388] BUG: unable to handle kernel NULL pointer dereference at 0000000000000035
<1>[   27.762403] IP: [<ffffffffc02db289>] hci_event_packet+0x1cae/0x2f21 [bluetooth]
<4>[   27.762426] PGD 0 
<4>[   27.762431] Oops: 0000 [#1] PREEMPT SMP 
<0>[   27.764533] gsmi: Log Shutdown Reason 0x03
<4>[   27.764540] Modules linked in: ip6t_REJECT nf_reject_ipv6 xt_TCPMSS ip6table_mangle veth algif_hash algif_skcipher af_alg rfcomm cmac uinput ip6table_filter snd_skl_nau88l25_max98357a snd_soc_hdac_hdmi btusb btrtl btbcm bridge snd_soc_dmic stp llc ipt_MASQUERADE nf_nat_masquerade_ipv4 snd_soc_skl btintel xt_mark bluetooth snd_soc_skl_ipc snd_soc_sst_acpi snd_soc_sst_ipc snd_soc_sst_dsp snd_hda_ext_core snd_hda_core uvcvideo videobuf2_vmalloc videobuf2_memops zram memconsole_x86_legacy memconsole snd_soc_nau8825 videobuf2_core acpi_als snd_soc_max98357a fuse snd_seq_dummy iio_trig_sysfs iwlmvm cros_ec_sensors_ring cros_ec_sensors cros_ec_sensors_core industrialio_triggered_buffer kfifo_buf industrialio snd_seq_midi snd_seq_midi_event snd_rawmidi snd_seq snd_seq_device iwlwifi iwl7000_mac80211 cfg80211 joydev
<4>[   27.764679] CPU: 1 PID: 690 Comm: kworker/u9:0 Tainted: G        W      3.18.0-16510-gb08afe9c5feb-dirty #1
<4>[   27.764689] Hardware name: Google Cave/Cave, BIOS Google_Cave.7820.347.0 11/10/2017
<4>[   27.764708] Workqueue: hci0 hci_rx_work [bluetooth]
<4>[   27.764715] task: ffff880178b74900 ti: ffff880176be4000 task.ti: ffff880176be4000
<4>[   27.764724] RIP: 0010:[<ffffffffc02db289>]  [<ffffffffc02db289>] hci_event_packet+0x1cae/0x2f21 [bluetooth]
<4>[   27.764746] RSP: 0018:ffff880176be7ce8  EFLAGS: 00010246
<4>[   27.764753] RAX: 0000000000000000 RBX: ffff880170d6e000 RCX: ffff880178b74900
<4>[   27.764761] RDX: 0000000000000000 RSI: 0000000000000100 RDI: ffff880170d6e000
<4>[   27.764769] RBP: ffff880176be7d98 R08: ffff880178b74900 R09: 0000000000000001
<4>[   27.764776] R10: 0000000000000001 R11: 000000000000000e R12: ffff880138216f00
<4>[   27.764784] R13: ffff880170d6e002 R14: ffff88012e6e0406 R15: ffff880170d6e010
<4>[   27.764792] FS:  0000000000000000(0000) GS:ffff88017ec80000(0000) knlGS:0000000000000000
<4>[   27.764801] CS:  0010 DS: 0000 ES: 0000 CR0: 0000000080050033
<4>[   27.764808] CR2: 0000000000000035 CR3: 0000000171f94000 CR4: 00000000003607e0
<4>[   27.764815] Stack:
<4>[   27.764819]  ffff880176be7d88 ffffffffba417bea ffffffffc030f7c0 0000008400000013
<4>[   27.764831]  ffff88002ab4b60b ffff88012e6eec0a 00ff880176be7d78 ffff8801431e8500
<4>[   27.764843]  00000000000168e0 0000000000000000 0000000000000000 0000000000000246
<4>[   27.764856] Call Trace:
<4>[   27.764865]  [<ffffffffba417bea>] ? pick_next_task_fair+0x2144/0x35d1
<4>[   27.764884]  [<ffffffffc02cfda1>] hci_rx_work+0x123/0x272 [bluetooth]
<4>[   27.764894]  [<ffffffffba408926>] worker_thread+0x5a8/0x874
<4>[   27.764904]  [<ffffffffba40837e>] ? worker_enter_idle+0x132/0x132
<4>[   27.764913]  [<ffffffffba59f3c9>] kthread+0x111/0x119
<4>[   27.764921]  [<ffffffffba59f2b8>] ? __kthread_parkme+0x67/0x67
<4>[   27.764931]  [<ffffffffbab7b4bc>] ret_from_fork+0x7c/0xb0
<4>[   27.764940]  [<ffffffffba59f2b8>] ? __kthread_parkme+0x67/0x67
<4>[   27.764946] Code: 48 85 c0 74 26 0f b6 48 1a 0f b6 50 35 48 8d 70 14 45 0f b6 c5 48 89 df 48 89 85 70 ff ff ff e8 28 b3 00 00 48 8b 85 70 ff ff ff <44> 8a 48 35 48 89 c7 44 88 8d 70 ff ff ff e8 49 a0 ff ff 80 bd 
<1>[   27.765042] RIP  [<ffffffffc02db289>] hci_event_packet+0x1cae/0x2f21 [bluetooth]
<4>[   27.765062]  RSP <ffff880176be7ce8>
<4>[   27.765067] CR2: 0000000000000035
<4>[   27.765073] ---[ end trace 703e07a925b6dd1d ]---
<0>[   27.771085] Kernel panic - not syncing: Fatal exception
<0>[   27.771099] Kernel Offset: 0x39400000 from 0xffffffff81000000 (relocation range: 0xffffffff80000000-0xffffffffbfffffff)
<0>[   27.771262] gsmi: Log Shutdown Reason 0x02

Capture from the second EVENT log (kernel panic log was missing):
326 | 2018-04-11 17:29:26 | ACPI Wake | S3
327 | 2018-04-11 17:29:26 | Wake Source | GPIO | 112
328 | 2018-04-11 17:29:26 | EC Event | Lid Open
329 | 2018-04-11 17:29:37 | Kernel Event | Oops
330 | 2018-04-11 17:29:37 | Kernel Event | Panic

From the third EVENT log, it seems that system was freeze after resuming from S3.

286 | 2018-04-11 23:45:03 | ACPI Wake | S3
287 | 2018-04-11 23:45:03 | Wake Source | GPIO | 112
288 | 2018-04-11 23:45:03 | EC Event | Key Pressed
289 | 2018-04-11 23:59:00 | System boot | 30
290 | 2018-04-11 23:59:00 | SUS Power Fail
291 | 2018-04-11 23:59:00 | Power Button Override
292 | 2018-04-11 23:59:00 | ACPI Wake | S5

For the first log, the kernel panic path is similar to https://bugs.chromium.org/p/chromium/issues/detail?id=821607
Cc: zhuohao@chromium.org
I believe I was able to capture another freeze; this time on 65.0.3325.209. After the dump was uploaded, I added information via https://bugs.chromium.org/p/chromium/issues/detail?id=832084 and the dump should be at crash/b79f9529700218f8
#CBC-RS/TC-watchlist

I have asked users to send feedback with #V65 freezing

RS/TC PD - Chromebooks freezing on Stable V65 
https://productforums.google.com/forum/#!private-topic/chromebook-central+rs-mentor/jXZjHH1JWAk;context-place=private-forum/chromebook-central+rs-mentor

CBC topics

Multiple Chromebook models freezing after latest update - Google Product Forums
https://productforums.google.com/forum/#!topic/chromebook-central/XSii0sqpB4M;context-place=forum/chromebook-central

Chromebook frozen, unable to shut down or reboot! - Google Product Forums
https://productforums.google.com/forum/#!topic/chromebook-central/xd0NGbvtiWA;context-place=forum/chromebook-central

Any way to capture system state during freeze? Version 65.0.3325.184 problem. - Google Product Forums
https://productforums.google.com/forum/#!topic/chromebook-central/1HO3-5-DUPU;context-place=forum/chromebook-central

Acer Chromebook 14 freezes - Google Product Forums
https://productforums.google.com/forum/#!topic/chromebook-central/PFanA6Xcdzk;context-place=forum/chromebook-central

Chromebox freezes a lot after most recent upgrade - Google Product Forums
https://productforums.google.com/forum/#!topic/chromebook-central/EBnlImiKPTk;context-place=forum/chromebook-central

Screen freezes - Google Product Forums
https://productforums.google.com/forum/#!topic/chromebook-central/KjycL-r3RkA;context-place=forum/chromebook-central

cursor frozen, keyboard not working - Google Product Forums
https://productforums.google.com/forum/#!topic/chromebook-central/6bIilYBJw6o;context-place=forum/chromebook-central



Cc: dmitrygr@google.com dtor@chromium.org
Is this possibly the same bug we have fixed with Bluetooth null pointer issues?
Cc: puneetster@chromium.org
Never mind - it seems other people have claimed that the freeze is probably in Chrome.
Cc: abodenha@chromium.org
I also think the freeze was caused by Chrome. Continue the third log(Comment #3):

From the powerd.previous log, powerd still can receive the "Power button" key and that proved that system was alive at that time (it is not a hardware hang issue). Moreover, powerd tried to ping the chrome however chrome didn't ack back:

[0411/235823:INFO:daemon.cc(530)] Power button down
[0411/235823:INFO:main.cc(225)] Launching "sync"
[0411/235823:INFO:daemon.cc(530)] Power button up
[0411/235825:INFO:activity_logger.cc(20)] User activity stopped; last reported 20 sec ago
[0411/235826:INFO:daemon.cc(530)] Power button down
[0411/235826:INFO:main.cc(225)] Launching "sync"
[0411/235828:INFO:daemon.cc(567)] Didn't receive power button acknowledgment from Chrome
[0411/235835:INFO:daemon.cc(530)] Power button up
[0411/235839:INFO:daemon.cc(782)] On battery at 65%, 2.960/4.564Ah at 0.445A, 7h31m38s until empty (7h3m47s until shutdown)
[0411/235843:INFO:daemon.cc(530)] Power button down
[0411/235843:INFO:main.cc(225)] Launching "sync"
Mergedinto: 821607
Owner: xiy...@chromium.org
Status: Duplicate (was: Unconfirmed)
Strongly suspect this is a dupe of  bug 821607 .

xiyuan, please undup if you don't agree.
For the record, since the update to

Google Chrome	65.0.3325.209 (Offizieller Build) (64-Bit)
√úberarbeitung	0
Plattform	10323.67.0 (Official Build) stable-channel cyan
Firmwareversion	Google_Cyan.7287.57.145

I no longer experienced the freezes on my Acer R11
I saw freeze/reboots on my Acer C710 on 65.0.3325.184 and 65.0.3325.209.  I am currently reverted to 65.0.3325.167 and not experiencing any issues.  See also https://productforums.google.com/forum/#!topic/chromebook-central/v5uLsvFczzs
Crosh uptime reports 14 days and change with 65.0.3325.167.  I couldn't make it through an 8 hour work day with the two subsequent releases.

Sign in to add a comment