New issue
Advanced search Search tips

Issue 820792 link

Starred by 3 users

Issue metadata

Status: Duplicate
Merged: issue 820876
Owner: ----
Closed: Mar 2018
Components:
EstimatedDays: ----
NextAction: ----
OS: Windows
Pri: 2
Type: Bug



Sign in to add a comment

Extension Option UI can't scroll under MD style extension manager

Reported by sbtalk.c...@gmail.com, Mar 11 2018

Issue description

UserAgent: Mozilla/5.0 (Windows NT 6.1; Win64; x64) AppleWebKit/537.36 (KHTML, like Gecko) Chrome/65.0.3325.146 Safari/537.36

Steps to reproduce the problem:
1. Open some extension option UI in MD extension manager

What is the expected behavior?
If the option UI is much heigher than preset, vertical scroll bar should be displayed for users to scroll down

What went wrong?
no scroll bar displayed

Did this work before? No 

Chrome version: 65.0.3325.146  Channel: stable
OS Version: 6.1 (Windows 7, Windows Server 2008 R2)
Flash Version: 

found some code update as below, seems you set dialog-body style to overflow: hidden

commit	08c0cf8984048bc5c40d01fc679c11b97c17e5a5
MD Extensions polish: Update options dialog sizing logic.

after disabled chrome://flags -- "Enable Material Design extensions", it works.
OR
use dev tool to disable this CSS, it also works.

for detail, please check with screenshot
 
001.jpg
49.2 KB View Download
002.jpg
67.2 KB View Download
003.jpg
113 KB View Download
are you able to just scroll over the dialog? unable to reproduce. 
Labels: Needs-Triage-M65

Comment 3 by a...@foosoft.net, Mar 12 2018

I have the same issue with my extension. The options popup will not show scroll bars even if its content does not all fit on the screen. This basically makes the dialog be unusable for large options pages since items lower on the page become inaccessible (no scrollbars, scrollwheel also does not work). 
Labels: Triaged-ET
Mergedinto: 820876
Status: Duplicate (was: Unconfirmed)
The issue looks similar to issue id: 820876. Hence, merging into the issue id: 820876.

Thanka...!!

Sign in to add a comment