New issue
Advanced search Search tips
Note: Color blocks (like or ) mean that a user may not be available. Tooltip shows the reason.
This site will be read-only for 3-4 hours starting at Sunday, 08:00AM PDT
Starred by 2 users

Issue metadata

Status: Fixed
Closed: Feb 12
EstimatedDays: ----
NextAction: ----
OS: Linux
Pri: 2
Type: Bug-Regression

Blocked on:
issue 744658

Sign in to add a comment

Chromium's detection of Mesa version broken

Reported by, Feb 6 Back to list

Issue description

UserAgent: Mozilla/5.0 (X11; Linux x86_64) AppleWebKit/537.36 (KHTML, like Gecko) Ubuntu Chromium/64.0.3282.119 Chrome/64.0.3282.119 Safari/537.36

Steps to reproduce the problem:
00:01.0 VGA compatible controller: Advanced Micro Devices, Inc. [AMD/ATI]
Kabini [Radeon HD 8400 / R3 Series] (amdgpu)
Mesa 17.3.3
GNOME + Xorg
+ reproducible with Ubuntu 17.10 + Mesa + google-chrome-stable/unstable

According to chrome://gpu, hardware GPU acceleration is completely turned off

Problems Detected
ATI/AMD cards with older drivers in Linux are crash-prone: 71381, 76428, 73910, 101225, 136240, 357314
Disabled Features: flash_stage3d, gpu_compositing, gpu_rasterization, flash3d, accelerated_webgl2, accelerated_2d_canvas, accelerated_video_decode, accelerated_webgl, flash_stage3d_baseline

According to the Chromium's source code , this must NOT be disabled on Mesa >=10.0.4, and I have Mesa 17.x

$ lsmod | grep amdgpu
amdgpu               2465792  0
i2c_algo_bit           20480  2 amdgpu,radeon
ttm                   122880  2 amdgpu,radeon
drm_kms_helper        225280  2 amdgpu,radeon
drm                   483328  14 amdgpu,radeon,ttm,drm_kms_helper
i2c_core               94208  8 i2c_piix4,i2c_algo_bit,amdgpu,videodev,radeon,psmouse,drm_kms_helper,drm

What is the expected behavior?

What went wrong?
I'm not sure, but I think that previous Chrome's versions (in autumn 2017) did not have this bug.

Did this work before? Yes 

Chrome version: 64.0.3282.119  Channel: stable
OS Version: 
Flash Version:
If turn of chrome://flags/#ignore-gpu-blacklist , then HW acceleration does work.

Components: Internals>GPU
Labels: Needs-Triage-M64
Labels: Needs-Bisect
Labels: Triaged-ET Thanks for the issue.

Tested this issue on Ubuntu 17.10 on Chromium 64.0.3282.119 and Unstable 64.0.3282.119 having Driver vendor: Mesa and Driver version: 17.2.2 and unable to reproduce the issue.

Cannot find the above features disabled under Problems detected in Chrome://gpu in both Chromium and Chrome builds.
Attached are the Chrome://gpu details of Chromium and Chrome.

Requesting someone from Internals>GPU team to please check and help in further triaging of the issue.

62.9 KB View Download
63.1 KB View Download
$ google-chrome-stable
[7239:7239:0207/] Lost UI shared context.
[1:10:0207/] ContextResult::kTransientFailure: Failed to send GpuChannelMsg_CreateCommandBuffer.

221 KB View Download
After chrome://flags/#ignore-gpu-blacklist ON : 
ATTENTION: default value of option force_s3tc_enable overridden by environment.
[24000:24000:0207/] InitializeSandbox() called with multiple threads in process gpu-process.

190 KB View Download
Rolled back to Chromium 61 on Ubuntu 17.10 (sudo apt install chromium-browser=61.0.3163.100-0ubuntu1.1378 chromium-codecs-ffmpeg-extra=61.0.3163.100-0ubuntu1.1378 chromium-browser-l10n=61.0.3163.100-0ubuntu1.1378)

The issue was reproduced
My integrated GPU (Radeon HD 8400 / R3) is supported by both radeon amd amdgpu kernel modules, and I tried radeon instead of amdgpu
alt+ctrl+f2, root, systemctl stop lightdm, rmmod amdgpu, systemctl restart lightdm
Nothing changed in google-chrome-stable 64

Comment 10 Deleted

To test if the GPU is really used when chrome://flags/#ignore-gpu-blacklist ON, I took google-chrome-unstable with chrome://flags/#ignore-gpu-blacklist OFF and tried to run the benchmark
It got stuck at WebGL 1.0 test

Then I set chrome://flags/#ignore-gpu-blacklist to ON, and successfully passed all the tests:

(but I got an error 
[15084:15084:0207/] [.Offscreen-For-WebGL-0x148f18a0f800]GL ERROR :GL_INVALID_OPERATION : glClear: can't be called on integer buffers
in the command-line when running WebGL 2.0 test)

When I first ran the test, probably with radeon instead of amdgpu and with #ignore-gpu-blacklist OFF, Chrome crashed and sent a dump:
Crash dump id: 
The same issue is with CentOS + Linux kernel 3.10 + radeon + Mesa 17.0 + google-chrome-stable 64
Снимок экрана от 2018-02-07 20-35-47.png
298 KB View Download
Labels: -Needs-Bisect
Unable to reproduce the issue on Ubuntu 17.10 on latest chrome stable #64.0.3282.140 having Driver vendor: Mesa and Driver version: 17.2.2.

Cannot find the above features disabled under Problems detected in Chrome://gpu in both Chromium and Chrome builds.
Attaching screen shot for reference.

As the issue is not reproducible from TE-end, hence removing the Needs-Bisect label and forwarding to Internals>GPU team for further investigation.

1.2 MB View Download
chrome://gpu shows information about the detected GPU, it will probably help to find the cause of the issue.
VENDOR = 0x1002, DEVICE= 0x9830
165 KB View Download
With chrome://flags/#ignore-gpu-blacklist ON the GL Provider and vendor are detected correctly:

196 KB View Download
Status: Assigned
Blockedon: 744658
Status: Fixed
This has been finally fixed after moving GPU info collection and blacklist decisions and SwiftShader decisions all to GPU process.

Just be patient and wait for Chrome to roll out (or be adventurous and use Chrome Developer channel instead).
Thank you

Sign in to add a comment