New issue
Advanced search Search tips
Note: Color blocks (like or ) mean that a user may not be available. Tooltip shows the reason.

Issue 784071 link

Starred by 5 users

Issue metadata

Status: Duplicate
Merged: issue 788431
Owner:
Closed: Dec 2017
Cc:
Components:
EstimatedDays: ----
NextAction: ----
OS: Windows
Pri: 2
Type: Bug


Show other hotlists

Hotlists containing this issue:
Chrome-ES


Sign in to add a comment

Magnet link application handler is not saved

Reported by lnorb...@gmail.com, Nov 11 2017

Issue description

UserAgent: Mozilla/5.0 (Windows NT 10.0; Win64; x64) AppleWebKit/537.36 (KHTML, like Gecko) Chrome/64.0.3260.2 Safari/537.36

Example URL:
magnet:?xt=urn:btih:f0b681341f8740eaee513ca742350a599d9d811d&dn=archlinux-2017.11.01-x86_64.iso&tr=udp://tracker.archlinux.org:6969&tr=http://tracker.archlinux.org:6969/announce

Steps to reproduce the problem:
1. Open a magnet link
2. The default magnet: url handler opens a window for the default associated application
3. When I check: use always, it doesn't remember next time, always asks if I want to open it in the default application

What is the expected behavior?
If I check the option for always opening the magnet url with the associated application, it should be remembered by Chrome

What went wrong?
magnet links handler (default 3rd party application) isn't saved

Does it occur on multiple sites: Yes

Is it a problem with a plugin? No 

Did this work before? Yes v63

Does this work in other browsers? Yes

Chrome version: 64.0.3260.2  Channel: dev
OS Version: 10.0
Flash Version: Shockwave Flash 27.0 r0
 
magnet.png
65.6 KB View Download
Cc: vamshi.k...@techmahindra.com
Labels: Triaged-ET Needs-Feedback Needs-Triage-M64
"@Reporter: Could you please share an accessible URL, as the links provided in comment#0 can not be opened.

Thanks! "

Comment 2 by lnorb...@gmail.com, Nov 13 2017

https://www.archlinux.org/download/ under

BitTorrent Download (recommended)
If you can spare the bytes, please leave the client open after your download is finished, so you can seed it back to others. A web-seed capable client is recommended for fastest download speeds.

**Magnet link for 2017.11.01**
Project Member

Comment 3 by sheriffbot@chromium.org, Nov 13 2017

Labels: -Needs-Feedback
Thank you for providing more feedback. Adding requester "vamshi.kommuri@techmahindra.com" to the cc list and removing "Needs-Feedback" label.

For more details visit https://www.chromium.org/issue-tracking/autotriage - Your friendly Sheriffbot
Cc: krajshree@chromium.org
Labels: Needs-Feedback
Tried testing the issue on Win-10 using chrome reported version #64.0.3260.2 but on navigating to URL: https://www.archlinux.org/download/ and clicking on the link "Magnet link for 2017.11.01" did not generate any pop up as in the magnet.png in comment #0.

Attached a screen cast for reference.

lnorbert@ - Could you please provide any other sample URL to test the issue from TE-end. This will help us in triaging the issue further.

Thanks...!!
784071.webm
3.5 MB View Download

Comment 5 by lnorb...@gmail.com, Nov 14 2017

I'll try to create a screencast too, the bug is related to a specific desktop PC, the same version works O.K. on another computers. It may be a damaged preferences file or database causing this, but I already tried to reinstall Chrome (although settings sync is on) without success.
Project Member

Comment 6 by sheriffbot@chromium.org, Nov 14 2017

Labels: -Needs-Feedback
Thank you for providing more feedback. Adding requester "krajshree@chromium.org" to the cc list and removing "Needs-Feedback" label.

For more details visit https://www.chromium.org/issue-tracking/autotriage - Your friendly Sheriffbot

Comment 7 by lnorb...@gmail.com, Nov 14 2017

Here is my screencast:
https://youtu.be/wjllv9kYRcY

And here is an another example: it's an official TV providers streaming site, which uses a 3rd party application (TVGOQuickPlayer) to play the IPTV streams. Every time it asks for enabling the player, even if the option was checked before.

https://youtu.be/-gszZLHnvUo

What can I do to fix Chrome save these ckecked options (delete or change some preferences maybe) or should I do a clean reinstall without syncing back my Chrome settings (though it would be a nightmare to set up the browser again). I already did a reinstall cleaning up the Chrome folder under c:\Users\norti\AppData\Local\Google\Chrome Dev\User Data\ before but when everything is synced back to the PC, the bug is present again. That's why I'm thinking it could be a corrupt settings or database file.
Labels: TE-NeedsTriageHelp
Unable to reproduce this issue on Windows-10 using chrome latest dev #64.0.3260.2 by following steps mentioned in the original comment.

As per comment #5 confirming this issue is related to specific hardware, adding appropriate label for further triage.

Thanks!

Comment 9 by bokan@chromium.org, Nov 15 2017

Cc: bokan@chromium.org
Components: -Blink UI>Browser>Navigation
This seems like an issue higher up in navigation.
Hi!

I'm a Top Contributor in the Spanish Google Help Forum, and some users came today to the Forum saying that they have the exact problem described in this issue in comment #1.

These are the links to the posts:
* https://productforums.google.com/d/msg/chrome-es/66a3jYVnIfU/4v8pIbmhAQAJ
* https://productforums.google.com/forum/#!topic/chrome-es/tJm1AydJmvo;noredirect=true

One of them says that he has version 63.0.3239.108.

Is there anything I can ask them so they can provide you more feedback about this issue? Both are having trouble with magnet urls, but maybe I can ask them to give me specific URLs where the issue is happening.

Thank you very much in advance!
Oh, I just saw in one screenshot that there's the following URL in which they are reproducing the problem:

http://1337x

.to/torrent/2500484/

Blade-Runner-2049-2017-CAM-720p-850MB-AAC-x264-Makintos13/ (I've separated the URL in various lines because I'm not sure it is legal to downnload that, and I wouldn't want a link to autogenerate).

BTW, the users I told you about are using Windows, and I'm unable to reproduce this in a Mac with Chrome version 63.0.3239.70 beta.

Comment 12 Deleted

Owner: dominickn@chromium.org
Is this possibly a dupe of  issue 788431 ?

Comment 14 by lnorb...@gmail.com, Dec 21 2017

It seems so :)

Comment 15 by bokan@chromium.org, Dec 21 2017

jocdeladria@, could you ask them to try it out in Canary channel?  issue 788431  landed a fix two days ago and should be in Canary. If that's fixed we can just dup into this bug (it sounds like it'll get merged to M64 so the only thing to do is wait for the next push).

Comment 16 by lnorb...@gmail.com, Dec 21 2017

bokan@ it's definitely fixed in Canary version 65.0.3300.0, thank you 

Comment 17 by bokan@chromium.org, Dec 21 2017

Mergedinto: 788431
Status: Duplicate (was: Unconfirmed)
Thanks, we'll just merge into there. It should get merged into the beta channel soon.
The same thing happens with the "PotPlayer YouTube Shortcut" extension. What it does is open a Yutube video in the Windows PotPlayer program through the extension. 

"It is possible that the web page potplayer://https://www.youtube.com/watch? V=1fz3IwQG1ws?T=0 is temporarily inactive or has been permanently moved to another address. 
ERR_UNKNOWN_URL_SCHEME"

I have installed previous versions where it worked and does not do it anymore. It seems as if something has been "destroyed" in the log file. This extension and the torrent file magnet does work in Chrome or Comodo Dragon.
#18: that possibly seems like a different issue. Can you provide a screenshot of what's happening?

Sign in to add a comment