New issue
Advanced search Search tips
Starred by 42 users
Status: Fixed
Owner: ----
Closed: Oct 29
Cc:
Components:
EstimatedDays: ----
NextAction: ----
OS: Linux, Windows, Mac
Pri: 2
Type: Bug-Regression

Restricted
  • Only users with EditIssue permission may comment.


Show other hotlists

Hotlists containing this issue:
Hotlist-1
Hotlist-1
Hotlist-1


Sign in to add a comment
Chrome crashes when accessing vSphere Web Client and other VMware products using Flash interface
Reported by lukas.w...@gmail.com, Oct 15 Back to list
UserAgent: Mozilla/5.0 (Windows NT 6.3; Win64; x64) AppleWebKit/537.36 (KHTML, like Gecko) Chrome/61.0.3163.100 Safari/537.36

Steps to reproduce the problem:
1. Open vSphere Web Client for vCenter 6.0 or later
2. After logging in, popup message "Google Chrome has stopped working" is displayed.
3. Only option is to reload Shockwave Flash but issue persists

What is the expected behavior?
After successful login, vSphere Web Client interface should be displayed.

What went wrong?
No idea, this behaviour happened after latest Google Chrome update (61.0.0163.100).

Crashed report ID: No - despite crash no Report ID is being generated

How much crashed? Just one plugin

Is it a problem with a plugin? Yes Adobe Shockwave Flash

Did this work before? Yes Any version before 61.0.0163.100

Chrome version: 61.0.3163.100  Channel: stable
OS Version: 6.3
Flash Version:
 
ChromeBrowserCrash_vSphereWebClient_151017.png
53.8 KB View Download
Similar issue on a different product: vCloud Director, same plugin crashing though, see attached file.
shockwave.PNG
4.3 KB View Download
Labels: Needs-Triage-M61 Needs-Bisect
 Issue 774772  has been merged into this issue.
replace pepflashplayer.dll by previous version 27.0.0.159 solve it. problem linked to the new flash 27.0.0.170.. and chrome not request before update plugins.
Cc: divya.pa...@techmahindra.com
Components: Internals>Plugins>Flash
Labels: Triaged-ET Needs-Feedback InternalsPluginsFlash
@ lukas.winn: We are unable to install vSphere Web Client for vCenter 6.0 on reported version 61.0.3163.100 using win 7 and win 10 as  we do not have sufficient permissions

1. Navigated to https://my.vmware.com/web/vmware/details?productId=491&downloadGroup=VC60U2 
2. logged in 
3. Clicked the Download button of VMware vCenter Server 6.0 Update 2 and Modules for Windows
4. When the file is downloaded, Insufficient permission is seen

Is there any demo URL where this can be tested and checked?

Adding Internals>Plugins>Flash for someone from the team to take a look into this
The workaround provided in Comment #4 by bau...@gmail.com worked for me and after replacing pepflashplayer.dll from v27.0.0.159 and restarting Chrome I was able to access vSphere Web Client as normal.

Is there a plan to fix the pepflashplayer.dll in Flash plugin v27.0.0.170  which is broken?
Project Member Comment 7 by sheriffbot@chromium.org, Oct 16
Labels: -Needs-Feedback
Thank you for providing more feedback. Adding requester "divya.padigela@techmahindra.com" to the cc list and removing "Needs-Feedback" label.

For more details visit https://www.chromium.org/issue-tracking/autotriage - Your friendly Sheriffbot
This isn't just a Windows issue. This also impacts macOS.
The merged ticket, 74722, has a user that has posted a working copy of the older pepflashplayer.dll file.  Replacing the current one with that file and restarting Chrome resolves my issues.  

https://bugs.chromium.org/p/chromium/issues/detail?id=774772


This is a major issue for myself and those I work with that rely on the flash player version of vsphere 6.5.  VMware Blogs has a posting about this issue now, too:  https://cloudhat.eu/latest-vcenter-latest-chrome-no-love/



Comment 10 Deleted
This is affecting me also, however simply replacing the dll is not working for me so I'm stuck. Both Firefox and Chrome.
Replacing the DLL doesn't work for me in neither Firefox or Chrome as well.
Cc: bbudge@chromium.org
After installing vSphere Web Client for vCenter 6.0, couldn't be able to log into it as it requires a valid user name and password. It may require a paid license.
Hence, ccing bbudge@ and requesting to please have a look into the issue.

Thanks...!!
You for sure don't need a paid license.
You should be able to get a 60 day trial using the following URL with any email address.

https://my.vmware.com/group/vmware/evalcenter?p=vsphere-6

This will give you access to the download bits. If you forget to note down the trial license key, don't worry about that, as the software will work for 60 days even without providing any license key.

You can then either set this up on a physical server using Windows or an ESXi hosts (if you have one) as a vCenter Server appliance.

If you prefer consumer virtualization software like VMWare workstation or Fusion (also available as a free 60 day trial if required) the setup becomes a bit more involved but is still doable. Please follow the instructions in http://www.virtuallyghetto.com/2016/10/how-to-deploy-the-vcenter-server-appliance-vcsa-6-5-running-on-vmware-fusion-workstation.html.

As for the username and password. During deploy time you have to specify a root password as as well as a password for the administrator@vsphere.local account (if you choose to not rename the default domain name).

The administrator@vsphere.local account and its password will let you log in into the Web Client then.

If you have any issues with the setup feel free to shoot me a message and I am happy to assist.
I open bug @adobe: https://tracker.adobe.com/#/view/FP-4198653
I reproduce the same with Firefox.. Chrome is just the first browser updated to lastest flashplayer 27.0.0.170.
I reproduce the same problem with latest adobe beta 27.0.0.174

The problem for Chrome is: it not display path to the flashplayer used, and version in use
If install PPAPI flashplayer, Chrome not use internal flashplayer (in pepperflash folder) if PPAPI installer is more recent that internal.. or not know how to see it (before it is displayed in chrome://plugins with all path and dll)

If not work after replace dll in pepperflash, remove flashplayer PPAPI in add/remove software (if not use OPERA; Chrome include flashplayer)
 
check version with: http://get.adobe.com/fr/flashplayer/about/


Comment 16 Deleted
Hi, I'm glad bau... opened a bug (and you should go to the Adobe site and vote for it) but be aware that Adobe claims that VMWare is the cause of the problem, specifically that some code in the Web client is to blame: 

https://forums.adobe.com/thread/2395850

"For background, to address the security issue discovered in the wild that prompted this release, we more tightly enforce rules in the initial validation of the SWF bytecode.  For some reason, the SWF that VMWare uses is failing those validation checks."

Adding my vote.  My entire team having the same issue and replacing the DLL using https://bugs.chromium.org/p/chromium/issues/attachment?aid=307292 and it still crashes.  
Sure VMWare 6U2 is the root cause: it use adobe ! (la daube in french) and this is the only reason to still use flashplayer. (we will move to 6.5 without adobe, but not immediately).
Problem is not "I can't use VMWare" but 'adobe CRASH'. 
and more time chrome crash (without impact in other tabs, thanks chrome for isolation), but chrome problem.
 (If open bad video file in my player, and it's crash. problem is the player. it must display can't read file and not crash) 

@predato...  If you have installed adobe flash PPAPI, you must remove it or install previous version (require for OPERA, but not for chrome). otherwise chrome will use the latest version it will find. (%systemRoot%\System32\Macromed\Flash\  check pepflash*.dll)

Check with http://get.adobe.com/fr/flashplayer/about/ if you use 27.0.0.159


Anyone with an idea to fix that on Linux ? 
I tried removing .config/google-chrome/PepperFlash/27.0.0.170 and replaced it with a 27.0.0.130, but Chrome appears to re-download 27.0.0.170 without asking... 

Cc: lafo...@chromium.org
Labels: OS-Mac
Labels: OS-Linux
Status: ExternalDependency
Thanks for the report(s).  I believe this is a dupe of 774932 (vsphere urls were common in those dumps).  Adobe is aware of this crash and investigating a fix.  We currently don't have an ETA on when a fix will be deployed.

Normally I'd dupe this into 774932, however since this particular issue is view restricted and is in Flash Player I'm setting the status to ExternalDependency, so this can remain open/ visible.
For those that replacing the .dll doesn't work try below:

I had the issue where replacing the dll in the user appdata folder was not helping, On a quick search I found that the files that needed to be replaced where in the following locations:

C:\Windows\SysWOW64\Macromed\Flash

C:\Windows\System32\Macromed\Flash

replacing the pepflashplayer64 and 32 with the pepflashplayer.dll version 27.0.0.159 and matching the old names it will resolve the issue.
2017-10-17 08_08_49-Flash.png
147 KB View Download
I can't find the attachment for replacing pepflashplayer.dll.
jgravel1...@gmail.com-  your workaround really helped!
Attached is  pepflashplayer.dll version 27.0.0.159
None of 'attached is pepflashplayer.dll' comments seem to contain attachment as such.

While appreciating commenter's intentions, this is all bit silly, with Chrome (Adobe?) support not posting the proper (official?) location of last known good pepflashplayer.dll to be used until the proper fix is made.

Searching the web for rather important part of our work infrastructure feels bit dangerous...
Thanks google again for deleting that attachment that vmware linked back to making it impossible to admin my datacenter. 
where is the attachment? 
Comment 30 Deleted
I created a blogpost. In the blogpost, at the end, you will find a link to download the  pepflashplayer.dll version 27.0.0.159 

http://up2v.nl/2017/10/18/shockwave-flash-has-crashed-in-vsphere-web-client/
Thank you for the workaround, it worked like a charm !
On Windows 10 (Versions 1703 and 1709) uninstalling KB4049179 resolves an issue with Internet Explorer.
there's an beta of adobe released which fixes the issue.
https://forums.adobe.com/thread/2395850
http://labs.adobe.com/downloads/flashplayer.html
Observed Flash player crash at end of vSphere Web Client Version 6.0.0 Build 5318172 splash/loading screen running flash-player-ppapi 27.0.0.170-release from the adobe-linux-x86_64 repository in Chromium 60.0.3112.113 on Fedora 25.

No problem running previous versions up to 27.0.0.159-release. I have not tested the Flash Player 27 Beta.

Adobe appears to not keep more than the latest version in their repo, so a simple "dnf downgrade flash-player-ppapi flash-plugin" will not work to reinstall 27.0.0.159 after the packages are updated.
Hi I did fix the issue by replacing the current folder i.e C:\Users\Username\AppData\Local\Google\Chrome\User Data\PepperFlash\27.0.0.170

and copied the contents of older flash version. I have attached the content as well, the folder name will remain same "27.0.0.170"
I can confirm running Flash Player 27 Beta has resolved the issue for me. 
Chrome - Version 62.0.3202.62 (Official Build) (64-bit)

https://forums.adobe.com/thread/2395850
http://labs.adobe.com/downloads/flashplayer.html
Labels: Restrict-AddIssueComment-EditIssue
Given that Adobe has a fix pending in their Beta release, I'm closing this issue for further comment.

If you need a workaround, please use the current Beta Flash Player release directly from Adobe, as that has both the crash fix and the security fixes (i.e., 27.0.0.159 is being actively targeted in the wild and should not be used).


Labels: -Needs-Bisect
Status: Fixed
This issue has been resolved with the latest Flash Player update 27.0.0.183, which we began deploying on Oct. 23rd.
Sign in to add a comment