New issue
Advanced search Search tips
Starred by 15 users

Issue metadata

Status: Duplicate
Merged: issue 769148
Owner: ----
Closed: Oct 2
Cc:
Components:
EstimatedDays: ----
NextAction: ----
OS: Android
Pri: 2
Type: Bug-Regression



Sign in to add a comment

Chrome 61 on Android 6.01 or 7.0 Received Video Freezes

Reported by warren.m...@gmail.com, Sep 28 2017 Back to list

Issue description

Steps to reproduce the problem:
1. Set up a WebRTC call between Windows Desktop and Android device with captured/sent video resolution higher than 320x240
2. Observe the Android browser and see that the received video track is either not rendered at all or freezes very soon. 

Or 
1. Connect call at low 320x240 resolution and confirm all is OK.
2. Screen share from Desktop at high res low frame rate (1280x720@5fps)
3. Observe Android browser is unresponsive and sharing is not displayed.  

What is the expected behavior?
Standard 640x480 or higher video tracks should decode and render well on recent Android devices. 

What went wrong?
The Android browser becomes unresponsive Chrome error sequence is report on device connected to Android Device Monitor: 

ERROR:gles2_cmd_decoder.cc(5332)] Error: 5 for Command kSwapBuffers 
ERROR:gles2_cmd_decoder.cc(15702)] Context lost because SwapBuffers failed.
ERROR:gles2_cmd_decoder.cc(4325)]   GLES2DecoderImpl: Trying to make lost context current.

Generally this continues as long as the video track is being received, but in a few tests, it did recover. 

Did this work before? Yes Works on Android 5.1.1 Samsung Tablet with same Chrome Version.

Chrome version: 61.0.3163.98  Channel: stable
OS Version: 7.0
Flash Version: 

Error is reproducible on Android 7.0 and 6.01 on
Galaxy S7/S7 Edge, HTC 10, Pixel, Nexus 5 devices
 

Comment 1 Deleted

Components: Blink>WebRTC
Requesting WebRTC team to triage.
Also reproducible on Samsung Tab S 10" with Android 6.0.1 and same browser version as above.

Comment 5 by guidou@chromium.org, Sep 29 2017

Components: -Blink>WebRTC Blink>WebRTC>Video
Mergedinto: 769148
Status: Duplicate
Found a workaround: set "border-radius: 0px" css property of the video tag. I think it changes something in the rendering process.

ps: only stops rendering if there is no debugger attached
Cc: liber...@chromium.org
 Issue 771819  has been merged into this issue.
I also have it reproduced on a Nexus 6P with Android version 8.0.0 kernel version 3.10.73-gad82c6620de built on Wed Aug 16 15:24:10 UTC.

About Chrome reports:
Application version: 61.0.3163.98
Operating system: Android 8.0.0; Nexus6P Build/OPR5.170623.007

Can confirm border-radius fixes the issue, but only if I set it to 1px in my particular application...

I tried AppRTC, but didn't get the exact same issue. There it was really slow before eventually crashing the page (!)
appear.in's new PWA thing works fine though

Sign in to add a comment