New issue
Advanced search Search tips
Starred by 1 user

Issue metadata

Status: WontFix
Closed: Sep 18
EstimatedDays: ----
NextAction: ----
OS: Chrome
Pri: 2
Type: Bug

Sign in to add a comment

x86-generic-full: build_packages: media-libs/mesa: econf failed: LLVM target 'amdgpu' not enabled

Project Member Reported by, Aug 22 2017 Back to list

Issue description

x86-generic-full fails for the last 200 builds in build_packages:

mesa-17.1.1-r4: configure: error: LLVM target 'amdgpu' not enabled in your LLVM build. Required by r600.
mesa-17.1.1-r4: !!! Please attach the following file when seeking support:
mesa-17.1.1-r4: !!! /build/x86-generic/tmp/portage/media-libs/mesa-17.1.1-r4/work/mesa-17.1.1/config.log
mesa-17.1.1-r4:  * ERROR: media-libs/mesa-17.1.1-r4::chromiumos failed (configure phase):
mesa-17.1.1-r4:  *   econf failed
Status: Assigned
Stephane, can you find someone to look at this?
Looks like a combination of LLVM toolchain changes (?) and mesa. One fix: just stop building with VIDEO_CARDS="... radeon ...". Or turn on amdgpu targets in our LLVM x86 build.
So, not to take the thunder out of anyone who'd like to work on this but... I guess we're dropping the builder:

It's just a matter of time (and restarts) before it drops off the waterfall (and everybody's radar).
not sure how this started happening. mesa does not use the same version of LLVM that we (toolchain) use. 
So, I don't know if graphics team cares about this somewhere else but we don't care about x86-generic anymore. 
Status: WontFix
if the builder is gone, then it's not relevant any longer...

Sign in to add a comment