Project: chromium Issues People Development process History Sign in
New issue
Advanced search Search tips
Starred by 0 users
Status: Duplicate
Merged: issue 757147
Owner:
Closed: Aug 22
Cc:
Components:
EstimatedDays: ----
NextAction: ----
OS: Chrome
Pri: 1
Type: Bug



Sign in to add a comment
chromiumos-sdk bot: failing to setup chroot
Project Member Reported by vapier@chromium.org, Aug 22 Back to list
last pass:
https://uberchromegw.corp.google.com/i/chromiumos/builders/chromiumos-sdk/builds/8083
first failure:
https://uberchromegw.corp.google.com/i/chromiumos/builders/chromiumos-sdk/builds/8084/steps/SDKTest/logs/stdio

INFO    cros_sdk:make_chroot: Adding user/group...
useradd: cannot create directory /home/chrome-bot
Running ['/b/c/cbuild/repository/src/scripts/sdk_lib/make_chroot.sh', '--stage3_path', '/b/c/cbuild/repository/built-sdk.tar.xz', '--chroot', '/b/c/cbuild/repository/new-sdk-chroot', '--cache_dir', '/b/c/cbuild/repository/.cache', '--nousepkg'] failed!
 
Cc: alanjones@google.com
Mergedinto: 757147
Status: Duplicate
Looks like the same error as  https://crbug.com/757147 .  I'm working on finding the cause.
Project Member Comment 3 by bugdroid1@chromium.org, Aug 24
The following revision refers to this bug:
  https://chromium.googlesource.com/chromiumos/chromite/+/95f30c12f2f0012aa5bc45ee05b1cdeae9c7b9ea

commit 95f30c12f2f0012aa5bc45ee05b1cdeae9c7b9ea
Author: Manoj Gupta <manojgupta@google.com>
Date: Thu Aug 24 06:57:00 2017

Revert "parallel_emerge: Work around Portage library bug with usepkg"

This reverts commit 14e53987cfbb1e99fa72f7517910acbb4e8ca5d4.
The revert is required to fix sdk builder breakage.

BUG= chromium:757824 ,  chromium:757147 
TEST=Chromiumos-sdk builder works after reverting the CL.
TEST=https://uberchromegw.corp.google.com/i/chromiumos.tryserver/builders/chromiumos-sdk/builds/2504

Change-Id: Ifa65f82f9b39b27eb56b8152adf14103202a2b5f
Reviewed-on: https://chromium-review.googlesource.com/625377
Trybot-Ready: Brian Norris <briannorris@chromium.org>
Tested-by: Brian Norris <briannorris@chromium.org>
Reviewed-by: Jason Clinton <jclinton@chromium.org>
Commit-Queue: Jason Clinton <jclinton@chromium.org>

[modify] https://crrev.com/95f30c12f2f0012aa5bc45ee05b1cdeae9c7b9ea/scripts/parallel_emerge.py

Sign in to add a comment