New issue
Advanced search Search tips

Issue 756868 link

Starred by 1 user

Issue metadata

Status: Duplicate
Merged: issue 754915
Owner:
Closed: Aug 2017
Components:
EstimatedDays: ----
NextAction: ----
OS: Windows
Pri: 2
Type: Bug


Participants' hotlists:
Hotlist-1


Sign in to add a comment

Doesn't keep the scroll position when exiting media viewer on Wikipedia

Reported by human.p...@gmail.com, Aug 18 2017

Issue description

UserAgent: Mozilla/5.0 (Windows NT 10.0; Win64; x64) AppleWebKit/537.36 (KHTML, like Gecko) Chrome/61.0.3163.49 Safari/537.36

Example URL:
https://en.wikipedia.org/wiki/Battle_of_Long_Tan#Battle

Steps to reproduce the problem:
1. New person (profile)
2. Open  https://en.wikipedia.org/wiki/Battle_of_Long_Tan#Battle
3. Click on the image on the right, there should be a media viewer showing the image
4. Close the said media viewer by pressing Esc or click X on the corner

What is the expected behavior?
The page should maintain its scroll position after exiting media viewer

What went wrong?
It doesn't. It jumps to the very top of that page.

Does it occur on multiple sites: Yes

Is it a problem with a plugin? No 

Did this work before? Yes 59

Does this work in other browsers? Yes

Chrome version: 62.0.3189.0  Channel: canary
OS Version: 10.0
Flash Version: Shockwave Flash 26.0 r0

Chrome 61+ is the only browser so far that I can reproduce this bug. 

I haven't narrowed the regression window yet, so not sure about 60. But I personally tested with 55.0.2870.0 it works fine. Other people reported that it works fine in 59 too.
 

Comment 1 by woxxom@gmail.com, Aug 18 2017

This is caused by scrollTopLeftInterop feature:
https://www.chromestatus.com/feature/6386758136627200

The behavior is present since r314821 (42.0.2297.0) but only by forcing scrollTopLeftInterop via command line:
chrome --enable-blink-features=ScrollTopLeftInterop

Bisect info: 481206 (good) - 481213 (bad)
https://chromium.googlesource.com/chromium/src/+log/b2e10129..31c39d8d?pretty=fuller
Suspecting r481208 "Enable scrollTopLeftInterop by default"
Landed in 61.0.3138.0
Labels: ReleaseBlock-Stable M-61 Needs-Triage-M61
Owner: dtapu...@chromium.org
Status: Assigned (was: Unconfirmed)
Thanks for the bisect. Assigning to CL owner.
Mergedinto: 754915
Status: Duplicate (was: Assigned)
seems wikipedia is using an old version of jquery.scrollTo
Reported against wikimedia: https://phabricator.wikimedia.org/T173618

Sign in to add a comment