New issue
Advanced search Search tips
Starred by 2 users
Status: Duplicate
Merged: issue 737379
Owner:
Closed: Sep 1
Cc:
EstimatedDays: ----
NextAction: ----
OS: ----
Pri: 2
Type: Bug-Regression



Sign in to add a comment
11.1% regression in thread_times.tough_scrolling_cases at 484112:484174
Project Member Reported by mustaq@chromium.org, Jul 7 Back to list
See the link to graphs below.
 
All graphs for this bug:
  https://chromeperf.appspot.com/group_report?bug_id=740120

(For debugging:) Original alerts at time of bug-filing:
  https://chromeperf.appspot.com/group_report?sid=02deaec99ee7ab32616ced6538e29942206e5b61c7b04f85482716d49db53b9b


Bot(s) for this bug's original alert(s):

android-webview-nexus6
Cc: chongz@chromium.org
Owner: chongz@chromium.org

=== Auto-CCing suspected CL author chongz@chromium.org ===

Hi chongz@chromium.org, the bisect results pointed to your CL, please take a look at the
results.


=== BISECT JOB RESULTS ===
Perf regression found with culprit

Suspected Commit
  Author : Chong Zhang
  Commit : 7c75487d4702daeff63df2bd7f4a288052cd054c
  Date   : Tue Jul 04 21:03:40 2017
  Subject: Flush TouchPad generated GestureScrollEnd immediately

Bisect Details
  Configuration: android_webview_nexus6_aosp_perf_bisect
  Benchmark    : thread_times.tough_scrolling_cases
  Metric       : thread_total_all_cpu_time_per_frame/thread_total_all_cpu_time_per_frame
  Change       : 12.33% | 57.1617562773 -> 64.2101331244

Revision             Result                   N
chromium@484111      57.1618 +- 4.83924       6      good
chromium@484143      57.6541 +- 2.88952       6      good
chromium@484151      57.1781 +- 4.86115       6      good
chromium@484155      56.8273 +- 2.06942       6      good
chromium@484156      57.3986 +- 4.17457       6      good
chromium@484157      64.5319 +- 0.787359      6      bad       <--
chromium@484159      63.6492 +- 2.62999       6      bad
chromium@484174      64.2101 +- 1.34207       6      bad

To Run This Test
  src/tools/perf/run_benchmark -v --browser=android-webview --output-format=chartjson --upload-results --pageset-repeat=1 --also-run-disabled-tests thread_times.tough_scrolling_cases

More information on addressing performance regressions:
  http://g.co/ChromePerformanceRegressions

Debug information about this bisect:
  https://chromeperf.appspot.com/buildbucket_job_status/8974716659785970416


For feedback, file a bug with component Speed>Bisection
Cc: pmeenan@chromium.org
 Issue 741723  has been merged into this issue.
Status: Started
Should be related to  issue 737379  but I'm not sure why the bisect bot points to this CL. Will see if my patch could fix this issue as well.
Perf sheriff checking in. chongz: any update on this?
Status: Assigned

=== Auto-CCing suspected CL author chongz@chromium.org ===

Hi chongz@chromium.org, the bisect results pointed to your CL, please take a look at the
results.


=== BISECT JOB RESULTS ===
Perf regression found with culprit

Suspected Commit
  Author : Chong Zhang
  Commit : 379f637084f5ccfe96bba687afaad8a75f53c3d5
  Date   : Mon Jun 26 21:23:59 2017
  Subject: Re-enable VsyncAlignedInput to Field Trial

Bisect Details
  Configuration: linux_perf_bisect
  Benchmark    : smoothness.top_25_smooth
  Metric       : mean_input_event_latency/Blogger
  Change       : 11.77% | 10.3563333333 -> 11.5751666667

Revision             Result                   N
chromium@482389      10.3563 +- 0.366163      6      good
chromium@482402      10.2005 +- 0.211848      6      good
chromium@482404      10.3508 +- 0.301889      6      good
chromium@482405      11.3428 +- 0.898892      6      bad       <--
chromium@482406      11.2372 +- 0.896876      6      bad
chromium@482409      11.2542 +- 0.826113      6      bad
chromium@482415      11.2222 +- 1.04064       6      bad
chromium@482441      11.2782 +- 0.664681      6      bad
chromium@482493      11.6112 +- 0.358565      6      bad
chromium@482597      11.4038 +- 0.521742      6      bad
chromium@482805      11.4478 +- 0.671908      6      bad
chromium@483221      11.3147 +- 0.828886      6      bad
chromium@484052      11.4863 +- 0.539089      6      bad
chromium@485714      11.5752 +- 0.666941      6      bad

To Run This Test
  src/tools/perf/run_benchmark -v --browser=release --output-format=chartjson --upload-results --pageset-repeat=1 --also-run-disabled-tests --story-filter=Blogger smoothness.top_25_smooth

More information on addressing performance regressions:
  http://g.co/ChromePerformanceRegressions

Debug information about this bisect:
  https://chromeperf.appspot.com/buildbucket_job_status/8969811321281483456


For feedback, file a bug with component Speed>Bisection
Mergedinto: 737379
Status: Duplicate
Status: Assigned

=== Auto-CCing suspected CL author chongz@chromium.org ===

Hi chongz@chromium.org, the bisect results pointed to your CL, please take a look at the
results.


=== BISECT JOB RESULTS ===
Perf regression found with culprit

Suspected Commit
  Author : Chong Zhang
  Commit : 379f637084f5ccfe96bba687afaad8a75f53c3d5
  Date   : Mon Jun 26 21:23:59 2017
  Subject: Re-enable VsyncAlignedInput to Field Trial

Bisect Details
  Configuration: linux_perf_bisect
  Benchmark    : smoothness.top_25_smooth
  Metric       : frame_times/Blogger
  Change       : 4.13% | 16.6724519547 -> 17.3614761596

Revision             Result                    N
chromium@482389      16.6725 +- 0.0582644      6      good
chromium@482402      16.6622 +- 0.0541652      6      good
chromium@482404      16.6589 +- 0.0397812      6      good
chromium@482405      17.3598 +- 0.124795       6      bad       <--
chromium@482406      17.335 +- 0.115708        6      bad
chromium@482409      17.3171 +- 0.28225        6      bad
chromium@482415      17.3079 +- 0.273509       6      bad
chromium@482441      17.3356 +- 0.170776       6      bad
chromium@482493      17.3454 +- 0.17302        6      bad
chromium@482597      17.3169 +- 0.0482933      6      bad
chromium@482805      17.3465 +- 0.21383        6      bad
chromium@483221      17.3306 +- 0.147529       6      bad
chromium@484052      17.3275 +- 0.2156         6      bad
chromium@485714      17.3615 +- 0.190322       6      bad

To Run This Test
  src/tools/perf/run_benchmark -v --browser=release --output-format=chartjson --upload-results --pageset-repeat=1 --also-run-disabled-tests --story-filter=Blogger smoothness.top_25_smooth

More information on addressing performance regressions:
  http://g.co/ChromePerformanceRegressions

Debug information about this bisect:
  https://chromeperf.appspot.com/buildbucket_job_status/8969714007565741376


For feedback, file a bug with component Speed>Bisection
Status: Duplicate
Merge into  issue 737379  according to bisect result (bisect bot changed it back somehow).

This is an expected regression since our synthetic events are generated at a rate similar to Vsync rate, thus some frames could receive no events.

Note that perf bot is showing a 16ms -> 33ms regression on frame_times/Blogger, however according to trace I believe this is caused by the low rate of VSync signal (30Hz) and not related to this issue.
perfbot-bad-trace-file-id_7-2017-07-11_19-22-58-53138.html
3.6 MB View Download
Sign in to add a comment