New issue
Advanced search Search tips
Starred by 2 users

Issue metadata

Status: Duplicate
Merged: issue 716571
Owner: ----
Closed: Aug 2017
Cc:
Components:
EstimatedDays: ----
NextAction: ----
OS: Android
Pri: 2
Type: Bug-Regression
Proj-XR



Sign in to add a comment
link

Issue 734106: Daydream controller generates mouse click events

Reported by jesm...@kaon.com, Jun 16 2017

Issue description

Steps to reproduce the problem:
1. Enter WebVR
2. Click daydream touchpad

What is the expected behavior?

What went wrong?
A mouse click at 0 0 is fired

Did this work before? Yes 58

Does this work in other browsers? N/A

Chrome version: 59.0.3071.92  Channel: stable
OS Version: 7.1.1
Flash Version:
 

Comment 1 by jesm...@kaon.com, Jun 16 2017

Sorry for the brevity. I reported it from the phone.

My WebVR page is using the Daydream controller as a gamepad. When the user clicks the touchpad part of the Daydream controller, it generates MouseEvents (Down, Up) with all the values set to 0, 0. In my application, there was a back button on the page that launched WebVR in the upper left corner, so this would take me off the page!

It's relatively easy to recognize these bogus events and reject them before they do damage, but they shouldn't be generated at all when in VR Presentation mode.

My guess is that it's the new VR Browsing feature that's generating these. Since that generates mouse clicks on pages, based on where the Daydream controller is pointed.

Comment 2 by ppolise...@chromium.org, Jun 19 2017

Components: UI>Browser>VR

Comment 3 by ddorwin@chromium.org, Jun 30 2017

Cc: klausw@chromium.org
Components: -UI>Browser>VR Blink>WebVR
Labels: Proj-VR
Important: This is a change in behavior between M58 and M59.

If you are in WebVR presentation, this may be caused by the simulated "cardboard compatible" click event, which will eventually be removed ( issue 716571 ).

 Issue 710863  modified the behavior of this simulated click at 0,0. The fix was merged into M59 but not M58, for which that issue was reported.

If other areas of the page are not receiving clicks, you may just need to avoid clickable elements at 0,0 (1,1 should be fine) until we can fix  issue 716571 .

Comment 4 by ddorwin@chromium.org, Aug 7 2017

Labels: Needs-Feedback
jesmith: Can you confirm that this is the behavior you are seeing? If so, I think we can close this as a duplicate.

Comment 5 by jesm...@kaon.com, Aug 7 2017

It sounds exactly like what I am seeing, yes.

Comment 6 by sheriffbot@chromium.org, Aug 7 2017

Project Member
Cc: ddorwin@chromium.org
Labels: -Needs-Feedback
Thank you for providing more feedback. Adding requester "ddorwin@chromium.org" to the cc list and removing "Needs-Feedback" label.

For more details visit https://www.chromium.org/issue-tracking/autotriage - Your friendly Sheriffbot

Comment 7 by ddorwin@chromium.org, Aug 8 2017

Mergedinto: 716571
Status: Duplicate (was: Unconfirmed)
Thank you for the quick response! Per  issue 716571 , we plan to resolve this in M62.

Comment 8 by btebbs@chromium.org, Jul 4 2018

Components: Blink>WebXR

Sign in to add a comment