Project: chromium Issues People Development process History Sign in
New issue
Advanced search Search tips
Starred by 1 user
Status: Duplicate
Merged: issue 722233
Owner:
Closed: May 15
Cc:
Components:
EstimatedDays: ----
NextAction: ----
OS: ----
Pri: 1
Type: Bug



Sign in to add a comment
browse:social:twitter broken on mac bots
Project Member Reported by chromium...@appspot.gserviceaccount.com, May 14 Back to list
"benchmarks.system_health_smoke_test.SystemHealthBenchmarkSmokeTest.system_health.memory_desktop.browse:social:twitter" is flaky.

This issue was created automatically by the chromium-try-flakes app. Please find the right owner to fix the respective test/step and assign this issue to them. If the step/test is infrastructure-related, please add Infra-Troopers label and change issue status to Untriaged. When done, please remove the issue from Sheriff Bug Queue by removing the Sheriff-Chromium label.

We have detected 3 recent flakes. List of all flakes can be found at https://chromium-try-flakes.appspot.com/all_flake_occurrences?key=ahVzfmNocm9taXVtLXRyeS1mbGFrZXNygAELEgVGbGFrZSJ1YmVuY2htYXJrcy5zeXN0ZW1faGVhbHRoX3Ntb2tlX3Rlc3QuU3lzdGVtSGVhbHRoQmVuY2htYXJrU21va2VUZXN0LnN5c3RlbV9oZWFsdGgubWVtb3J5X2Rlc2t0b3AuYnJvd3NlOnNvY2lhbDp0d2l0dGVyDA.

Flaky tests should be disabled within 30 minutes unless culprit CL is found and reverted. Please see more details here: https://sites.google.com/a/chromium.org/dev/developers/tree-sheriffs/sheriffing-bug-queues#triaging-auto-filed-flakiness-bugs

This flaky test/step was previously tracked in  issue 678363 .
 
Cc: chaopeng@chromium.org
This is popping up in the waterfall
 - https://uberchromegw.corp.google.com/i/chromium.mac/builders/Mac10.11%20Tests/builds/12359

I'm not seeing much useful in the logs.

  TimeoutException: Timed out while waiting 60s for IsJavaScriptExpressionTrue.
  Console output:
  
  
  [  FAILED  ] browse:social:twitter@{'case': 'browse', 'group': 'social'} (100121 ms)
  [  PASSED  ] 0 tests.
  [  FAILED  ] 1 test, listed below:
  [  FAILED  ]  browse:social:twitter@{'case': 'browse', 'group': 'social'}
  
  1 FAILED TEST


  ********************* BROWSER LOG *********************
  [15226:1295:0514/190857.436143:INFO:CONSOLE(437)] "JQMIGRATE: Migrate is installed with logging active, version 1.4.1", source: https://abs.twimg.com/c/swift/en/init.192c9100d1429e9ad2f009f2fe4a3ea8d8794b20.js (437)
  [15226:1295:0514/190857.618036:INFO:CONSOLE(435)] "JQMIGRATE: jQuery.browser is deprecated", source: https://abs.twimg.com/c/swift/en/init.192c9100d1429e9ad2f009f2fe4a3ea8d8794b20.js (435)
  [15226:1295:0514/190857.618135:INFO:CONSOLE(436)] "console.trace", source: https://abs.twimg.com/c/swift/en/init.192c9100d1429e9ad2f009f2fe4a3ea8d8794b20.js (436)
  [15226:1295:0514/190858.797424:INFO:CONSOLE(436)] "console.trace", source: https://abs.twimg.com/c/swift/en/init.192c9100d1429e9ad2f009f2fe4a3ea8d8794b20.js (436)
  [15232:775:0514/190900.178446:ERROR:gpu_video_decode_accelerator.cc(378)] HW video decode not available for profile h264 main
  [15232:775:0514/190900.220533:ERROR:gpu_video_decode_accelerator.cc(378)] HW video decode not available for profile h264 main
  [15226:1295:0514/190909.623702:INFO:CONSOLE(352)] "Synchronous XMLHttpRequest on the main thread is deprecated because of its detrimental effects to the end user's experience. For more help, check https://xhr.spec.whatwg.org/.", source: https://abs.twimg.com/c/swift/en/init.192c9100d1429e9ad2f009f2fe4a3ea8d8794b20.js (352)
  
  ***************** END OF BROWSER LOG ******************
  Chrome version: 3100
  Trace sizes in bytes: {'traceEvents': 15407, 'telemetry': 115132, 'tabIds': 40}
  Uploading /b/s/w/itfK6WFx/tmpbOrWzG/chrome.log to gs://chrome-telemetry-output/log_7c7cc341-4c73-4ad2-bb9a-176e6fa6c28a
  Uploading browser log to https://console.developers.google.com/m/cloudstorage/b/chrome-telemetry-output/o/log_7c7cc341-4c73-4ad2-bb9a-176e6fa6c28a
  Failed to gracefully shutdown.
  Proceed to kill the browser.
  Traceback (most recent call last):
    File "/b/s/w/ir/tools/perf/benchmarks/system_health_smoke_test.py", line 103, in RunTest
      msg='Failed: %s' % benchmark_class)
  AssertionError: Failed: <class 'benchmarks.system_health.DesktopMemorySystemHealth'
Cc: bokan@chromium.org
Sorry. I do not see relevance between this issue and my previous issue. 
Cc: mustaq@chromium.org
chaopeng@, given your previous work, are you able to suggest a suitable owner here? The issue still shows up in the SoM and I am not sure who should own this.
Owner: perezju@chromium.org
Status: Assigned
Timeouts are an issue with the test itself. According to the chromeperf dashboard (https://docs.google.com/spreadsheets/d/1xaAo0_SU3iDfGdqDJZX_jRV0QtkufwHUKH3kQKF3YQs/edit#gid=0), the test owner of system_health.memory_desktop is perezju@ so over to him to triage.
Cc: nedngu...@google.com
Looks like something broke browse:social:twitter, investigating ...
Summary: browse:social:twitter broken on mac bots (was: "benchmarks.system_health_smoke_test.SystemHealthBenchmarkSmokeTest.system_health.memory_desktop.browse:social:twitter" is flaky)
What I've found so far:

- Issue appears to affect mac bots only.
- These are the logs we get from Chrome (not sure if relevant)

(INFO) 2017-05-12 09:24:34,589 browser.DumpStateUponFailure:370  2017-05-12 09:23:01.907 Google Chrome[7438:88309] NSWindow warning: adding an unknown subview: <FullSizeContentView: 0x7ffbf18102b0>. Break on NSLog to debug.
2017-05-12 09:23:01.908 Google Chrome[7438:88309] Call stack:
(
    "+callStackSymbols disabled for performance reasons"
)
2017-05-12 09:23:02.409 Google Chrome[7438:88309] Errors logged by ksadmin: KSKeyedPersistentStore store directory does not exist. [com.google.UpdateEngine.CommonErrorDomain:501 - '/Library/Google/GoogleSoftwareUpdate/TicketStore' - 'KSKeyedPersistentStore.m:372']
KSPersistentTicketStore failed to load tickets. (productID: com.google.Chrome) [com.google.UpdateEngine.CoreErrorDomain:1051 - '/Library/Google/GoogleSoftwareUpdate/TicketStore/Keystone.ticketstore'] (KSKeyedPersistentStore store directory does not exist. - '/Library/Google/GoogleSoftwareUpdate/TicketStore' [com.google.UpdateEngine.CommonErrorDomain:501])
ksadmin cannot access the ticket store:<KSUpdateError:0x100605150
	domain="com.google.UpdateEngine.CoreErrorDomain"
	code=1051
	userInfo={
		function = "-[KSProductKeyedStore(ProtectedMethods) errorForStoreError:productID:message:timeoutMessage:]";
		date = 2017-05-12 16:23:02 +0000;
		productids = {(
			"com.google.Chrome"
		)};
		filename = "KSProductKeyedStore.m";
		line = 91;
		NSFilePath = "/Library/Google/GoogleSoftwareUpdate/TicketStore/Keystone.ticketstore";
		NSUnderlyingError = <KSError:0x100604790
			domain="com.google.UpdateEngine.CommonErrorDomain"
			code=501
			userInfo={
				date = 2017-05-12 16:23:02 +0000;
				line = 372;
				filename = "KSKeyedPersistentStore.m";
				function = "-[KSKeyedPersistentStore(PrivateMethods) validateStorePath]";
				NSFilePath = "/Library/Google/GoogleSoftwareUpdate/TicketStore";
				NSLocalizedDescription = "KSKeyedPersistentStore store directory does not exist.";
			}
		>;
		NSLocalizedDescription = "KSPersistentTicketStore failed to load tickets.";
	}
>

https://luci-logdog.appspot.com/v/?s=chrome%2Fbb%2Fchromium.perf%2FMac_Mini_8GB_10.12_Perf%2F1563%2F%2B%2Frecipes%2Fsteps%2Fsystem_health.common_desktop_on_Intel_GPU_on_Mac_on_Mac-10.12%2F0%2Fstdout

- Failure happens while trying to _NavigateToItem
- Screenshot shows the page is gone (?)

https://console.developers.google.com/m/cloudstorage/b/chrome-telemetry-output/o/profiler-file-id_59-2017-05-12_09-29-0328840.png

- Culprit CL should be somewhere in the range:
  http://test-results.appspot.com/revision_range?start=471253&end=471280

I'm going to disable the story while we investigate further.
Project Member Comment 8 by bugdroid1@chromium.org, May 15
The following revision refers to this bug:
  https://chromium.googlesource.com/chromium/src.git/+/5d406d88f635955f2ab90a1832cb0cd3dc86591c

commit 5d406d88f635955f2ab90a1832cb0cd3dc86591c
Author: perezju <perezju@chromium.org>
Date: Mon May 15 14:43:19 2017

[tools/perf] Disable browse:social:twitter on mac

Benchmark is failing on Mac bots.

TBR=nednguyen@google.com
BUG= 722094 

Review-Url: https://codereview.chromium.org/2886463002
Cr-Commit-Position: refs/heads/master@{#471757}

[modify] https://crrev.com/5d406d88f635955f2ab90a1832cb0cd3dc86591c/tools/perf/page_sets/system_health/browsing_stories.py

Mergedinto: 722233
Status: Duplicate

=== BISECT JOB RESULTS ===
Test failure found with culprit

Suspected Commit
  Author : Yutaka Hirano
  Commit : 823d5c738187627cbe218f01ddac6f383bcaaba8
  Date   : Fri May 12 09:29:18 2017
  Subject: Set URLResponseBodyConsumer::kMaxNumConsumedBytesInTask to 32K

Bisect Details
  Configuration: mac_pro_perf_bisect
  Benchmark    : system_health.memory_desktop
  Metric       : memory:chrome:all_processes:dump_count_avg/browse_social/browse_social_twitter

Revision             Exit Code      N
chromium@471253      0 +- N/A       6      good
chromium@471255      0 +- N/A       6      good
chromium@471256      0 +- N/A       6      good
chromium@471257      1 +- N/A       6      bad       <--
chromium@471260      1 +- N/A       6      bad
chromium@471267      1 +- N/A       6      bad
chromium@471280      1 +- N/A       6      bad

Please refer to the following doc on diagnosing memory regressions:
  https://chromium.googlesource.com/chromium/src/+/master/docs/memory-infra/memory_benchmarks.md

To Run This Test
  src/tools/perf/run_benchmark -v --browser=release --output-format=chartjson --upload-results --pageset-repeat=1 --also-run-disabled-tests --story-filter=browse.social.twitter system_health.memory_desktop

Debug Info
  https://chromeperf.appspot.com/buildbucket_job_status/8979525642122301808

Is this bisect wrong?
  https://chromeperf.appspot.com/bad_bisect?try_job_id=5305627917680640


| O O | Visit http://www.chromium.org/developers/speed-infra/perf-bug-faq
|  X  | for more information addressing perf regression bugs. For feedback,
| / \ | file a bug with component Speed>Bisection.  Thank you!
Project Member Comment 10 by bugdroid1@chromium.org, May 15
The following revision refers to this bug:
  https://chromium.googlesource.com/chromium/src.git/+/69c298a0367624b2412314b0c49bc6f0024f5f8d

commit 69c298a0367624b2412314b0c49bc6f0024f5f8d
Author: perezju <perezju@chromium.org>
Date: Mon May 15 16:17:30 2017

Revert of [tools/perf] Disable browse:social:twitter on mac (patchset #1 id:1 of https://codereview.chromium.org/2886463002/ )

Reason for revert:
Breaking change got reverted at:
https://chromium-review.googlesource.com/c/505649/

Original issue's description:
> [tools/perf] Disable browse:social:twitter on mac
>
> Benchmark is failing on Mac bots.
>
> TBR=nednguyen@google.com
> BUG= 722094 
>
> Review-Url: https://codereview.chromium.org/2886463002
> Cr-Commit-Position: refs/heads/master@{#471757}
> Committed: https://chromium.googlesource.com/chromium/src/+/5d406d88f635955f2ab90a1832cb0cd3dc86591c

TBR=nednguyen@google.com
# Skipping CQ checks because original CL landed less than 1 days ago.
NOPRESUBMIT=true
NOTREECHECKS=true
NOTRY=true
BUG= 722094 

Review-Url: https://codereview.chromium.org/2883983003
Cr-Commit-Position: refs/heads/master@{#471782}

[modify] https://crrev.com/69c298a0367624b2412314b0c49bc6f0024f5f8d/tools/perf/page_sets/system_health/browsing_stories.py

Sign in to add a comment