New issue
Advanced search Search tips
Note: Color blocks (like or ) mean that a user may not be available. Tooltip shows the reason.
Starred by 1 user

Issue metadata

Status: Duplicate
Merged: issue 709374
Owner: ----
Closed: Jun 2017
Cc:
Components:
EstimatedDays: ----
NextAction: ----
OS: iOS
Pri: 3
Type: Bug

Blocked on:
issue 709374



Sign in to add a comment

"google_apis_unittests" is flaky

Project Member Reported by chromium...@appspot.gserviceaccount.com, Apr 20 2017

Issue description

"google_apis_unittests" is flaky.

This issue was created automatically by the chromium-try-flakes app. Please find the right owner to fix the respective test/step and assign this issue to them. If the step/test is infrastructure-related, please add Infra-Troopers label and change issue status to Untriaged. When done, please remove the issue from Sheriff Bug Queue by removing the Sheriff-Chromium label.

We have detected 3 recent flakes. List of all flakes can be found at https://chromium-try-flakes.appspot.com/all_flake_occurrences?key=ahVzfmNocm9taXVtLXRyeS1mbGFrZXNyIAsSBUZsYWtlIhVnb29nbGVfYXBpc191bml0dGVzdHMM.

The chromium-try-flakes app is able to file bugs for individual tests when the test launcher is uploading results to the Test Results Server. If recent flakes above are caused by failing tests and you would like to have them filed as invidual bugs, please read more at https://goo.gl/QJKXV4.

This flaky test/step was previously tracked in  issue 679979 .
 
Blockedon: 709374
Likely relatedto or even blocked by  issue 709374  which is the continuation of  issue 679979 .

Comment 2 by xlai@chromium.org, Apr 21 2017

Cc: rogerta@chromium.org
Components: Infra>Client>iOS
Labels: OS-iOS

Comment 3 by sky@chromium.org, Apr 28 2017

Owner: pkl@chromium.org
Status: Assigned (was: Untriaged)
I assigned 709374 to Peter, so passing this one to him too in hopes of finding an owner.

Comment 4 by sky@chromium.org, Apr 28 2017

Labels: -Sheriff-Chromium

Comment 5 by pkl@chromium.org, May 1 2017

Cc: baxley@chromium.org sergeybe...@chromium.org pkl@chromium.org
Labels: -Pri-1 Pri-3
Owner: ----
Status: Available (was: Assigned)
Adjusted priority to match.
Project Member

Comment 6 by chromium...@appspot.gserviceaccount.com, May 4 2017

Labels: Sheriff-Chromium
Detected 3 new flakes for test/step "google_apis_unittests". To see the actual flakes, please visit https://chromium-try-flakes.appspot.com/all_flake_occurrences?key=ahVzfmNocm9taXVtLXRyeS1mbGFrZXNyIAsSBUZsYWtlIhVnb29nbGVfYXBpc191bml0dGVzdHMM. This message was posted automatically by the chromium-try-flakes app. Since flakiness is ongoing, the issue was moved back into Sheriff Bug Queue (unless already there).
Project Member

Comment 7 by chromium...@appspot.gserviceaccount.com, May 6 2017

Detected 3 new flakes for test/step "google_apis_unittests". To see the actual flakes, please visit https://chromium-try-flakes.appspot.com/all_flake_occurrences?key=ahVzfmNocm9taXVtLXRyeS1mbGFrZXNyIAsSBUZsYWtlIhVnb29nbGVfYXBpc191bml0dGVzdHMM. This message was posted automatically by the chromium-try-flakes app.
Labels: -Sheriff-Chromium
Removing from sheriff queue (again)
Project Member

Comment 9 by chromium...@appspot.gserviceaccount.com, May 27 2017

Labels: Sheriff-Chromium
Detected 3 new flakes for test/step "google_apis_unittests". To see the actual flakes, please visit https://chromium-try-flakes.appspot.com/all_flake_occurrences?key=ahVzfmNocm9taXVtLXRyeS1mbGFrZXNyIAsSBUZsYWtlIhVnb29nbGVfYXBpc191bml0dGVzdHMM. This message was posted automatically by the chromium-try-flakes app. Since flakiness is ongoing, the issue was moved back into Sheriff Bug Queue (unless already there).
Labels: -Sheriff-Chromium
Blocked on  issue 709374 , which has been pinged recently and is Pri=1
Project Member

Comment 11 by chromium...@appspot.gserviceaccount.com, Jun 7 2017

Labels: Sheriff-Chromium
Detected 3 new flakes for test/step "google_apis_unittests". To see the actual flakes, please visit https://chromium-try-flakes.appspot.com/all_flake_occurrences?key=ahVzfmNocm9taXVtLXRyeS1mbGFrZXNyIAsSBUZsYWtlIhVnb29nbGVfYXBpc191bml0dGVzdHMM. This message was posted automatically by the chromium-try-flakes app. Since flakiness is ongoing, the issue was moved back into Sheriff Bug Queue (unless already there).
Labels: -Sheriff-Chromium Infra-Troopers
Failures in comment #11 are "Unexpected infrastructure failure." Not the same as comment #9. Adding infra trooper to see if recent failures are same as the blocked on  issue 709374 .
Owner: sergeybe...@chromium.org
Status: Assigned (was: Available)
Labels: -Infra-Troopers Sheriff-Chromium
Owner: ----
Status: Available (was: Assigned)
I could only find one build with infra failures: https://luci-milo.appspot.com/buildbot/tryserver.chromium.mac/ios-simulator/232646

It's due to all swarming bots dying unexpectedly around 10:36am PDT on June 7. It seems to correspond to the network outage issue 730736.

That incident was resolved, there is nothing for the trooper to do.

All the following flakes seem to be the same as before - test timeout.
Bouncing back to the sheriff.
Mergedinto: 709374
Status: Duplicate (was: Available)
And it seems it's a known issue with iossim hanging. Dedupping.

Sign in to add a comment