Project: chromium Issues People Development process History Sign in
New issue
Advanced search Search tips
Starred by 1 user
Status: Duplicate
Merged: issue 709374
Owner:
Closed: Jun 14
Cc:
Components:
EstimatedDays: ----
NextAction: ----
OS: iOS
Pri: 1
Type: Bug



Sign in to add a comment
"components_unittests" is flaky
Project Member Reported by chromium...@appspot.gserviceaccount.com, Apr 19 Back to list
"components_unittests" is flaky.

This issue was created automatically by the chromium-try-flakes app. Please find the right owner to fix the respective test/step and assign this issue to them. If the step/test is infrastructure-related, please add Infra-Troopers label and change issue status to Untriaged. When done, please remove the issue from Sheriff Bug Queue by removing the Sheriff-Chromium label.

We have detected 3 recent flakes. List of all flakes can be found at https://chromium-try-flakes.appspot.com/all_flake_occurrences?key=ahVzfmNocm9taXVtLXRyeS1mbGFrZXNyHwsSBUZsYWtlIhRjb21wb25lbnRzX3VuaXR0ZXN0cww.

The chromium-try-flakes app is able to file bugs for individual tests when the test launcher is uploading results to the Test Results Server. If recent flakes above are caused by failing tests and you would like to have them filed as invidual bugs, please read more at https://goo.gl/QJKXV4.

This flaky test/step was previously tracked in  issue 658619 .
 
It looks like this roll exhibited this flakiness in the trybots.

https://codereview.chromium.org/2827543002
Owner: a...@chromium.org
Status: Assigned
alph@ can you take a look and see if your core/probe changes are the root here.

(your CL has the flake in it's trybot runs and the flake starts on the builders in the CL's which follow yours)

I'm proactively reverting in the meantime.
Owner: ----
Status: Available
Bah, just saw that the initial failure was on a dry-run, not a commit.

:(

Sorry, false alarm.
Labels: -Sheriff-Chromium Infra-Troopers
This started showing up on dry-run's today: a problem with the machine/env?
Labels: -Infra-Troopers Sheriff-Chromium
It looks like this is timing out on iOS devices. I don't see evidence of anything machine related. I suspect that the test is flaky/racy.
Cc: rogerm@chromium.org pinkerton@chromium.org iannucci@chromium.org ojan@chromium.org
Labels: OS-iOS
It looks like running components_unittest under the iOS simulator sometimes goes off into a black hole.

Looking back through both successful and flaky builds and their corresonding CLs, I'm seeing that the flake has been there for a while (as in CLs landing with retried ios_simulator try bot runs).

It's not clear who best to route this to: infra or platform team.

pinkerton@ and iannucci@: your thoughts?
Owner: pinkerton@chromium.org
Assigning to pinkerton for now so we have a clear owner. 
Labels: -Sheriff-Chromium
Cc: rohitrao@chromium.org
Owner: liaoyuke@chromium.org
Status: Assigned
-> yuke for flaky tests
Detected 7 new flakes for test/step "components_unittests". To see the actual flakes, please visit https://chromium-try-flakes.appspot.com/all_flake_occurrences?key=ahVzfmNocm9taXVtLXRyeS1mbGFrZXNyHwsSBUZsYWtlIhRjb21wb25lbnRzX3VuaXR0ZXN0cww. This message was posted automatically by the chromium-try-flakes app.
Detected 3 new flakes for test/step "components_unittests". To see the actual flakes, please visit https://chromium-try-flakes.appspot.com/all_flake_occurrences?key=ahVzfmNocm9taXVtLXRyeS1mbGFrZXNyHwsSBUZsYWtlIhRjb21wb25lbnRzX3VuaXR0ZXN0cww. This message was posted automatically by the chromium-try-flakes app.
Detected 3 new flakes for test/step "components_unittests". To see the actual flakes, please visit https://chromium-try-flakes.appspot.com/all_flake_occurrences?key=ahVzfmNocm9taXVtLXRyeS1mbGFrZXNyHwsSBUZsYWtlIhRjb21wb25lbnRzX3VuaXR0ZXN0cww. This message was posted automatically by the chromium-try-flakes app.
Cc: -ojan@chromium.org
Detected 3 new flakes for test/step "components_unittests". To see the actual flakes, please visit https://chromium-try-flakes.appspot.com/all_flake_occurrences?key=ahVzfmNocm9taXVtLXRyeS1mbGFrZXNyHwsSBUZsYWtlIhRjb21wb25lbnRzX3VuaXR0ZXN0cww. This message was posted automatically by the chromium-try-flakes app.
Detected 3 new flakes for test/step "components_unittests". To see the actual flakes, please visit https://chromium-try-flakes.appspot.com/all_flake_occurrences?key=ahVzfmNocm9taXVtLXRyeS1mbGFrZXNyHwsSBUZsYWtlIhRjb21wb25lbnRzX3VuaXR0ZXN0cww. This message was posted automatically by the chromium-try-flakes app.
Detected 3 new flakes for test/step "components_unittests". To see the actual flakes, please visit https://chromium-try-flakes.appspot.com/all_flake_occurrences?key=ahVzfmNocm9taXVtLXRyeS1mbGFrZXNyHwsSBUZsYWtlIhRjb21wb25lbnRzX3VuaXR0ZXN0cww. This message was posted automatically by the chromium-try-flakes app.
Detected 3 new flakes for test/step "components_unittests". To see the actual flakes, please visit https://chromium-try-flakes.appspot.com/all_flake_occurrences?key=ahVzfmNocm9taXVtLXRyeS1mbGFrZXNyHwsSBUZsYWtlIhRjb21wb25lbnRzX3VuaXR0ZXN0cww. This message was posted automatically by the chromium-try-flakes app.
Detected 7 new flakes for test/step "components_unittests". To see the actual flakes, please visit https://chromium-try-flakes.appspot.com/all_flake_occurrences?key=ahVzfmNocm9taXVtLXRyeS1mbGFrZXNyHwsSBUZsYWtlIhRjb21wb25lbnRzX3VuaXR0ZXN0cww. This message was posted automatically by the chromium-try-flakes app.
Detected 3 new flakes for test/step "components_unittests". To see the actual flakes, please visit https://chromium-try-flakes.appspot.com/all_flake_occurrences?key=ahVzfmNocm9taXVtLXRyeS1mbGFrZXNyHwsSBUZsYWtlIhRjb21wb25lbnRzX3VuaXR0ZXN0cww. This message was posted automatically by the chromium-try-flakes app.
Detected 3 new flakes for test/step "components_unittests". To see the actual flakes, please visit https://chromium-try-flakes.appspot.com/all_flake_occurrences?key=ahVzfmNocm9taXVtLXRyeS1mbGFrZXNyHwsSBUZsYWtlIhRjb21wb25lbnRzX3VuaXR0ZXN0cww. This message was posted automatically by the chromium-try-flakes app.
Detected 3 new flakes for test/step "components_unittests". To see the actual flakes, please visit https://chromium-try-flakes.appspot.com/all_flake_occurrences?key=ahVzfmNocm9taXVtLXRyeS1mbGFrZXNyHwsSBUZsYWtlIhRjb21wb25lbnRzX3VuaXR0ZXN0cww. This message was posted automatically by the chromium-try-flakes app.
Detected 3 new flakes for test/step "components_unittests". To see the actual flakes, please visit https://chromium-try-flakes.appspot.com/all_flake_occurrences?key=ahVzfmNocm9taXVtLXRyeS1mbGFrZXNyHwsSBUZsYWtlIhRjb21wb25lbnRzX3VuaXR0ZXN0cww. This message was posted automatically by the chromium-try-flakes app.
Mergedinto: 709374
Status: Duplicate
Sign in to add a comment