Project: chromium Issues People Development process History Sign in
New issue
Advanced search Search tips
Issue 712512 "ios_net_unittests" is flaky
Starred by 1 user Project Member Reported by chromium...@appspot.gserviceaccount.com, Apr 18 Back to list
Status: Duplicate
Merged: issue 709374
Owner: ----
Closed: Apr 18
Cc:
Components:
EstimatedDays: ----
NextAction: ----
OS: iOS
Pri: 1
Type: Bug



Sign in to add a comment
"ios_net_unittests" is flaky.

This issue was created automatically by the chromium-try-flakes app. Please find the right owner to fix the respective test/step and assign this issue to them. If the step/test is infrastructure-related, please add Infra-Troopers label and change issue status to Untriaged. When done, please remove the issue from Sheriff Bug Queue by removing the Sheriff-Chromium label.

We have detected 3 recent flakes. List of all flakes can be found at https://chromium-try-flakes.appspot.com/all_flake_occurrences?key=ahVzfmNocm9taXVtLXRyeS1mbGFrZXNyHAsSBUZsYWtlIhFpb3NfbmV0X3VuaXR0ZXN0cww.

The chromium-try-flakes app is able to file bugs for individual tests when the test launcher is uploading results to the Test Results Server. If recent flakes above are caused by failing tests and you would like to have them filed as invidual bugs, please read more at https://goo.gl/QJKXV4.
 
Labels: -Sheriff-Chromium Infra-Troopers OS-iOS
This does not seem to be a concrete test failing, rather the whole step fails with the error code 241.

Not sure where to route this, but I'm adding the iOS label and Infra-Troopers in case this somehow an issue in the iOS testing infrastructure.

A sample output is below:

python -u /b/build/scripts/tools/runit.py --show-path -- python /b/build/scripts/slave/recipe_modules/swarming/resources/collect_task.py -o /var/folders/9x/6c6sv3cj4j53wzpzthbp4ksm0000gm/T/tmprHMkyf.json --task-output-dir /var/folders/9x/6c6sv3cj4j53wzpzthbp4ksm0000gm/T/48fcAgIf --merge-script /b/build/scripts/slave/recipe_modules/swarming/resources/noop_merge.py --merge-additional-args '[]' -- python -u /b/build/slave/ios-simulator/build/swarming.client/swarming.py collect --swarming https://chromium-swarm.appspot.com --decorate --print-status-updates --json /var/folders/9x/6c6sv3cj4j53wzpzthbp4ksm0000gm/T/tmpEQuZto.json --task-summary-json /var/folders/9x/6c6sv3cj4j53wzpzthbp4ksm0000gm/T/tmpqdB9dF.json
in dir /b/build/slave/ios-simulator/build:
 allow_subannotations: False
 base_name: ios_net_unittests (iPad Air 2 iOS 10.0)
 cmd: ['python', '-u', '/b/build/scripts/tools/runit.py', '--show-path', '--', 'python', '/b/build/scripts/slave/recipe_modules/swarming/resources/collect_task.py', '-o', '/var/folders/9x/6c6sv3cj4j53wzpzthbp4ksm0000gm/T/tmprHMkyf.json', '--task-output-dir', '/var/folders/9x/6c6sv3cj4j53wzpzthbp4ksm0000gm/T/48fcAgIf', '--merge-script', '/b/build/scripts/slave/recipe_modules/swarming/resources/noop_merge.py', '--merge-additional-args', '[]', '--', 'python', '-u', '/b/build/slave/ios-simulator/build/swarming.client/swarming.py', 'collect', '--swarming', 'https://chromium-swarm.appspot.com', '--decorate', '--print-status-updates', '--json', '/var/folders/9x/6c6sv3cj4j53wzpzthbp4ksm0000gm/T/tmpEQuZto.json', '--task-summary-json', '/var/folders/9x/6c6sv3cj4j53wzpzthbp4ksm0000gm/T/tmpqdB9dF.json']
 cwd: /b/build/slave/ios-simulator/build
 infra_step: False
 name: ios_net_unittests (iPad Air 2 iOS 10.0)
 nest_level: 0
 ok_ret: frozenset([0])
 step_test_data: <lambda>(...)
 trigger_specs: []
full environment:
 AWS_CREDENTIAL_FILE: /b/build/site_config/.boto
 BOTO_CONFIG: /b/build/site_config/.boto
 BUILDBOT_BLAMELIST: [u'ramyasharma@chromium.org']
 BUILDBOT_BRANCH: 
 BUILDBOT_BUILDBOTURL: http://build.chromium.org/p/tryserver.chromium.mac/
 BUILDBOT_BUILDERNAME: ios-simulator
 BUILDBOT_BUILDNUMBER: 195939
 BUILDBOT_CLOBBER: 
 BUILDBOT_GOT_REVISION: None
 BUILDBOT_MASTERNAME: tryserver.chromium.mac
 BUILDBOT_REVISION: 
 BUILDBOT_SCHEDULER: None
 BUILDBOT_SLAVENAME: vm807-m4
 CHROME_HEADLESS: 1
 CIPD_CACHE_DIR: /b/c/cipd
 GIT_USER_AGENT: darwin git/2.7.4 vm807-m4.golo.chromium.org
 HOME: /Users/chrome-bot
 INFRA_BUILDBOT_MASTER_CLASS_NAME: TryServerChromiumMac
 INFRA_BUILDBOT_SLAVE_ACTIVE_SUBDIR: 
 INFRA_BUILDBOT_SLAVE_NAME: vm807-m4
 LOGDOG_COORDINATOR_HOST: luci-logdog.appspot.com
 LOGDOG_STREAM_PREFIX: bb/tryserver.chromium.mac/ios-simulator/195939
 LOGDOG_STREAM_PROJECT: chromium
 LOGDOG_STREAM_SERVER_PATH: unix:/b/build/.recipe_runtime/tmpJUiHVF/butler.sock
 LOGNAME: chrome-bot
 PAGER: cat
 PATH: /b/cipd_path_tools:/b/cipd_client:/Users/chrome-bot/slavebin:/b/depot_tools:/usr/local/git/bin:/usr/bin:/usr/bin:/bin:/usr/sbin:/sbin:/usr/local/bin
 PWD: /b/build/slave/ios-simulator/build
 PYTHONIOENCODING: UTF-8
 PYTHONPATH: /b/build/site_config:/b/build/scripts:/b/build/scripts/release:/b/build/third_party:/b/build/third_party/google_api_python_client:/b/build/third_party/httplib2/python2:/b/build/third_party/infra_libs:/b/build/third_party/oauth2client:/b/build/third_party/pyasn1:/b/build/third_party/pyasn1-modules:/b/build/third_party/python-rsa:/b/build/third_party/requests_2_10_0:/b/build/third_party/setuptools-0.6c11:/b/build/third_party/site-packages:/b/build/third_party/uritemplate:/b/build_internal/site_config:/b/build_internal/symsrc:/b/build/slave:/b/build/third_party/buildbot_slave_8_4:/b/build/third_party/twisted_10_2:
 PYTHONUNBUFFERED: 1
 SHELL: /bin/bash
 SSH_AUTH_SOCK: /private/tmp/com.apple.launchd.ke7RWXz5Ph/Listeners
 TMPDIR: /var/folders/9x/6c6sv3cj4j53wzpzthbp4ksm0000gm/T/
 USER: chrome-bot
 VERSIONER_PYTHON_PREFER_32_BIT: no
 VERSIONER_PYTHON_VERSION: 2.7
 __CF_USER_TEXT_ENCODING: 0x1F4:0x0:0x0

Set PYTHONPATH: /b/build/scripts:/b/build/site_config:/b/build/third_party:/b/build/third_party/buildbot_8_4p1:/b/build/third_party/buildbot_slave_8_4:/b/build/third_party/coverage-3.7.1:/b/build/third_party/decorator_3_3_1:/b/build/third_party/google_api_python_client:/b/build/third_party/httplib2/python2:/b/build/third_party/infra_libs:/b/build/third_party/jinja2:/b/build/third_party/markupsafe:/b/build/third_party/mock-1.0.1:/b/build/third_party/oauth2client:/b/build/third_party/pyasn1:/b/build/third_party/pyasn1-modules:/b/build/third_party/python-rsa:/b/build/third_party/requests_2_10_0:/b/build/third_party/setuptools-0.6c11:/b/build/third_party/sqlalchemy_0_7_1:/b/build/third_party/sqlalchemy_migrate_0_7_1:/b/build/third_party/tempita_0_5:/b/build/third_party/twisted_10_2:/b/build/third_party/uritemplate:/b/build/third_party/site-packages:/b/build/scripts/tools:/b/build/scripts/release:/b/build_internal/site_config:/b/build_internal/symsrc:/b/build/slave:/b/build/slave/ios-simulator/build:/System/Library/Frameworks/Python.framework/Versions/2.7/lib/python27.zip:/System/Library/Frameworks/Python.framework/Versions/2.7/lib/python2.7:/System/Library/Frameworks/Python.framework/Versions/2.7/lib/python2.7/plat-darwin:/System/Library/Frameworks/Python.framework/Versions/2.7/lib/python2.7/plat-mac:/System/Library/Frameworks/Python.framework/Versions/2.7/lib/python2.7/plat-mac/lib-scriptpackages:/System/Library/Frameworks/Python.framework/Versions/2.7/Extras/lib/python:/System/Library/Frameworks/Python.framework/Versions/2.7/lib/python2.7/lib-tk:/System/Library/Frameworks/Python.framework/Versions/2.7/lib/python2.7/lib-old:/System/Library/Frameworks/Python.framework/Versions/2.7/lib/python2.7/lib-dynload:/System/Library/Frameworks/Python.framework/Versions/2.7/Extras/lib/python/PyObjC
WARNING:root:task_output_dir '/var/folders/9x/6c6sv3cj4j53wzpzthbp4ksm0000gm/T/48fcAgIf' already exists!
WARNING:root:task_output_dir existing content: []
+---------------------------------------------------------------------------------+
| Shard 0  https://chromium-swarm.appspot.com/user/task/359723b697ed9710          |
+---------------------------------------------------------------------------------+
Device wiped.
/b/s/w/ir/src/out/Debug-iphonesimulator/iossim -d iPad Air 2 -s 10.0 /b/s/w/ir/src/out/Debug-iphonesimulator/ios_net_unittests.app

User defaults from command line:
    IDETestRunSpecificationPath = /var/folders/p4/py6nlvcx4fs5s3fg51_pzqmc0000gm/T/B3C991D0-73C0-4022-A2CB-51E4AFDE3D22
+---------------------------------------------------------------------------------+
| End of shard 0  Pending: 259.5s  Duration: 1202.6s  Bot: build782-m4  Exit: -15 |
+---------------------------------------------------------------------------------+
Total duration: 1202.6s
WARNING:root:collect_cmd had non-zero return code: 241
WARNING:root:No shard json files found in task_output_dir: '/var/folders/9x/6c6sv3cj4j53wzpzthbp4ksm0000gm/T/48fcAgIf'
Found ['/var/folders/9x/6c6sv3cj4j53wzpzthbp4ksm0000gm/T/48fcAgIf/summary.json']
step returned non-zero exit code: 241
Mergedinto: 709374
Status: Duplicate
Looks like a dupe of bug 709374.
Sign in to add a comment