New issue
Advanced search Search tips
Note: Color blocks (like or ) mean that a user may not be available. Tooltip shows the reason.

Issue 71052 link

Starred by 5 users

Issue metadata

Status: Duplicate
Owner:
Email to this user bounced
Closed: Feb 2011
Cc:
Components:
EstimatedDays: ----
NextAction: ----
OS: All
Pri: 1
Type: Bug-Regression

Restricted
  • Only users with EditIssue permission may comment.



Sign in to add a comment

CSS selector :last-child not working with selector :after in lists

Reported by pba...@gmail.com, Jan 27 2011

Issue description

Chrome Version       : 10.0.648.6 dev @ mac
Other browsers tested:
Add OK or FAIL after other browsers where you have tested this issue:
     Safari 5: OK
  Firefox 3.x: OK

What steps will reproduce the problem?
Go to page that uses something like li:last-child:after {content: "]"}. 
HTML code: http://pastebin.com/icN3bsmf

What is the expected result?
You will see square brackets before each list ending.

What happens instead?
You won't see it.
 
Screen shot 2011-01-27 at 4.17.38 PM.png
5.2 KB View Download
index.html
715 bytes View Download
Labels: -Pri-2 -Area-Undefined Pri-1 Area-WebKit OS-All Regression ReleaseBlock-Beta Mstone-10
Status: Untriaged
Looks like there's a regression here. 

9.0.597.83 - OK
10.0.648.6 - NOT OK

Comment 2 by karen@chromium.org, Feb 1 2011

Status: Assigned
any idea hamaji-san?
Hi Sunand,

Can you help find a narrow regression window?

thanks,
Jeff
Build 71636 - Good
Build 71660 - Bad

Looks like this webkit change: http://trac.webkit.org/changeset/76012/
Thank you very much for getting the regression window.

Comment 6 by k...@google.com, Feb 4 2011

Labels: -ReleaseBlock-Beta ReleaseBlock-Stable
+yuzo as I think he made some fixes for pseudo style selectors.
Mergedinto: 71273
Status: Duplicate
I can't repro in WebKit ToT. Building Chromiu

Comment 9 by pba...@gmail.com, Mar 10 2011

Still exists in Chrome Stable 10.0.648.127.
Mergedinto:
Interesting test case for this one: Try adding an ID to the last element and then referencing the ID in the CSS - Fixes the issue. 

See broken here: http://jsfiddle.net/D4T6L/4/ and fixed here: http://jsfiddle.net/773ee/

Hope that helps you figure out the issue. -Eric
Mergedinto: 71273
re-merging with  issue 71273 
Labels: -Regression bulkmove Type-Regression
Mergedinto: -0
Chrome Version       : 10.0.648.6 dev @ mac
Other browsers tested:
Add OK or FAIL after other browsers where you have tested this issue:
     Safari 5: OK
  Firefox 3.x: OK

What steps will reproduce the problem?
Go to page that uses something like li:last-child:after {content: "]"}. 
HTML code: http://pastebin.com/icN3bsmf

What is the expected result?
You will see square brackets before each list ending.

What happens instead?
You won't see it.
Project Member

Comment 13 by bugdroid1@chromium.org, Oct 13 2012

Labels: Restrict-AddIssueComment-Commit
This issue has been closed for some time. No one will pay attention to new comments.
If you are seeing this bug or have new data, please click New Issue to start a new bug.
Project Member

Comment 14 by bugdroid1@chromium.org, Mar 9 2013

Labels: -Area-WebKit -Mstone-10 -Type-Regression Cr-Content Type-Bug-Regression M-10
Project Member

Comment 15 by bugdroid1@chromium.org, Mar 13 2013

Labels: -Restrict-AddIssueComment-Commit Restrict-AddIssueComment-EditIssue
Project Member

Comment 16 by bugdroid1@chromium.org, Apr 6 2013

Labels: -Cr-Content Cr-Blink

Sign in to add a comment