Project: chromium Issues People Development process History Sign in
New issue
Advanced search Search tips
Note: Color blocks (like or ) mean that a user may not be available. Tooltip shows the reason.
Issue 70636 Unable to launch browser in linux
Starred by 6 users Project Member Reported by vivianz@chromium.org, Jan 24 2011 Back to list
Status: Verified
Owner:
User never visited
Closed: Jan 2011
Cc:
Components:
EstimatedDays: ----
NextAction: ----
OS: Linux
Pri: 0
Type: Bug

Restricted
  • Only users with EditIssue permission may comment.



Sign in to add a comment
Chrome: 10.0.648.0-r72316

What steps will reproduce the problem?
1.install chrome
2.try to launch chrome


What is the expected output? What do you see instead?
failed to launch chrome, the browser shut down right away, with error message:

[16390:16390:2742729859686:ERROR:extension_prefs.cc(734)] Bad or missing pref 'state' for extension 'hpibmhghjndideebpackbdlpncgkcppp'
[16390:16398:2742729870711:FATAL:external_pref_extension_loader.cc(89)] Check failed: !prefs_->empty() || !base_path_.empty(). 

Please use labels and text to provide additional information.

 
Labels: Feature-Browser
Comment 3 by evan@chromium.org, Jan 24 2011
Assigning to skerner based on blame.
 Issue 70559  has been merged into this issue.
Status: Started
Comment 6 by k...@google.com, Jan 24 2011
Is it possible to just revert the change that caused this on the branch for now?  We're stuck waiting for a good build until this is fixed.
Comment 7 by bme...@gmail.com, Jan 24 2011
As per the (older) merged  issue 70559 , 

"run as root:
mkdir /opt/chromium-browser/extensions" [not my original work]

Should fix the problem/give you a good starting place to look at (it fixed the problem for me).
Comment 8 by skerner@google.com, Jan 24 2011
Will be submitting a fix in the next hour.
Project Member Comment 9 by bugdroid1@chromium.org, Jan 24 2011
The following revision refers to this bug:
    http://src.chromium.org/viewvc/chrome?view=rev&revision=72413

------------------------------------------------------------------------
r72413 | skerner@chromium.org | Mon Jan 24 15:11:06 PST 2011

Changed paths:
 M http://src.chromium.org/viewvc/chrome/trunk/src/chrome/browser/extensions/external_pref_extension_loader.cc?r1=72413&r2=72412&pathrev=72413

Fix logic in a CHECK(), which was missing a ! .

BUG= 70636 
TEST=Manual

Review URL: http://codereview.chromium.org/6299016
------------------------------------------------------------------------
Status: Fixed
Status: Verified
Verified as fixed in Chrome 10.0.649.0 (Official Build 72449)
Project Member Comment 12 by bugdroid1@chromium.org, Oct 12 2012
Labels: Restrict-AddIssueComment-Commit
This issue has been closed for some time. No one will pay attention to new comments.
If you are seeing this bug or have new data, please click New Issue to start a new bug.
Project Member Comment 13 by bugdroid1@chromium.org, Mar 10 2013
Labels: -Area-Internals -Mstone-10 -Feature-Browser Cr-Internals M-10 Cr-UI-Browser-Core
Project Member Comment 14 by bugdroid1@chromium.org, Mar 13 2013
Labels: -Restrict-AddIssueComment-Commit Restrict-AddIssueComment-EditIssue
Sign in to add a comment