New issue
Advanced search Search tips
Note: Color blocks (like or ) mean that a user may not be available. Tooltip shows the reason.
Starred by 0 users

Issue metadata

Status: Duplicate
Merged: issue 544244
Owner: ----
Closed: Mar 2017
Cc:
Components:
EstimatedDays: ----
NextAction: ----
OS: Windows
Pri: 2
Type: Bug



Sign in to add a comment

squid proxy realm content not displayed when chrome configured to go through squid proxy

Reported by l...@ebay.com, Mar 10 2017

Issue description

UserAgent: Mozilla/5.0 (Windows NT 6.1; WOW64) AppleWebKit/537.36 (KHTML, like Gecko) Chrome/56.0.2924.87 Safari/537.36

Steps to reproduce the problem:
1. Configure the chrome browser to use proxy to use the wpad file : https://c2sproxy.vip.ebay.com/wpad.dat
2. When trying to access the web URL, it should prompt the realm configured in the squid but it's not displaying it.
3. Chrome browser displays the default and not the one configured in the squid proxy.

What is the expected behavior?
When accessing the internal sites, it should display the message which is configured in the squid like this:
--------------------------------------------------------------------------------------------------
auth_param basic realm Please use your Yubikey to login. If you do not have one please request one
at MyIT.  In the meantime you may use your SecurID to login (do not use the same code twice, 
wait for the next token).
--------------------------------------------------------------------------------------------------

And the browser should display the realm when accessing the internal sites.

What went wrong?
chrome_screenshot: in this image, the real is not displayed.
firefox_screenshot: the realm message is displayed.

Because of this the customer not sure sure what to give when prompted. Most of the time customers are using their username and password and their account got locked as they're trying multiple times.

Did this work before? N/A 

Chrome version: 56.0.2924.87  Channel: n/a
OS Version: 6.1 (Windows 7, Windows Server 2008 R2)
Flash Version:
 
chrome_screenshot.PNG
4.0 KB View Download
firefox_screenshot.PNG
40.2 KB View Download
Cc: asanka@chromium.org mzheng@chromium.org blumberg@chromium.org ligim...@chromium.org
Components: Internals>Network

Comment 2 by asanka@chromium.org, Mar 11 2017

Mergedinto: 544244
Status: Duplicate (was: Unconfirmed)
This was the result of a change to remove server controlled strings from the auth dialog. Efforts are underway to add them back in a safe manner.

Sign in to add a comment