New issue
Advanced search Search tips

Issue 696785 link

Starred by 1 user

Issue metadata

Status: Duplicate
Merged: issue 507397
Owner: ----
Closed: Mar 2017
EstimatedDays: ----
NextAction: ----
OS: Linux
Pri: 2
Type: Bug



Sign in to add a comment

flex-wrap not working in nested flex elements.

Project Member Reported by yiwenluo@google.com, Feb 27 2017

Issue description

UserAgent: Mozilla/5.0 (X11; Linux x86_64) AppleWebKit/537.36 (KHTML, like Gecko) Chrome/56.0.2924.87 Safari/537.36

Steps to reproduce the problem:
Reduced Example: http://codepen.io/anon/pen/evNwdN?editors=1100

1. A flex column container with flex-wrap enabled. 
2. Insert a child flex row element with flex-wrap enabled. 
3. In the child element, add 2 fixed width elements. 

What is the expected behavior?
Expected the flex row element to wrap its children when the width is not enough to hold both children. 

What went wrong?
The flex row element doesn't wrap its children when width is small enough. 

Did this work before? N/A 

Does this work in other browsers? No
 Firefox behaves the same as Chrome for this issue. 

Chrome version: 56.0.2924.87  Channel: stable
OS Version: 
Flash Version: 

This bug is similar to, but not 100% sure it's a duplicate of

https://bugs.chromium.org/p/chromium/issues/detail?id=507397&q=component%3ABlink%3ELayout%3EFlexbox%20&colspec=ID%20Pri%20M%20Stars%20ReleaseBlock%20Component%20Status%20Owner%20Summary%20OS%20Modified

 
Labels: Needs-Triage-M56
Mergedinto: 507397
Status: Duplicate (was: Unconfirmed)
Issue seems similar to the bug 507397.Hence merging this into 507397.
Please feel free to undupe if not similar.

Thanks,

Sign in to add a comment