New issue
Advanced search Search tips

Issue 68629 link

Starred by 2 users

Issue metadata

Status: Duplicate
Merged: issue 68861
Owner: ----
Closed: Feb 2011
EstimatedDays: ----
NextAction: ----
OS: ----
Pri: 2
Type: Bug

Restricted
  • Only users with Commit permission may comment.



Sign in to add a comment

Phony <div> element set as event.relatedTarget instead of an <input> element.

Project Member Reported by pajas@google.com, Jan 5 2011

Issue description

Chrome Version       : 9.0.597.19 beta, 10.0.612.1 dev
URLs (if applicable) : http://jsbin.com/ipaho3/2
Other browsers tested:
Add OK or FAIL after other browsers where you have tested this issue:
     Safari 5: OK
  Firefox 3.x: OK
       IE 7/8: OK
     Chrome 8: OK

What steps will reproduce the problem?

1. open http://jsbin.com/ipaho3/2
2. hover over "X" in the input box
3. move the mouse to the right towards the "Hello world" text
4. compare Expected and Actual results shown on the page

What is the expected result?

Expected: event.relatedTarget: [object HTMLInputElement], parent: [object HTMLDivElement]

What happens instead?

Actual: event.relatedTarget: [object HTMLDivElement], parent: null

Please provide any additional information below. Attach a screenshot if
possible.

The problem is that relatedTarget, toElement and/or fromElement fields on the Event object for mouseover/mouseout events are set with some "internal" <div> element that is not attached to the document tree instead of being set with the <input> element to which they logically relate.

The <div> element seems to represent the value of the input box internally (e.g. its textContext is the input value and assigning to it modifies the value shown in the input box - see dots getting appended to the input box value).

This seems to be a problem only in beta/dev versions of Chrome (or Webkit), not reproducible with Chrome 8.
 

Comment 1 by pajas@google.com, Feb 7 2011

This bug was also noted here http://bugs.jquery.com/ticket/7729. It is now present in Chrome 9 which has been released!
Mergedinto: 68861
Status: Duplicate
Thanks for the report. Marking as a duplicate of  issue 68861  which has more info.

Comment 3 by mrkev...@gmail.com, Feb 24 2011

Please Fix this. I am also experiencing this...

Comment 4 by mrkev...@gmail.com, Feb 24 2011

Users here are experiencing the same thing: 
http://flowplayer.org/tools/forum/30/54230
Project Member

Comment 5 by bugdroid1@chromium.org, Oct 12 2012

Labels: Restrict-AddIssueComment-Commit
Mergedinto: chromium:68861
This issue has been closed for some time. No one will pay attention to new comments.
If you are seeing this bug or have new data, please click New Issue to start a new bug.
Project Member

Comment 6 by bugdroid1@chromium.org, Mar 11 2013

Labels: -Area-Undefined

Sign in to add a comment