New issue
Advanced search Search tips
Starred by 87 users

Issue metadata

Status: Duplicate
Merged: issue 157225
Owner:
Closed: Feb 2013
Cc:
Components:
EstimatedDays: ----
NextAction: ----
OS: ----
Pri: 2
Type: Feature

Blocking:
issue 68358

Restricted
  • Only users with EditIssue permission may comment.



Sign in to add a comment
link

Issue 68108: provide means to overwrite existing file instead of appending numbers on downloads

Reported by kazu.sem...@gmail.com, Dec 27 2010

Issue description

Chromium Version       : all of them
What steps will reproduce the problem?
1.Save a file
2.Save the same file again

What is the expected result?
I expect a prompt that asks me what to do with the file.
i.e. '"$FILENAME" is already present. Would you like to overwrite the existing file or do you want to append a number on it? 
[Overwrite] [Append number] [Cancel]'.
Ideally with file information of both files like the overwrite dialog from Dolphin(kde4) or windows vista/7.

What happens instead?
It automatically appends a number on the file.

Please provide any additional information below. Attach a screenshot if
possible.

I used to like chrome very much, even in the early stages without extension support, but the first time i tried to seriously use chrome i was extremely disappointed in the lack of proper download behavior. At that time i through it would be a pretty much wanted "feature" to overwrite existing files, so i didn't really bother to look up bug reports about it. I used firefox since then and estimated now to be a good time to try it again, but sadly it behaves the same. Not even one bug report is to be found about it, only a few post in related chrome forums.

So here is my feature request. Please make the appending of numbers optional on already existing files and add overwrite abilities. Perhaps it can be done like suggested above, or it could be a option in the preferences.

Thank you for listening to my plea.
 

Comment 1 by mkte...@gmail.com, Dec 28 2010

Labels: -Type-Bug -Area-Undefined Type-Feature Area-UI Feature-Downloads
FYI, if you really want to overwrite, you can remove the appended number manually.

Comment 2 by kazu.sem...@gmail.com, Dec 28 2010

I don't really look at the name field of the save dialog, but more at the location where it is saved and just click at the left button of the two down there on the screen. Simply because i don't want to waste my time to check the filename while my head is full of other things. There are even times where the filename is too long and i can't see if a number is appended.

Apart from that, i too wouldn't download a file two times. That would be more of a comfort function for me.

It seems that not all files are affected, html doesn't get the appended number and i get a dialog that asks me if i want to overwrite. That would be nice as an option for all files.

Thank you for your answer.

Comment 3 by rdsmith@chromium.org, Jan 18 2011

 Issue 21154  has been merged into this issue.

Comment 4 by rdsmith@chromium.org, Jan 18 2011

 Issue 41602  has been merged into this issue.

Comment 5 by thebeani...@gmail.com, Jan 19 2011

Any ideas how a suitable solution can be implemented?

As far as im aware chrome does not have any POP UP Prompts. Maybe the options [Overwrite] [Append number] [Cancel] can be in the download strip at the bottom. To make things fast chrome could download the file and append a number, but after the user selects the desired option the file could be overwritten (if required) after download.

My solution doesn't really solve the issue as you would be nagged every time, maybe the user preference could be saved against the file association?

Comment 6 by brian.bo...@nrg-edge.com, Jul 25 2011

Would really prefer Firefox-like behavior on this. The CMS I work with allows exporting of stuff in XML format through the browser, and the filename for each bootstrap file is always the same. It's not a huge deal, but it throws an extra couple steps into the workflow I was used to. Thanks.

Comment 7 by tayre...@bridgelearningcampus.com, Nov 10 2011

This is causing some headaches in a school environment, where users just happily click through the save dialog. We just did a search for duplicate files (we don't have a de-duplicating file store) and around half of the data in Downloads folders is duplicated. For example, one user receives a report every day from an external agency, this file is always the same name, and a quick look in their downloads folder shows me 15 of the files, each one 1.5Mb in size, when they only need one of them - the latest one.

We need a way to not only enable this capability, but also to force it via the enterprise administration tools.

Comment 8 by rdsmith@chromium.org, Jun 21 2012

Comment 9 by bugdroid1@chromium.org, Aug 10 2012

Project Member
Labels: -Pri-2 Pri-3 Action-NeedsReview
Status: IceBox
Due to the age of the issue, changing the priority to P3, however because it has at least 10 stars, marking it for review.

Comment 10 by aver...@gmail.com, Aug 10 2012

Huh?  Because nobody got around to fixing it it gets downgraded in priority?  That's an odd procedure to handling bugs.

Comment 11 by laforge@google.com, Aug 10 2012

Status: Unconfirmed

Comment 12 by rdsmith@chromium.org, Aug 13 2012

Cc: benjhayden@chromium.org
Labels: -Pri-3 -Action-NeedsReview Pri-2
Status: Untriaged
@avernar: It's the Unconfirmed that's the trigger, and for this bug, that's invalid.  I'll fix that.

In terms of the long-term trajectory for this item: Chrome aims to provide a single behavior that works for the majority of users; we don't put in very many flags at all.  So it's unlikely that we'll put in this feature.  There are two ways I could imagine handling this use case:

* Putting enough hooks in the downloads extensions API so that we can tweak the default filename for saving.  This would require some thought around security implications, but I could imagine could be useful for other reasons.  CCing Ben for inclusion in his thoughts around the extensions API.

* Searching through the downloads history on new downloads, and recognizing if a file is already downloaded if it's coming from the same URL as before, and entity tag/last-modified evaluations check out.  I could imagine this being really frustrating if the user really wanted to re-download (e.g. they *know* the file has changed, even though the last-modify/etag checks say it hasn't) so I'm a little nervous about implementing it.  But I think it would be right for the large majority of users.  

I doubt we'll get to this very soon, though.

Comment 13 by msampso...@gmail.com, Aug 13 2012

"Chrome aims to provide a single behavior that works for the majority of users"

Maybe things have changed since I've last checked (which is actually quite possible) but doesn't every single other browser handle this with a prompt rather than incrementing the file name?  It's not like either method is very difficult, but a majority of users expect a prompt based on how almost every single other application in existence works.

You could even have a prompt the first time a file shares the same name asking what behavior you'd like it to do from then on.  In the mean time I guess I'll just continue using Firefox.  My exclusion will have the added benefit of increasing the percentage of users the current behavior works for.

A real pity.

Comment 14 by aver...@gmail.com, Aug 13 2012

Agreed.  Auto numbering of saves on existing files is a behaviour I very rarely see in other applications, let alone other browsers.

The expected behaviour, based on user experience with other applications, is to ask to overwrite and give the option of changing the filename.

Comment 15 by benjhayden@chromium.org, Aug 13 2012

Owner: benjhayden@chromium.org
Status: Assigned
I think that some form of fix for this should be easy enough via the extension api.
Perhaps something like chrome.downloads.setDestination({overwrite:true})?
This would allow extensions to listen for new downloads, wait for their filename to be determined, look for the counter, and either automatically overwrite or prompt via a browser action or notification or panel or whatever. The extension could manage a database of "Always/Never overwrite for this filename/url/hostname/mime".
No guarantees, but I'm planning on putting some more work into the api sometime in the next few weeks.

Comment 16 by dgsinka...@gmail.com, Sep 2 2012

This is very annoying - automatic multiple download files aaaghhh!!! Just give the user the option to turn off please.

Comment 17 by Deleted ...@, Sep 7 2012

i want the auto numbering feature that mysteriously disappeared recently, is there a switch for this to turn it back on again?

Comment 18 by rdsmith@chromium.org, Sep 7 2012

@johan.i.zahri: That feature shouldn't have disappeared; if downloads aren't being auto-numbered, that's a bug.  Could you file a new bug report, including a net-internals dump (see http://dev.chromium.org/for-testers/providing-network-details ), and cc me on it?  Thanks!

Comment 19 by msampso...@gmail.com, Sep 10 2012

@johan.i.zahri  Also post the bug number here, so all of us that want that behavior can have what we want for a brief period.

Comment 20 by Deleted ...@, Oct 26 2012

Almost two years since this bug was reported and you still haven't fixed it or at least added a way to disable it. UNBELIEVABLE!!!
I recently changed from FF because of their silly "forced no option" changes and now I run into this. What are the Browser programmers thinking? Have you all been drinking the same kool-aid? Come on, get off your soap box and add a disable option.
Until then I guess I'll look at other browsers.

Comment 21 by kalvia...@gmail.com, Nov 17 2012

I would like to see this feature soon.

Comment 22 by keyboar...@gmail.com, Nov 27 2012

Same here. Darn frustrating not to have an option in the browser.

Comment 23 by Deleted ...@, Nov 29 2012

It's looks like the Chrome has the auto-rename limit to 100 and once we reached the 100th then it will ask for over-write the existing file.

Comment 24 by rob.cann...@gmail.com, Dec 11 2012

I too would like this fixed.  PRETTY PLEASE?

Comment 25 by jameskwi...@gmail.com, Dec 14 2012

Google, you can have my soul if you just fix this.  Honestly, it can't be that difficult to add a toggle of some sort.  Duplicate files = insanity...

Comment 26 by Deleted ...@, Dec 20 2012

Fix this please.
I think Chrome is the best browser, but for most projects im rolling out at customers, the lack of the function to turn the numbering thing off makes it impossible to use Chrome.

Comment 27 by Deleted ...@, Jan 3 2013

I have recently started using Google Drive and part of Google Apps. I have a many files that are shared with me so are only available via the browser. If you download a file to edit it, but it already exists in you "Downloads" (perhaps as an older version with the same file name) you inadvertently start editing the file with a different name. The only resolution I have found is to delete the old version and rename the new one before re-uploading to Drive. Insane. Please fix.

Comment 28 by Deleted ...@, Jan 14 2013

I've got the same problem, I don't like when chrome creates a new file with a number instead of overwrite a existing file. Please make an option to overwrite an existing file.

Comment 29 Deleted

Comment 30 by Deleted ...@, Jan 14 2013

Agree. Annoying. BTW I noted the numbering stops at 100. After that any file with the same name overwrites the  original/actual file name. So not only is the behavior not very user friendly it also isn't implemented consistent.

Comment 31 by rdsmith@chromium.org, Jan 15 2013

We stop auto-downloading at 100; after that we figure that there's something weird going on and prompt the user for where to put the file.  If that's not the behavior you're seeing, please file a (different) bug with repro instructions.

The plan for supporting this use case is sketched out in c#12.  The first part of that (providing an extension API that allows for creating extensions specifying the file name) is in progress, though the extension API is still restricted to dev channel.  But it'll probably be moving to beta and then stable over the next couple of months.  The second part of that (snapping a download to a previously existing file) is still something I'd like to see happen, but we don't have immediate plans.  

We are not going to provide an option in Chrome to simply overwrite the file.  One of Chrome's primary goals is simplicity, and as a result we try to keep the number of tweakable options to an absolute minimum.  Generally we try to allow people to modify functionality through extension APIs (as we are here).

Comment 32 by aver...@gmail.com, Jan 15 2013

Yes, I've heard the "simplicity" mantra already.  I'm not happy it's being used to defend a poor design decision made long ago.  People expect an overwrite prompt if the file exists just like almost every other program out there does.

Unfortunately there are some people who like or are use to this behaviour and simply changing it would bring out a chorus of "change it back" reports.  That's why we're asking for a config option.  It doesn't have to be in the main config.  It could be buried somewhere where only advanced users could change it.

What is the point of the second section of c#12?  I don't see a need for snapping or download history searching or not downloading because it was downloaded already.  It's a very simple algorithm that all other programs use:

1) Pop up the usual dialog with the filename from the server and save and cancel buttons.
2) If cancel pressed, abort download.
2) If save pressed, does the filename already exist in the current download directory?
3) No, save the file.
4) Yes, pop up a prompt to overwrite with overwrite and no buttons.
5) No was pressed, go back to step 1.
6) Yes was pressed, save the file.

As you can see, the download history has nothing to do with that algorithm.  Nor is the fact that it's from the same source and is newer.  That's because we are NOT asking for overwriting the file automatically.  The user must be asked to overwrite the file.

Comment 33 by samecool...@gmail.com, Feb 11 2013

It is completely reasonable to expect an overwrite prompt for a duplicate download. This is the ordinary behaviour of almost every other application that can have this behaviour.

What kind of bizarre definition of "simple" are you using that implicates acting in a manner contrary to the intuition of every user. I think the phrase "counter intuitive" would be more apt.

Please put this right

Comment 34 by rdsmith@chromium.org, Feb 11 2013

Mergedinto: 157225
Status: Duplicate

Comment 35 by Deleted ...@, Feb 21 2013

i just wonder why the duplicate number file and not overwritting !! its so simple and i think chrome can fix it if they really want .......

its so annoying when you deal with large file system i don't want to do it manually cause it end up with disasters when the files are so close in names, and another thing removing the duplicate number manually = more mistakes to happen...

we just need an answer if you can fix it or not?

Comment 36 by Deleted ...@, Feb 28 2013

Vote for it! It's soooooooooooo simple and useful. I got literally tons of new versions of the same file downloaded by chrome.

Could it be addressed by an extension? I doubt extension has access to local files :(

Comment 37 by samjs...@gmail.com, Mar 1 2013

I have to download a Citrix ICA Connection file every time I open an application for my web-based accounting software.   Currently, Chrome will automatically download 100 of these files and number them before it stops and requires action.  I then have to go into my downloads and delete the 101 files so that the process can start over again.  I have to do this every 10-20 or so days because I will typically open 5-10 or so applications per day/session.  The corrections described elsewhere in this thread allowing for the files to be overwritten would solve this problem that doesn't exist if I were to use IE or FF.

Comment 38 by bugdroid1@chromium.org, Mar 3 2013

Project Member
The following revision refers to this bug:
    http://src.chromium.org/viewvc/chrome?view=rev&revision=185811

------------------------------------------------------------------------
r185811 | benjhayden@chromium.org | 2013-03-03T21:57:57.449192Z

Changed paths:
   M http://src.chromium.org/viewvc/chrome/trunk/src/chrome/common/extensions/permissions/permission_set_unittest.cc?r1=185811&r2=185810&pathrev=185811
   M http://src.chromium.org/viewvc/chrome/trunk/src/chrome/renderer/resources/renderer_resources.grd?r1=185811&r2=185810&pathrev=185811
   M http://src.chromium.org/viewvc/chrome/trunk/src/chrome/browser/extensions/api/downloads/downloads_api_unittest.cc?r1=185811&r2=185810&pathrev=185811
   M http://src.chromium.org/viewvc/chrome/trunk/src/chrome/browser/extensions/api/downloads/downloads_api.cc?r1=185811&r2=185810&pathrev=185811
   A http://src.chromium.org/viewvc/chrome/trunk/src/chrome/common/extensions/api/downloads_internal.idl?r1=185811&r2=185810&pathrev=185811
   M http://src.chromium.org/viewvc/chrome/trunk/src/chrome/browser/extensions/extension_function_histogram_value.h?r1=185811&r2=185810&pathrev=185811
   M http://src.chromium.org/viewvc/chrome/trunk/src/chrome/browser/download/download_service.cc?r1=185811&r2=185810&pathrev=185811
   M http://src.chromium.org/viewvc/chrome/trunk/src/chrome/common/extensions/permissions/api_permission.cc?r1=185811&r2=185810&pathrev=185811
   M http://src.chromium.org/viewvc/chrome/trunk/src/chrome/common/extensions/api/api.gyp?r1=185811&r2=185810&pathrev=185811
   M http://src.chromium.org/viewvc/chrome/trunk/src/chrome/browser/download/download_service.h?r1=185811&r2=185810&pathrev=185811
   M http://src.chromium.org/viewvc/chrome/trunk/src/WATCHLISTS?r1=185811&r2=185810&pathrev=185811
   M http://src.chromium.org/viewvc/chrome/trunk/src/chrome/browser/download/chrome_download_manager_delegate.h?r1=185811&r2=185810&pathrev=185811
   M http://src.chromium.org/viewvc/chrome/trunk/src/chrome/common/extensions/permissions/api_permission.h?r1=185811&r2=185810&pathrev=185811
   M http://src.chromium.org/viewvc/chrome/trunk/src/chrome/browser/extensions/event_names.cc?r1=185811&r2=185810&pathrev=185811
   A http://src.chromium.org/viewvc/chrome/trunk/src/chrome/test/data/extensions/api_test/downloads_spanning?r1=185811&r2=185810&pathrev=185811
   A http://src.chromium.org/viewvc/chrome/trunk/src/chrome/browser/extensions/api/downloads_internal/downloads_internal_api.h?r1=185811&r2=185810&pathrev=185811
   A http://src.chromium.org/viewvc/chrome/trunk/src/chrome/test/data/extensions/api_test/downloads_spanning/empty.html?r1=185811&r2=185810&pathrev=185811
   M http://src.chromium.org/viewvc/chrome/trunk/src/chrome/common/extensions/permissions/permission_set.cc?r1=185811&r2=185810&pathrev=185811
   A http://src.chromium.org/viewvc/chrome/trunk/src/chrome/renderer/resources/extensions/downloads_custom_bindings.js?r1=185811&r2=185810&pathrev=185811
   M http://src.chromium.org/viewvc/chrome/trunk/src/chrome/browser/extensions/api/downloads/downloads_api.h?r1=185811&r2=185810&pathrev=185811
   A http://src.chromium.org/viewvc/chrome/trunk/src/chrome/common/extensions/docs/examples/api/downloads/downloads_overwrite?r1=185811&r2=185810&pathrev=185811
   M http://src.chromium.org/viewvc/chrome/trunk/src/chrome/common/extensions/api/downloads.idl?r1=185811&r2=185810&pathrev=185811
   A http://src.chromium.org/viewvc/chrome/trunk/src/chrome/common/extensions/docs/examples/api/downloads/downloads_overwrite/bg.js?r1=185811&r2=185810&pathrev=185811
   A http://src.chromium.org/viewvc/chrome/trunk/src/chrome/test/data/extensions/api_test/downloads_spanning/manifest.json?r1=185811&r2=185810&pathrev=185811
   M http://src.chromium.org/viewvc/chrome/trunk/src/chrome/chrome_browser_extensions.gypi?r1=185811&r2=185810&pathrev=185811
   M http://src.chromium.org/viewvc/chrome/trunk/src/chrome/browser/download/chrome_download_manager_delegate.cc?r1=185811&r2=185810&pathrev=185811
   M http://src.chromium.org/viewvc/chrome/trunk/src/chrome/renderer/resources/extensions/event.js?r1=185811&r2=185810&pathrev=185811
   M http://src.chromium.org/viewvc/chrome/trunk/src/chrome/browser/extensions/event_names.h?r1=185811&r2=185810&pathrev=185811
   A http://src.chromium.org/viewvc/chrome/trunk/src/chrome/common/extensions/docs/examples/api/downloads/downloads_overwrite/manifest.json?r1=185811&r2=185810&pathrev=185811
   M http://src.chromium.org/viewvc/chrome/trunk/src/chrome/renderer/extensions/dispatcher.cc?r1=185811&r2=185810&pathrev=185811
   A http://src.chromium.org/viewvc/chrome/trunk/src/chrome/browser/extensions/api/downloads_internal?r1=185811&r2=185810&pathrev=185811
   M http://src.chromium.org/viewvc/chrome/trunk/src/chrome/test/data/extensions/api_test/downloads_split/manifest.json?r1=185811&r2=185810&pathrev=185811
   M http://src.chromium.org/viewvc/chrome/trunk/src/chrome/browser/extensions/api/web_request/web_request_api.cc?r1=185811&r2=185810&pathrev=185811
   A http://src.chromium.org/viewvc/chrome/trunk/src/chrome/browser/extensions/api/downloads_internal/downloads_internal_api.cc?r1=185811&r2=185810&pathrev=185811
   M http://src.chromium.org/viewvc/chrome/trunk/src/tools/json_schema_compiler/idl_schema.py?r1=185811&r2=185810&pathrev=185811
   M http://src.chromium.org/viewvc/chrome/trunk/src/chrome/renderer/resources/extensions/web_request_custom_bindings.js?r1=185811&r2=185810&pathrev=185811

Implement chrome.downloads.onDeterminingFilename() to allow extensions to participate in the download filename determination process.

Docs staged: http://basho.cam.corp.google.com:8000/extensions/downloads.html#event-onDeterminingFilename

Example:
chrome.downloads.onDeterminingFilename.addListener(function(item, suggest) {
  suggest({filename: item.filename, overwrite: true});
});
chrome.downloads.onDeterminingFilename.addListener(function(item, suggest) {
  window.setTimeout(function() {
    suggest({filename: item.mime.split('/')[0] + '/' + item.filename, overwrite: false});
  }, 1);
  return true;  // handling asynchronously
});

BUG= 12133 
BUG= 68108 

Review URL: https://chromiumcodereview.appspot.com/11574006
------------------------------------------------------------------------

Comment 39 by msampso...@gmail.com, Mar 4 2013

Oh my god, are they about to implement this feature?!  I guess three years isn't too long a wait. :)

Comment 40 by bugdroid1@chromium.org, Mar 11 2013

Project Member
Labels: -Area-UI -Feature-Downloads Cr-UI-Browser-Downloads Cr-UI

Comment 41 by Deleted ...@, Mar 17 2013

It would be great if chrome could check whether the previous file is same file and doesn't download it in that case.

Comment 42 by Deleted ...@, Mar 28 2013

I'm running Version 26.0.1410.43 m on a Windows 7 PC.  I'd like the fix to this issue, how do I get it?

Comment 43 by Deleted ...@, Apr 2 2013

Pretty sad that I read through this to see repeated pushes by the devs that this feature found in 99% of other programs, is something other than simple and commonplace.

I can't think of any program I've EVER used, that simply decides it's going to auto-rename a file it's saving. Even Windows Explorer prompts you and provides you with options!

Anything else is counter-intuitive, and stating otherwise is just, well ignorant of what users actually expect to encounter. Anyone expecting to encounter the current behavior, must use nothing but Chrome on a daily basis and hasn't used a computer prior to Chrome being available...

Comment 44 by mafia...@gmail.com, Apr 3 2013

Just thought I'd throw my two cents in, but I think we're over-complicating this fix by positing the idea of an additional dialog box.  Instead, why not simply implement a system-wide setting that changes the auto-rename parameter from 100 to 0, so that way if users don't like this functionality they can disable it from occurring by default?

I'm not sure if the variable works like that, but there should be simple system option to either enable or disable this functionality.

Comment 45 by Deleted ...@, Apr 8 2013

I was pretty aggrevated when this "feature" suddenly popped up.  I had chrome auto-update disabled and in a moment of insanity I let it update.  Easily this is the most loathed new behaviour to Chrome in recent memory.

I have generally felt that big company up in Redmond, Washington, should offer an "Expert User" setting, somewhere in the OS, so when I'm about to overwrite a file, IT JUST DOES IT.  I truly despise being second guessed all the time.  Yeah, I really do always mean to overwrite a file that's why I didn't select "Save As" but "Save"  at least ^S works in many apps to just Save.

With Chrome I'm hit twice, save filename(1).zip, no, change to filename.zip, Do you want to overwrite filename.zip?!??!?!?   Dang.  Talk about nanny coding everything.

Comment 46 by paul.gro...@gmail.com, Aug 20 2013

I'm not sure how far this has been investigated, but I too feel like this should be worked upon. I'm relatively new with Chrome, and it's an irritating experience to go through and remove (1) from the file that I want to overwrite. That along with duplicate files will often result in more hard drive space taken up. Just imagine for a moment if you will, someone downloads... say...

Multiple install files of Autodesk 3DS Max (assuming worst case scenario). It's not convenient to be downloading multiple copies and sucking up 5-20~GB space due to a completely rookie computer user failing to see that it's been downloaded before. The result, swift hard drive space consumption and potential instability.

See this through my eyes, and I promise you, you'll see quite a risk in this.

Comment 47 by Deleted ...@, Aug 20 2013

Just to add another voice, renaming a file being downloaded without telling the user seems to be counter to what would be the expected behavior. Plus the problems it causes when you get to version 100 of the file, causes additional confusion. In a web application that I have, users continually create a pdf version of a document which is downloaded to them. When it eventually gets to version 100, they are at a loss as to what to do. Having to instruct them to go to the downloads folder and deleting all the previous versions is not a good thing to have to do. Chrome has otherwise been an excellent browser for my application, but this is a serious issue.

Comment 48 Deleted

Comment 49 by Deleted ...@, Aug 20 2013

Let's face it: this issue is open for almost 3 years. Google doesn't care about reasoning nor logic. They might as well put a big finger on this page. We are wasting our time.

Comment 50 by Deleted ...@, Aug 23 2013

Well I started using Chrome because Firefox was acting screwy, but if I can't get that prompt when I download something, I'll figure out what went wrong with Firefox and fix that.  

It's that important.

Comment 51 by Deleted ...@, Oct 3 2013

The fact that this feature is yet to be implemented is a disgrace.
this numbering things is so annoying!!

Comment 52 by Deleted ...@, Oct 24 2013

Why don't you just confirm if you want the file overwritten like IE.  The software I use all day long requires me to download the same file name after I export settings.  It is annoying to constantly remove the (x) numbering from the file name.  Who seriously thinks ..... oh good I have the last 30 versions of the file to dig through and figure out which one I really need?

Comment 53 by Deleted ...@, Nov 11 2013

Yes I agree. It doesnt download latest file and overwrite it. I am a user and I want to  run new latest file with same name but it doesnt downloads it and when i run it it is running old file. Why can't google fix such a simple issue? Most of other browsers supports this functionality.

Comment 54 by zantol...@hotmail.com, Nov 19 2013

this is the first time i've used chrome, and it is one of the biggest disappointments that i have with it, i download LOTS and i don't want to keep on looking for copy when i can just overwrite.

Comment 55 by Deleted ...@, Nov 20 2013

This issue affects me and I would very much like to see it changed.

Comment 56 by jameskwi...@gmail.com, Nov 22 2013

Hi Father Google, 

It has been almost a year since my last comment...for some reason I asked to be emailed on this issue.  I guess my hopes were that it would be fixed, and I thought it would be kinda cool to feel like I was part of the group that pushed to get it to happen.  My recent most recent reaction to what is now my 30th email since said comment (#25), was to once again look into this issue and see if it was fixed.  All that I discovered was that there is actually a bug that won't let you even overwrite files at all.  Why is Google so hell-bent on forcing us to append EVERYTHING WITH NUMBERS.  Just remove whatever coding you added to force that option, and voila...fixed.  Make it a toggle click and everyone in the world that you are taking over is happy.  Trust me, when you take over the world...the last thing you want is to have unhappy slaves.  Please just fix this already.  I don't even know that I'll switch back to Firefox, but I would just end up Googling "Top places to hide when Google takes over the world"...so you would know what I was up to regardless.

Side note from rant...just realized google is underlined red and recommended to be changed to Google...reminds me of the whole god God ...omg god isn't underlined...real-time realizatoins...haha. I'm honestly pretty anti-religion but The Beatles said they were bigger than Jesus once, and now half of them are dead.  And Google was a word before you existed...You are very full of yourself google...there is an important lesson to learn somewhere in all this, and I found it for you.  Here, I binged you plenty of options:

http://www.bing.com/search?q=story+of+icarus&go=&qs=n&form=QBLH&pq=story+of+icarus&sc=8-13&sp=-1&sk=&cvid=189f3dc7c5c64cf4853edc8a866fe778   

Also, if you are hiring...I need a job, and I would be way down to learn how to program if it meant that I could come and work for google and fix this.

Comment 57 Deleted

Comment 58 by ghostyki...@gmail.com, Dec 3 2013

-send document to self, from first computer, via email to open it on second computer
-open document on second computer and save to second computer
-work on document on second computer
-save edited version of document on second computer
-send document, from second computer, via email to open it on first computer
-attempt to overwrite the old document from first computer with edited document from second computer
...
chrome-blocked

This is especially irritating when I send myself a large number of files or need to send the same file back and forth between computers.

To clarify, neither of the two computers is portable and both exist at different locations (e.g.: work & home).

I like Google Chrome, but I generally expect it to have more functionality than internet explorer. However, internet explorer will give the user a nice prompt when the user attempts to save a file that shares the name of a file in the same folder.

How many people do you think decide to turn back to internet explorer because they cannot find a way to disable the (N) feature?

internet browsers are like leaders:
when a leader fails to govern its people, it is deposed and replaced with another leader
when a browser fails to accommodate the simple feature requests of its users, it is ignored and replaced by another browser

do not be the failed browser

seriously, we just want a button in the settings menu

Comment 59 by Deleted ...@, Dec 4 2013

this should be able to be toggled off.  the fact that there are this many complaints should let you know there are thousands of people like myself, who have been upset about this for a while, but didn't know there was a place to complain or affect change. 

most people won't find this place and will suffer in silence, but I suppose since the devs are unwilling to do anything, they, like myself up until today, believe rightfully that there is nothing they can do about it, so just deal with it.

Comment 60 by samecool...@gmail.com, Dec 5 2013

Dear Saint Google,

Inspired by James's post, I'd like to update you on the situation here.

Well, as it transpires, obviously, you haven't fixed the issue. So the situation here is just as dire as it was in February.

I can't help suspect you are hoping this will just go away. That if you leave it long enough you can reasonably claim "oh well, we can't change it now, people are used to our broken functionality, so we have to leave it that way".

Or perhaps your mentality is, like a baby realizing his ego for the first time "Me Google, Google want download number, Google want download number. Google have download number. Waaah, waaah. Google made a number 2." ?

Excuse the blithe analogy, but I had indeed expected a little more maturity from a company of your calibre. Evidently not, hence the expression of my exasperation in terms perhaps more endearing to your temperament.

So please big baby Google, cast your blubbery eyes away from the crib's mobile and look us users in the eyes for a second. Listen to reason. You can go back to playing with your dummy in a minute. Implement this simple fix and help daddy out.

staropram

Comment 61 by Deleted ...@, Jan 20 2014

Please for the love of God fix this already

Comment 62 by wmcdan2...@gmail.com, Jan 24 2014

I'm not sure why this got merged into the other topic, because the other suggestion is completely different.

We're asking for a simple option in the settings - if we try to download the same file, let the user choose the behavior.

I'm sure some people like adding the (x) after the file - I found one thread where the poster was complaining that it only went to 100 and he wanted to download hundreds of files with the same name and get a unique name for each.

I am not that person, and I don't like this behavior.  I frequently have to download files which have to be named the same thing for the automation process to work, but contain different data. It's a time waster for me to see that Chrome downloaded File(1), because I have to go rename the file, or download it again and change the name.

Please just give us an option in settings to choose how we want to handle downloading a file that already exists.  It should be pretty easy to give us three options
1. Silently overwrite
2. Prompt for overwrite
3. Rename file automatically

Comment 63 by benjhayden@chromium.org, Jan 24 2014

Labels: Restrict-AddIssueComment-EditIssue
I have already implemented the option to overwrite either silently or with a prompt as an extension.
http://src.chromium.org/viewvc/chrome/trunk/src/chrome/common/extensions/docs/examples/api/downloads/downloads_overwrite/
I'll upload it to the webstore and link it here.

Unfortunately, we cannot implement this as an option in chrome itself. Whether the simplicity argument convinces you or not, the chromium project leaders are convinced.

Issue 157225 is different from the overwrite option, but closely related to it. Chrome could silently overwrite files without an option if the old file and the new are the same. This is something that we can do in chrome, and it would alleviate some of the need for the overwrite option.

Comment 65 by mattm@chromium.org, Oct 13 2015

 Issue 542567  has been merged into this issue.

Sign in to add a comment