New issue
Advanced search Search tips
Note: Color blocks (like or ) mean that a user may not be available. Tooltip shows the reason.
Starred by 1 user
Status: WontFix
Owner: ----
Closed: Jan 2017
Cc:
Components:
EstimatedDays: ----
NextAction: 2017-01-09
OS: Mac
Pri: 2
Type: Bug



Sign in to add a comment
CSS Hyphens: The last word of a text is not hyphenated
Reported by bra...@bram.us, Dec 24 2016 Back to list
UserAgent: Mozilla/5.0 (Macintosh; Intel Mac OS X 10_12_2) AppleWebKit/537.36 (KHTML, like Gecko) Chrome/55.0.2883.95 Safari/537.36

Example URL:
http://codepen.io/bramus/full/pNBXWW/

Steps to reproduce the problem:
1. Create an element with very long words in it
2. Limit the width of the box via CSS
3. Apply "hyphens: auto" via CSS on the box

What is the expected behavior?
All words that exceed the width of the box should be hyphenated.

What went wrong?
All lengthy words, except for the last one, are hyphenated.

Does it occur on multiple sites: Yes

Is it a problem with a plugin? No 

Did this work before? N/A 

Does this work in other browsers? Yes

Chrome version: 55.0.2883.95  Channel: stable
OS Version: OS X 10.12.2
Flash Version: 

Demo URL: http://codepen.io/bramus/full/pNBXWW/ (scroll down to “Long \w strings”)
 
Screen Shot 2016-12-24 at 17.28.15.png
139 KB View Download
Components: -Blink Blink>Layout
Labels: Needs-Feedback
NextAction: 2017-01-09
I can't reproduce this on MacBook, Chrome 56.0.2924.28 beta or Chrome Version 57.0.2957.0 (Official Build) canary (64-bit). It might have been fixed. Could you please try one of these versions and verify the behavior.

Also, on the example site the emoji line is not hyphenated. Is that what you see?
This was probably fixed in  issue 671125 .
Comment 3 by bra...@bram.us, Dec 28 2016
Just checked it with Canary 57.0.2965.0, and verified as fixed: the last word is hyphenated.
Cc: kavvaru@chromium.org
Labels: -Needs-Feedback
Status: WontFix
Thanks for the update.
Closing this issue as per the comment #3.

bramus@Please feel free to raise a new issue if you face any issue on chrome.

Thanks,
Sign in to add a comment