New issue
Advanced search Search tips

Issue 66553 link

Starred by 2 users

Issue metadata

Status: Duplicate
Merged: issue 40787
Owner: ----
Closed: Dec 2010
EstimatedDays: ----
NextAction: ----
OS: Linux
Pri: 2
Type: Bug

Restricted
  • Only users with Commit permission may comment.



Sign in to add a comment

Pyjamas HelloWorld! fails from Unsafe JavaScript access

Reported by theprope...@gtempaccount.com, Dec 11 2010

Issue description

Chrome Version (from the about:version page): 8.0.552.215 (Official Build 67652)
Is this the most recent version: Yes
OS + version: Ubuntu 10.10 + 8.0.552.215 (Official Build 67652)
CPU architecture (32-bit / 64-bit): 64-bit Desktop
Window manager: Gnome
URLs (if relevant):
Behavior in Linux Firefox: Works correctly
Behavior in Windows Chrome (if you have access to it):

What steps will reproduce the problem?
1. Install pyjamas via apt-get.
2. Download the pyjamas source from SourceForge (we want the examples).
3. When in the base directory of pyjamas set python path in bash by typing:
export PYTHONPATH=`pwd`
4. In .../pyjamas/examples/helloworld/ issue the command:
pyjsbuild Hello.py
This will create a directory called output.
5. Both from the command line, and from the URL entry textbox in chrome navigate to .../pyjamas/examples/helloworld/output/Hello.html

What is the expected result?
A garish set of green buttons that when clicked do incredibly simple things.

What happens instead?
A white page stating: "some text demonstrating static HTML here." The text should be there, it's there in firefox, but nothing else is there...

Please provide any additional information below. Attach a screenshot
and backtrace if possible.
In the javascript console in Chrome I see the following error:
Unsafe JavaScript attempt to access frame with URL file:///home/*USER*/sandbox/pyjamas/examples/helloworld/output/Hello.html from frame with URL file:///home/*USER*/sandbox/pyjamas/examples/helloworld/output/Hello.nocache.html. Domains, protocols and ports must match.

 

Comment 1 by temp01...@gmail.com, Dec 11 2010

Mergedinto: 40787
Status: Duplicate
This is a duplicate of  issue 40787 . See 60867 for details.
Project Member

Comment 2 by bugdroid1@chromium.org, Oct 12 2012

Labels: Restrict-AddIssueComment-Commit
Mergedinto: chromium:40787
This issue has been closed for some time. No one will pay attention to new comments.
If you are seeing this bug or have new data, please click New Issue to start a new bug.
Project Member

Comment 3 by bugdroid1@chromium.org, Mar 11 2013

Labels: -Area-Undefined

Sign in to add a comment