Project: chromium Issues People Development process History Sign in
New issue
Advanced search Search tips
Note: Color blocks (like or ) mean that a user may not be available. Tooltip shows the reason.
Starred by 239 users
Status: Available
Merged: issue 152430
Owner: ----
Cc:
Components:
EstimatedDays: ----
NextAction: 2017-09-30
OS: All
Pri: 3
Type: Feature

Blocked on: View detail
issue 591099
issue 726125

Blocking:
issue 463348


Participants' hotlists:
Top-Starred-Bugs

Show other hotlists

Other hotlists containing this issue:
test


Sign in to add a comment
Missing MathML implementation
Reported by krivan.b...@gmail.com, Jan 17 2009 Back to list
Chrome Version       : 2.0.157.2
URL                  : http://www.w3.org/Math/testsuite/mml2-
testsuite/TortureTests/Complexity/complex1.xml
Other browsers tested:
    Firefox 3: OK
         IE 7: OK (MathPlayer)

What steps will reproduce the problem?
1. Open a page with MathML content

What is the expected result?
You should see the correct MathML rendering.

What happens instead?
You see just a few symbol without correct rendering.

 
ie7.png
23.5 KB View Download
firefox.png
32.1 KB View Download
chrome.png
21.3 KB View Download
Labels: -Area-Misc Area-WebKit Webkit-Specific Report-to-Webkit
Status: Untriaged
Safari 3.2: not ok

Labels: -Report-to-Webkit Reported-to-Webkit
Status: Upstream
Bug filed upstream : https://bugs.webkit.org/show_bug.cgi?id=24127
Comment 3 by dhh...@gmail.com, Mar 19 2009
Webkit  bug 24127  has been duplicated to https://bugs.webkit.org/show_bug.cgi?id=3251
 Issue 9230  has been merged into this issue.
This is a bug for almost 4 years in webkit. Can't you, chromium guys, implement this?
Because I don't think they're really working on this @ webkit. And I think it's a
really needed feature in Chromium.

Reading the thread @ bugs.wekbit.org, we could do something like this: mathml to svg.
And SVG could be displayed correctly.

Thanks for reading!
Comment 6 by jon@chromium.org, Jul 20 2009
Labels: -Type-Bug Type-Feature Mstone-X
I'm using Chromium to use Google Wave preview (it feels faster and more stable than 
with firefox). But I started using Google wave for Collaborate on Math stuff. There is 
nice robots there for rendering LaTeX as mathML. Too bad the MathML rendering is so 
poor on Chromium....
Comment 8 by evan@chromium.org, Aug 6 2010
Status: ExternalDependency
This is now enabled in WebKit, should be turned on in Chromium builds as well.
Comment 10 by peter@chromium.org, Oct 20 2010
Status: Untriaged
Considering this no longer is dependent on an external dependency, seeing WebKit enabled it by default, I'm removing the label and moving this back to untriaged.

The following thread on chromium-dev is relevant to this issue:

http://groups.google.com/a/chromium.org/group/chromium-dev/browse_thread/thread/b926b2068277aa97/276d5c2345067fec?lnk=gst
Comment 11 by Deleted ...@, Dec 21 2010
Opera 11 is OK.
Comment 12 by szhor...@gmail.com, Dec 21 2010
Well, to be honest, Opera's MathML implementation is quite broken and cannot handle diacritics properly.  It is unsuitable for real world applications (tried to use it for my class notes, for which IE/MathPlayer & Firefox worked fine)
Comment 13 by kareng@google.com, May 13 2011
Status: Available
 Issue 84491  has been merged into this issue.
Cc: tmc...@chromium.org
Labels: Review-Security
Given that Safari 5.1 now supports MathML, I believe we should look into implementing this. Allegedly one of the reasons it hasn't been already is that it has not had a security audit. Marked it for review.
Cc: jsc...@chromium.org
Labels: -Review-Security
@rschoen - If someone wants to take ownership of landing MathML then they can file a feature metabug and work through any changes needed to land it (including what I would anticipate to be a large number of security crashes). However, unless someone antes up for the work it's not going to happen on its own.
Comment 18 Deleted
Comment 19 Deleted
Blocking: 22554
Comment 21 by papal...@gmail.com, Jan 16 2012
So this bug seems to be just about enabling MathML parsing from comment 9 onward, but for displaying MathML you might – depending on the platform targeted – also need to think about font support, i.e. about whether you will ship with the STIX/XITS fonts on e.g. Windows (BTW which are now included in OS X 10.7 because of Safari's MathML support I would guess).
Comment 22 by tkent@chromium.org, Feb 27 2012
 Issue 115809  has been merged into this issue.
Comment 23 by nrb...@gmail.com, Apr 21 2012
It's 2012 not 1999.

Chrome 20.0.1105.0 (Official Build 132547) dev fails the Mozilla MathML test (http://www.mozilla.org/projects/mathml/demo/texvsmml.html)
I cannot believe this.

Google accepts 2 projects for the Google Summer of Code 2012 for improving MathML support in Firefox (https://developer.mozilla.org/en/Mozilla_MathML_Project)
but still does'nt implement MathML at all in their own Browser Chrome.
Comment 25 Deleted
I explained on comment #17 what's preventing MathML from being enabled. Simply put, someone needs to take ownership of the feature and get it to a state where it's demonstrated stable and safe enough to ship.
Concerning comment #17, does the remark about potentially "a large number of security crashes" still have any validity whatsoever? Does Apple do that much less testing of the code they use than Google? Not to mention that the MathML code is out in open  for a year now.
Are you volunteering and do you have the necessary expertise to do the work? If not, I don't see that your comments are contributing anything useful at this stage. We have an obligation to our users to meet a minimum bar before enabling a feature. No amount of complaining on this bug is a substitute for meeting that obligation.
Comment 29 by fred.w...@free.fr, Apr 28 2012
FYI, Dave Barton is working on Webkit's MathML implementation and is concentrating his effort on fixing the most important bugs that could prevent passing security review. People who are really interested in seeing this bug fixed should follow his work on Webkit's bugzilla and possibly help him.

about comment 24: the two MathML projects mentioned were just proposals from Mozilla. Finally one student was accepted (for a different MathML project).
Comment 30 by dhw@chromium.org, Oct 2 2012
 Issue 61672  has been merged into this issue.
Comment 31 by dhw@chromium.org, Oct 25 2012
Blocking: -chromium:22554
Comment 32 by dhw@chromium.org, Oct 25 2012
Mergedinto: 152430
Status: Duplicate
Marking as duplicate of newer  Issue 152430 
Project Member Comment 33 by bugdroid1@chromium.org, Mar 11 2013
Labels: -Area-WebKit Cr-Content
Project Member Comment 34 by bugdroid1@chromium.org, Apr 6 2013
Labels: -Cr-Content Cr-Blink
Comment 35 by tkent@chromium.org, Dec 12 2016
Components: -Blink Blink>Layout
Labels: -Reported-to-Webkit -Pri-2 -Mstone-X mstone-X Reported-To-WebKit Pri-3
Status: Available
Reopen.   Issue 152430  isn't a feature request.

Comment 36 by nadav...@gmail.com, Dec 12 2016
Google, please make an effort to fix this.

Comment 37 Deleted
Comment 38 by papal...@gmail.com, Dec 12 2016
The previously heavily criticized Webkit implementation has improved quite a lot since 2013: https://webkit.org/blog/6803/improvements-in-mathml-rendering/

Thanks goes out to Frédéric Wang and the other people working on it or arguing for it, I hope Blink will be their next target (and once Blink has MathML, has Microsoft will have to follow suit now that they made it an official stance that Edge has to be on-par with Chrome + they probably need it for better EPUB support).
Blocking: 463348
Comment 40 by sors...@gmail.com, Dec 12 2016
Please add this! This would revolutionize my daily mathematical life on the Internet!
Cc: -jsc...@chromium.org
I join Chrome users in urging Google to advance MathML technology in order to promote universal access to scientific knowledge. Thank you.
Please "star" this issue to vote for it, rather than leaving a comment. The star button is located at the top of the page, next to the "Issue" text.
As mentioned, the current WebKit MathML implementation is vastly different from the one which was removed from Blink circa 2013. For an overview of the changes, see

http://frederic-wang.fr/mathml-refactoring-in-webkit.html
http://frederic-wang.fr/mathml-improvements-in-webkit.html

Hopefully, this refactoring addresses the technical objections to the previous MathML implementation.

On the user-experience side, it cannot be emphasized enough that the proposed "alternative" to a native MathML implementation (namely MathJax) provides a distinctly-inferior user experience. 
Cc: jsc...@chromium.org ojan@chromium.org
Ojan/Justin, thoughts on this bug after #44? Predictability program has set an OKR to gain traction on the top 50 starred bugs this quarter: either by closing them, stating what milestone the change will ship, or setting a NextAction date so that we know when to check back in.
Comment 46 by ojan@chromium.org, Jan 24 2017
Cc: e...@chromium.org ikilpatrick@chromium.org dk...@chromium.org
eae/ikilpatrick/dknox are the best people to express opinions on this now.
eae@, ikilpatrick@, dknox@, what are your thoughts here? Please note that this is the #8 top starred issue in Blink.
Comment 48 by e...@chromium.org, Feb 14 2017
It is something that we'd like to support eventually but only if it can be done in a maintainable and secure way.
Comment 49 by gel...@gmail.com, Feb 15 2017
#48 My view is that one can very close with plain CSS -- no javascript -- and it can only get better as CSS is developed further.  Implementation of CSS flexible boxes added quite a lot of value that, I think, was not available in 2011-2012.  In my talk at TUG 2014 I showed examples, e.g.,
http://www.albany.edu/~hammond/presentations/tug2014/gamma-lm.xml
of math rendering using only CSS (actually, a different XML markup, but Frederic Wang has written corresponding CSS for MathML). In the write-up of the talk for Tugboat I made comments about my wishes for the development of CSS.  Those ideas are NOT specific to the needs of math.
For more: http://www.albany.edu/~hammond/presentations/tug2014/

#49 how accessible is that XML? We rely on MathML for accessible (for users with disabilities using assistive tech) math, so students using AT are currently restricted to supporting browsers or whoever can run MathJax (which sometimes hangs/crashes pages with many complex equations (esp on phones) and does not accurately display some types of very complex equations, resulting in us rendering images of math (which don't scale) with a hidden MathML fallback as a sort of alt text).
I like the idea of being able to turn LaTeX into MathML/whatever and styled with CSS, so long as the whatever can read sensibly to screen readers and scales nicely with magnification. I don't think I can hope for speech support :(
The more browsers support math, the more choice our end-users have in which browser they can use to consume our content.
Comment 51 by mort...@gmail.com, Feb 15 2017
The suggestion to drop MathML has also surfaced on the Firefox dev forum. See this post which lists some good reasons to keep it/re-enable it.

https://groups.google.com/forum/m/#!msg/mozilla.dev.platform/96dZw1jXTvM/rIzKSrRgk18J
Comment 52 by gel...@gmail.com, Feb 15 2017
#51 Misleading.  That thread about firefox has not been touched since May 2013.  Certainly in #49 I did NOT suggest dropping MathML.
Comment 53 by gel...@gmail.com, Feb 15 2017
#50  "how accessible is that XML?"

AFAIK nothing has been done to tie it to access-related software.  The CSS provided with the example is entirely visual.  The idea with LaTeX profiles,
http://www.albany.edu/~hammond/presentations/Tug2010/, is that if a community with specific access concerns -- or other specialized concerns -- has its own ideal XML document type, it should be possible to provide reliable automatic translation from a LaTeX profile to that XML document type.
Personally, I think supporting a standard makes sense from an access point
of view, because then screen readers only have a single standard to
implement, and don't have to work around workarounds that people have put
in place.
While rendering MathML via CSS might work, it isn't the same as native
support. It also requires that one learns another library or language, or
use sometimes complicated hack to get it to do what you want. Supporting a
standard simplified the process and lowers the barrier to entry, whilst
simultaneously making sure that mathematical equations can be rendered
correctly in multiple places - without having to convert from one format to
another.

On 15 Feb 2017 3:18 am, "gel… via monorail" <monorail+v2.4120037860@
chromium.org> wrote:
#55, I don't see why you can't just use CSS to fully-support the standard.
Comment 57 Deleted
Cc: -jsc...@chromium.org
#57 ah I see, you need the editor. If it was just about meaning, CSS could
still do that, but yeah you need native support for a MathML editor
Labels: -Webkit-Specific -mstone-X -Reported-To-WebKit
eae@ We're trying to understand the plan for all top-starred bugs.  When you say "done in a maintainable way", are you implying that this is perhaps blocked on LayoutNG (or maybe custom layout)?

I'm just hoping that we can mark this bug blocked on some other work and set a Next-Action date for when we should check back in on that work.
Blockedon: 591099 726125
We (layout team and igalia) have a tentative plan to build a MathML implementation on top of LayoutNG and Custom Layout. I've marked this as blocked on CSS Custom Layout and LayoutNG.
NextAction: 2017-09-30
Great, thanks!  I know LayoutNG is a big project, so setting next-action to the end of Q3 to trigger check-in for Q4.
The NextAction date has arrived: 2017-09-30
Sign in to add a comment