New issue
Advanced search Search tips
Starred by 1 user

Issue metadata

Status: Duplicate
Merged: issue 435727
Owner: ----
Closed: Sep 2016
Cc:
Components:
EstimatedDays: ----
NextAction: ----
OS: ----
Pri: 3
Type: Bug

Blocked on:
issue 643712

Blocking:
issue 651572



Sign in to add a comment
link

Issue 651748: 2 failing web-platform-tests for IndexedDB that pass in Firefox and Edge

Reported by foolip@chromium.org, Sep 30 2016 Project Member

Issue description

http://w3c-test.org/IndexedDB/interfaces.html
http://w3c-test.org/IndexedDB/transaction-lifetime-empty.html

These failures need analysis, but may point to low-hanging fruit for improving interop. Judgement is required, the failures may be entangled with spec issues.

See  issue 651572  for the source of this data, which includes failing subtests.

Note: Results may have changed in the interim.
 

Comment 1 by jsb...@chromium.org, Sep 30 2016

Blockedon: 643712
This is basically a dupe of issue 435727 but I appreciate the robo-filing. :)

Hrm, transaction-lifetime-empty.html passes in stable (53), and I don't think we regressed it. Any more details about the failure?

interfaces.html is good old issue 643712

Comment 2 by jsb...@chromium.org, Sep 30 2016

Cc: pwnall@chromium.org
https://docs.google.com/spreadsheets/d/1dIBAZwkuGy-H1AEk9pT1xF-pLb2Du8zZUnSRmrNdtj0/edit#gid=1409104618 says:

/IndexedDB/transaction-lifetime-empty.html	Multiple transactions without requests complete in the expected order	FAIL	PASS	PASS

Comment 3 by foolip@chromium.org, Sep 30 2016

Is that any clue, or is it still mysterious why this may have failed?

Comment 4 by jsb...@chromium.org, Sep 30 2016

This was fixed in 53 and we upstreamed the test at the same time, so since it was tested by jgraham before 53 hit stable it would have failed - mystery solved.

Comment 5 by foolip@chromium.org, Sep 30 2016

Mergedinto: 435727
Status: Duplicate (was: Untriaged)
Thanks, I think everything is accounted for then, so I'll dupe this.

Sign in to add a comment