New issue
Advanced search Search tips
Starred by 4 users

Issue metadata

Status: Duplicate
Merged: issue 633805
Owner: ----
Closed: Sep 2016
Cc:
Components:
EstimatedDays: ----
NextAction: ----
OS: Mac
Pri: 2
Type: Compat



Sign in to add a comment
link

Issue 649383: constant background-color differs across an element (MacOS 10.12)

Reported by br...@bryanbergman.com, Sep 22 2016

Issue description

UserAgent: Mozilla/5.0 (Macintosh; Intel Mac OS X 10_12_0) AppleWebKit/537.36 (KHTML, like Gecko) Chrome/53.0.2785.116 Safari/537.36

Example URL:

Steps to reproduce the problem:
Create a minimal HTML document with a few div elements, each with a height of 400px and a background-color of #aaa. Open in Chrome.

EXAMPLE:

<!doctype html>
<html>
    <head>
        <title>Bug</title>
    </head>
    <body style="margin: 0;">
		<div style="height: 400px; background-color: #aaa;"></div>
		<br>
		<div style="height: 400px; background-color: #aaa;"></div>
		<br>
		<div style="height: 400px; background-color: #aaa;"></div>
    </body>
</html>

What is the expected behavior?
The div elements should be colored with #aaa only.

What went wrong?
The div elements appear with both #a0a0a0 and rectangles of #aaa. How many rectangles and how large they are changes when margin is set to 0 on the body element. It also changes when the window is resized.

Does it occur on multiple sites: N/A

Is it a problem with a plugin? N/A 

Did this work before? Yes 

Does this work in other browsers? Yes 

Chrome version: 53.0.2785.116  Channel: stable
OS Version: OS X 10.12.0
Flash Version: Shockwave Flash 23.0 r0
 
Screen Shot 2016-09-22 at 9.58.03 AM.png
50.1 KB View Download

Comment 1 by shrike@chromium.org, Sep 22 2016

Components: Blink>CSS
Unable to reproduce in 53.0.2785.116. This is on my Retina machine, and I tried enabling things like Ganesh and experimental web technologies. Passing to blink team to see if they have any ideas. Also tried it in 53.0.2785.116 on my 10.12 non-Retina machine.

Attached is my test file.
sample.html
320 bytes View Download

Comment 2 by timloh@chromium.org, Sep 23 2016

Components: -Blink>CSS Blink>Paint

Comment 3 by m...@janhohner.de, Sep 23 2016

I do have the exact same issue on MacOS 10.12 with Chrome 53.0.2785.116. I use three screens in total, two external screens plugged into a 13" Retina Macbook, but the bug only appears on the external screens. The external screens show exactly what Bryan Bergmann's screenshot shows, but as soon as I move the window to the Macbook screen it shows correctly (see my attached screenshot).

Another interesting thing is: the bug is gone in 55.0.2868.3 canary (64-bit).
Bildschirmfoto 2016-09-23 um 08.08.28.png
488 KB View Download

Comment 4 by m...@janhohner.de, Sep 23 2016

I just tested this with one of the external screens on my Windows 10 machine with Chrome 53.0.2785.116 m (64-bit) and the bug does not appear there.

Comment 5 by m...@janhohner.de, Sep 23 2016

I just had a friend with an older version of MacOS (10.10.5) check this out on Chrome 53.0.2785.116 (64-bit) and he did not encounter this bug. Looks to me more and more like the combination of MacOS Sierra and Chrome 53 is the problem.

Comment 6 by schenney@chromium.org, Sep 23 2016

Cc: ccameron@chromium.org
Components: -Blink>Paint Internals>GPU
Labels: Needs-Feedback
Summary: constant background-color differs across an element (MacOS 10.12) (was: background-color producing more than one color)
me@, bryan@, could you please open up Developer Tools, find the "Rendering" tab and enable display of layer boundaries and tile boundaries. We would like to discover where the boundaries in the background are coming from.

This must be something related to color space correction, although why it is not uniform across the div is extremely bizarre to me. I'm sorry that it might take us a little while to fix this as we do not have many developers with MacOS 10.12 available. The fact it's fixed in M55 also suggests it's color space related.

It's unlikely this is paint related. We issue a single draw command for the entire background.

Comment 7 by m...@janhohner.de, Sep 23 2016

As soon as I enable layer borders the colour gets corrected, but I made a screenshot anyway. I hope this helps.
Bildschirmfoto 2016-09-23 um 17.05.31.png
23.8 KB View Download

Comment 8 by br...@bryanbergman.com, Sep 23 2016

Enabling layer borders produces the same result as m...@janhohner.de

FYI, I'm using an external monitor with a MacBook Air (13-inch, Mid 2013). The bug still appears on the device when I remove the external monitor.

Comment 9 by ccameron@chromium.org, Sep 28 2016

Cc: ericrk@chromium.org
Mergedinto: 633805
Status: Duplicate (was: Unconfirmed)
This looks the same as  issue 633805 . I haven't been able to reproduce it. Could be Sierra or color spaces or GPU raster related.

Sign in to add a comment