New issue
Advanced search Search tips
Starred by 3 users

Issue metadata

Status: Duplicate
Merged: issue 29427
Owner: ----
Closed: Nov 2010
EstimatedDays: ----
NextAction: ----
OS: ----
Pri: 2
Type: Bug

Restricted
  • Only users with Commit permission may comment.



Sign in to add a comment
link

Issue 64674: Inset shadow

Reported by digiw...@gmail.com, Nov 29 2010

Issue description

Chrome Version       : 8.0.552.28 (Official Build 64647) beta
URLs (if applicable) :
Other browsers tested:
Add OK or FAIL after other browsers where you have tested this issue:
    Chrome/Mac OS X: OK
     Safari 5: OK
  Firefox 3.x: OK
       IE 7/8: N/A

What steps will reproduce the problem?
1. Have an html element with both border-radius and a box-shadow with 'inset' defined.
2. View in chrome on windows 

What is the expected result?
Inset border should apply to the inner rounded area of the div. 

What happens instead?
On windows chrome only, a full rectangular box is shown behind the rounded corners in the color defined on the inset shadow.

Please provide any additional information below. Attach a screenshot if
possible.
 
mac-chrome-8.png
8.8 KB View Download
windows-chrome-8.jpg
5.8 KB View Download
inset-shadow-broken.zip
910 bytes Download

Comment 1 by paulir...@chromium.org, Nov 29 2010

Mergedinto: 29427
Status: Duplicate
Sadly a dupe of this nasty bug.


The best workaround.. and one that would work for this case would be to use border-image.
http://border-image.com will come in handy if you go that route.

Comment 2 by bugdroid1@chromium.org, Oct 12 2012

Project Member
Labels: Restrict-AddIssueComment-Commit
Mergedinto: chromium:29427
This issue has been closed for some time. No one will pay attention to new comments.
If you are seeing this bug or have new data, please click New Issue to start a new bug.

Comment 3 by bugdroid1@chromium.org, Mar 11 2013

Project Member
Labels: -Area-Undefined

Sign in to add a comment